locked
After hanging up a call, the call is placed on hold for about 10 seconds then dropped RRS feed

  • Question

  • We are working on integrating Lync with our phone system and have discovered that when a call is ended from Lync, it appears to go into Hold state for about 10 seconds before it is disconnected.  Using CUCM with Mobility, I can see my line appearance change from just being in use (while on Lync), to holding the call (after hanging up in Lync).

    If the outside party terminates the call, it is terminated immediately on our end.


    It worked for me.

    Tuesday, September 23, 2014 8:13 PM

Answers

All replies

  • This is somewhat typical behavior if you're using Cisco mobility and simultaneous ringing. If you change the call to a full forward so that the call goes direct from Cisco to Lync through the trunk avoiding mobility, and does not ring the Cisco phone, it should work without the unnecessary hold you're seeing. Cisco isn't fully letting go of the call with mobility, nothing much we can do on the Lync side.

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications


    • Edited by Anthony CaragolMVP Tuesday, September 23, 2014 10:58 PM
    • Marked as answer by one0 Wednesday, September 24, 2014 1:56 PM
    • Unmarked as answer by one0 Wednesday, September 24, 2014 2:44 PM
    Tuesday, September 23, 2014 10:57 PM
  • Going along Anthony's lines, I recently did an integration and ran into a very similar scenario, the call would be put on hold if it was within 20 seconds of being made, as Cisco would "wait" for your desk phone to be picked up when doing Mobility.

    The solution was to modify the Maximum Wait Time for Desk Pickup timer and set it to 0 for each End User that is configured for Mobility in CUCM.

    • Marked as answer by one0 Wednesday, September 24, 2014 2:44 PM
    Wednesday, September 24, 2014 2:19 PM
  • Thanks Gonzalo, that worked.  However, now it seems that Lync stops ringing about 5-10 seconds before the other Remote Destination and desk phone.  The Lync RD and other RD are configured exactly the same, except for having different destination numbers.

    In Lync, is there an equivalent of the Answer Too Late Timer that I can adjust?


    It worked for me.

    Wednesday, September 24, 2014 2:44 PM
  • Glad it worked! You can try adjusting your Call options from within your Lync client. By default, it'll ring for 20 seconds then go to voicemail (or just stop ringing).

    Try going to your Lync client options, then Call Forwarding, then change the timer in the setting for "Unanswered calls will go to"

    Good luck!

    Wednesday, September 24, 2014 3:29 PM
  • Is it possible to make this a global setting for everyone?

    It worked for me.

    Wednesday, September 24, 2014 4:57 PM
  • Unfortunately you can't set this as part of a User policy or Voice policy, it's a per-user configuration setting stored in a SQL DB somewhere, either rtclocal or your backend. You might be able to do some digging and find the setting there.

    Wednesday, September 24, 2014 5:21 PM
  • Thanks for the information, this was quite helpful.

    It worked for me.

    Wednesday, September 24, 2014 8:14 PM
  • You can set it with sefautil: http://blogs.technet.com/b/meacoex/archive/2011/04/23/configure-simultaneous-ring-delegate-ringing-and-call-forwarding-settings-on-behalf-of-a-lync-server-2010-user.aspx but it can easily be reset by the user. 

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    • Marked as answer by Eason Huang Thursday, October 9, 2014 7:41 AM
    Wednesday, September 24, 2014 8:17 PM