locked
Configuration changes related to URL aliases changed Audience Targeting behavior RRS feed

  • Question

  • Hi,

    I was hoping someone could shed some light on this experience. We had audience targeting set up to view some content on a page. It always worked but during some SharePoint troubleshooting on another issue, numerous settings were tweaked (we believe the culprit was probably in IIS). After this the behavior was different depending on the URL we put. When we got to the site from the FQDN hostname https://mossxyz.domain.com/... audience targeting would still work. However, when getting to the site with just "moss" (i.e. https://moss.domain.com/, where moss is a DNS A record pointing to mossxyz), then audience targeting would fail and would be shown to everyone.

    Unfortunately (or fortunately depending on how you look at it) I can't open a support ticket (already tried) because the settings have already been changed and we are no longer able to reproduce the issue. We would really like to understand what could have possibly attributed to this failure, perhaps by understanding how audience targeting is affected by any IIS settings / DNS / Aliases etc. If anyone could give any tips or advice that could help us so that we don't have to completely avoid the feature. Thanks in advance.

    • Changed type Elvin Morales Wednesday, July 27, 2011 3:01 PM
    • Changed type Elvin Morales Wednesday, July 27, 2011 3:02 PM
    • Moved by Mike Walsh FIN Wednesday, July 27, 2011 3:17 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Wednesday, July 27, 2011 3:01 PM

All replies

  • Hi Elvin,

     

    Audience targeting seems to work well in your environment. From your description I don't get what changes you have made. Have you tried to reset your audience targeting settings or restore your computer(if the price is not big) to fix this?

    Friday, July 29, 2011 12:09 PM