none
Schedule page RRS feed

  • Question

  • We have an issue with Project server 2013 online, suddenly if we click on project to view project schedule an error fires as below:

    You do not have sufficient permissions to view the specified page. Please contact your administrator for permissions to view this page.

    We are working on this web access with the below:

    1. SharePoint Permission mode.
    2. logged-in with Admin Account.


     Please Help.

    Thanks & Regards Ahmed Amin


    Tuesday, December 31, 2013 12:44 PM

Answers

  • Switching views and refreshing the page usually works for me.

    That is the solution. And the problem probably is because of deleting a view that users had been using during their last connection. PWA tries to access it again, and you get that error.

    Tuesday, July 8, 2014 1:25 PM

All replies

  • As per error comment, Your user is not having sufficient permission.

    Check Following 

    1. Edit affected user account,without making any change click on save button, it will resync user with root collection site 

    2. Check the Group associated for the user.

    3. If user belong to Team member then Check the permission.

    4. Check in User group whether "Open project" permission is enabled or not. By default for Team member group it is not enabled .


     

    kirtesh


    • Edited by Kirteshtiw Wednesday, January 1, 2014 5:40 AM
    Wednesday, January 1, 2014 5:40 AM
  • Thanks for your reply,

    but i think i have deffrent issue as i am using "SharePoint Permission" mode, and i do not have group permission to check with.

    Also i have granted another user same permission (Administrator for Web App) to test the access, and it works fine.

    i have faced issue in EPM 2010 on-premise and solved using edit in DB which is not valid on project online.

    http://social.technet.microsoft.com/Forums/projectserver/en-US/09b91b5c-cc1f-4395-a55d-d75ab085a42c/project-server-2010-tasks-page-an-unknown-error-has-occurred?forum=projserv2010setup


    Thanks & Regards Ahmed Amin

    Wednesday, January 1, 2014 9:40 AM
  • Link which you have given is different from your current issue thhat was the bug in the Project server 2010, Microsoft has released hot fix for that.

    For current issue i think your user is having Team Member permission that is why not able to open schedule page. Check in User group whether "Open project" permission is enabled or not. By default for Team member group it is not enabled .

    Check the associated group for user and let us know ??

    kirtesh



    • Edited by Kirteshtiw Wednesday, January 1, 2014 1:18 PM
    Wednesday, January 1, 2014 12:52 PM
  • I have tried the below:

    1. granted another user the same permission, and project views are working correctly with him.
    2. Deleted the corrupted one, and re-create it with the same name & permission, and fires the same error.

    Also i am not using RBS, or advanced permission, i use the default Project online permision (SharePoint permission mode)


    Thanks & Regards Ahmed Amin

    Wednesday, January 1, 2014 1:23 PM
  • Okay can please add that user in project team and assign any task then publish the project and check.

    Also could you please let me know what permission(group) you are giving to him?? give him project manager permission for project web app.  

    Also check the license of the users .


    kirtesh





    • Edited by Kirteshtiw Wednesday, January 1, 2014 4:28 PM
    Wednesday, January 1, 2014 1:28 PM
  • Is it possible that someone slapped permissions on the Project Detail Page library?  That could cause this.  What if you grant that user permissions within the PDP library?

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky

    Wednesday, January 1, 2014 10:02 PM
    Moderator
  • Thanks for your reply,

    both reply did not solve the issue,

    Kirtesh, i have tried but with no luck.

    Andrew, i have check the issue and it is not related tp PDP page permission, as it loads normally with no SharePoint error, the error message is fired inside the schedule web part (Deatils webpart)


    Thanks & Regards Ahmed Amin


    Thursday, January 2, 2014 10:20 AM
  • Hi Ahmed,

    I am also facing the exact same problem, but only work around i have so far been able to identify is, create a new user, with a slight change in name. This would allow them to view the schedule web part.

    Rest i am also now following this thread, if we are able to find a solution that would be great.

    Thursday, January 9, 2014 12:47 PM
  • Hi,

    What is the exact error you get? Fo you have a permission denied message? Or just the schedule doesn't appear and the webpart is blank?

    Which Project Server and IE versions are you using?


    Guillaume Rouyre - MBA, MCP, MCTS

    Thursday, January 9, 2014 1:53 PM
    Moderator
  • Using Windows 8 with IE 11, tested it on Chrome as well.

    The error that web part displays is "You do not have sufficient permissions to view the specified page. Please contact your administrator for permissions to view this page."

    Monday, January 13, 2014 8:09 AM
  • Can you ask your AD team to see the property for the User you may get any clue. 

    Also You add Project Project Online web app to Trusted zone for intranet and internet. Also ask user to try to open same from different machine. In the IE advanced option enable scripts then check.

    If nothing works i would suggest you to open Support ticket with Microsoft.


    kirtesh

    Monday, January 13, 2014 11:48 AM
  • My client just started having this issue in production after being stable for 6 months.

    I am using Project Server permission mode, administrators with full rights get this message on the schedule PDP. Has anyone solved this?


    120811049008

    Monday, May 26, 2014 7:28 PM
  • Switching views and refreshing the page usually works for me.
    • Proposed as answer by Hester Blok Wednesday, July 9, 2014 7:39 AM
    Tuesday, July 8, 2014 11:27 AM
  • Switching views and refreshing the page usually works for me.

    That is the solution. And the problem probably is because of deleting a view that users had been using during their last connection. PWA tries to access it again, and you get that error.

    Tuesday, July 8, 2014 1:25 PM
  • Exactly. Or when category permissions have been changed.
    Wednesday, July 9, 2014 7:38 AM
  • It sounds like perhaps someone deleted the default view. Could this be?

    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Thursday, July 10, 2014 2:13 PM
    Moderator
  • I had the similar issue and this worked for me.  

    What I found out different is  When I looked at the Views section , there was nothing defaulted or it was just blank which was weird. 

    So I Changed it to Tasks Summary and refreshed the page and it worked as expected. 

    Raj

    Thursday, January 8, 2015 9:34 PM