none
Some of my desktop icons have turned white RRS feed

  • Question

  • Some of my desktop icons(.docx and .json files) have turned white. They open alright, but the icons have turned white. I have Windows 8.1 OS. Please help me out.
    Sunday, July 6, 2014 9:34 AM

Answers

  • Hi,

    Thanks for your help. I have figured out my problem. Actually, I realized that indexing was turned off. So I turned on indexing and my problems were solved.

    Sunday, July 13, 2014 12:46 PM

All replies

  • White means ? can you please post a screenshot ?

    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, July 6, 2014 10:17 AM
  • Hi,

    This might be caused by service conflict, I suggest to perform a clean boot in this way:

    1.Swipe in from the right edge of the screen, and then tap Search. Or, if you are using a mouse, point to the lower-right corner of the screen, and then click Search.

    2.Type msconfig in the search box, and then tap or click msconfig.

    3.On the Services tab of the System Configuration dialog box, tap or click to select the Hide all Microsoft services check box, and then tap or click Disable all.

    4.On the Startup tab of the System Configuration dialog box, tap or click Open Task Manager.

    5.On the Startup tab in Task Manager, for each startup item, select the item and then click Disable.

    6.Close Task Manager.

    7.On the Startup tab of the System Configuration dialog box, tap or click OK, and then restart the computer.

    Details as below:

    http://support.microsoft.com/kb/929135

    Regards


    Wade Liu
    TechNet Community Support

    Monday, July 7, 2014 10:35 AM
  • I tried the above. The problem still persists. In my Downloads folder, all the docx and xlsx files have white icons, though they open correctly. They remain so until the whole folder loads. After 5-7 minutes the icons become colored as usual. This was not the case earlier as the Downloads folder used to load instantaneously. I would like to know what is causing the delay.
    Monday, July 7, 2014 11:53 AM
  • Hi,

    Windows Explorer loads the icon cache into memory when it starts, and then update it in-memory.
    I suggest to delete the Iconcache.db file,  forcing it to build a new cache when it starts back up.

    Delete the file by typing this:%USERPROFILE%\AppData\Local\Iconcache.db at the Windows explorer box.

    Regards


    Wade Liu
    TechNet Community Support

    Tuesday, July 8, 2014 3:01 AM
  • Hi,

    Thanks for your help. I tried the above and deleted the IconCache.db. However, on restarting my laptop I have the following symptoms

    1. The docx and json icons on my desktop have permanantly become white icons.
    2. On opening my file explorer, most of the icons are white the folders(Downloads, D:\, C:\) open, but the MS Office icons(viz. doc, xls) and pdf, rar, exe icons are white.
    Tuesday, July 8, 2014 7:45 AM
  • Hi,

    I want to know if this happen to other user accounts, try to log on the computer with a different account to see this.

    Regards


    Wade Liu
    TechNet Community Support

    Thursday, July 10, 2014 9:54 AM
  • Hi,

    Thanks for your help. I have figured out my problem. Actually, I realized that indexing was turned off. So I turned on indexing and my problems were solved.

    Sunday, July 13, 2014 12:46 PM
  • Hey, I am having this same problem. Wondering if you can share your fix? I have no idea what you meant when you said that you turned indexing on. Please help.
    Saturday, December 17, 2016 2:46 AM
  • I just got an answer on another site.  Simple and it works.

    Open NOTEPAD and enter:  IconCashe.db  then click on file at the top and save.  

    I named mine IconCashe although I don't think that is necessary. Almost forgot I am on Windows 10 Home 1903 (version)

    Zbuckone


    • Edited by zbuckone Wednesday, September 11, 2019 12:16 AM
    Wednesday, September 11, 2019 12:13 AM