locked
AppV 5.0 Network Failure error RRS feed

  • Question

  • Hello everyone, I have virtualized QuickBooks 2014 in AppV 5.0. We have a server at the datacenter that we use to Globally publish the virtual applications to the server. We then create a Remote application to the virtual application. We have had great success with other applications using other AppV 5.o as well as 4.6.

    This particular application (QB 2014 AppV 5.0), has a script that changes the permissions to the VFS to allow for license to be written.

    Here is the issue we are running into with this particular application. When the user goes to open the application, it will connect to the Application, The script runs because we see the Message (the permissions have been edited for your application), then the application will then close.

    We then try to reopen the application and we will immediately get a "Network Failure" error. Even if I try to open directly from the server where it is globally published.

    This error is from the trying to access via "Remote App"
    • Error produced from Remote Aoo
    Error produced from Remote Aoo


    This is directly from where the app is globally published
    • Error produced while attempting to launch from Globally published icon
    Error produced while attempting to launch from Globally published icon


    UPDATE: Here is the Event Viewer Error:
    Process 7000 failed to start due to Virtual Filesystem subsystem failure. Package ID {ba11d2ba-d2c5-4861-8ee8-b3bda532bfba}. Version ID {56a20036-a369-4fac-acc5-4c3c30ddb796}. Error: 0xFD01925-0x5

    I then turned up a new server and tested with a clean App-V 5.0 SP3 RDS client install. I was able to open the applicaiton directly from the new server with the application "Globally" Published just fine, then deployed the app via "Remote App", copied the RDP created to the test users desktop and was able to run, all looked good. Then I used another  test user  with the same RDP file and I get this error. I tried to run from the server itself and get the same error. Not sure where to go here. 


    Any help would be great!

    Thank you!


    Duramaxster

    Wednesday, April 23, 2014 7:04 PM

Answers

All replies

  • Hello,

    I would suggest that you install App-V 5.0 SP2 Hotfix 2 (SP3 is not released).

    http://support.microsoft.com/kb/2934349


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, April 24, 2014 5:17 AM
  • Hey Knack, I actually meant SP2. I will try the hotfix and report back. DO I need to do anything other than install the hotfix? clear any profiles?

    Thank you!
    Paul


    Duramaxster

    Thursday, April 24, 2014 2:07 PM
  • Hello,

    As far as I know, no. If the issue still occurs - you can always try it within a test environment and for a test-user


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, April 24, 2014 3:49 PM
  • Still no luck, I can open as an Admin. I need to get Procmon running in there so I can hopefully find it. Quite new with Procmon, but will need some help getting it to run in the Virtual app as well as how to trim down the events within. any thoughts?

    Paul


    Duramaxster

    Friday, April 25, 2014 2:13 PM
  • Hello,

    This is a great guide on howto trim down the events within Process Monitor;

    http://blogs.technet.com/b/chad/archive/2009/12/30/how-to-use-sysinternals-process-monitor-and-process-explorer-to-troubleshoot-sharepoint.aspx


    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, April 26, 2014 9:24 AM
  • Thank you for the details, however I am still having trouble finding out how to run Procmon inside the App-V 5 application. What I am able to find without figuring out procmon, is that I can run the application as an admin. 

    Do I have some other issues with my RDP client configuration?

    Where might I find a step by step guide on setting up a package to open procmon when launching a virtual app?

    Thank you again!
    Paul


    Duramaxster

    Monday, April 28, 2014 7:33 PM
  • I did a clean sequence with SP2 sequencer and still have the same issues.

    Duramaxster

    Monday, April 28, 2014 7:34 PM
  • For App-V 5 there is no 'special action' required to allow ProcMon to look into the protected environment. No secret command line parameters nor special break-into tricks are required.

    If your Procmon trace doesn't show virtual application activities, it _might_ be necessary to run Procmon once, then reboot the machine, then start the trace.


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Tuesday, April 29, 2014 1:08 PM
    Moderator
  • Hi,

    How did you fix this?? I have the same problem/Error Code?

    Thnx

    Wednesday, January 28, 2015 1:32 PM