locked
Server is not operational message when ADUC is opened RRS feed

  • Question

  • Hi, Folks

    I have a serious problem with a Windows 2008 Standard domain controller.

    There are two DC's, the affected one and a W2k3 DC.

    What happened:

    I have been looking into Network Policy Server and decided to install the RRAS role as a start to see how it looked and to test it out. I did this via Remote Desktop while logged on as the domain administrator.

    I installed the role via Server Manager, choosing Routing and Remote Access and nothing else. I chose the first option to handle VPN connections. (I did not write this down so my terminology will be off). I told it to get DHCP addresses from the domain and not to assign them itself.

    After the installation finished, which was successful, a message appeared about a configuration option with a link to a help topic. I clicked the link and it displayed information about setting the DHCP relay server. When I closed the help file, NPS was shown in the list of roles in Server Manager, and Routing and Remote Access was visible off that. When I clicked it, there was a message to configure it and it asked for the DHCP information so I entered the IP address of our DHCP server which is the W2k3 domain controller.

    When I clicked OK there was a pause and then the Remote Desktop connection died.

    I went to the server and logged on. The network icon showed local access only, although the network could not be reached. Mapped drives could not be accessed, and trying to connect to a machine using a UNC path failed. Pinging the 2008 server from another machine failed.

    In order to try to undo the changes I used the Server Manager to uninstall NPS. This went fine and it requested a restart. After restarting and logging back in the uninstall completed successfully. Unfortunately, the machine was still unable to connect to the network.

    The problem is that Active Directory cannot be accessed either. When I try to open ADUC a message appears:


    Naming information cannot be located for the following reason:
    The server is not operational.

     

    When I use the network diagnostic to check the connection the following is shown:


    The following policy might need to be adjusted to allow Windows to connect:
    Policy provider: Filter Name:local send filter driver filter

     

    The network is shown as a Private network. A red cross exists between the network and the Internet on the diagram in the Network and Sharing Center.

    I tried running DCDiag but it failed with an LDAP error.

    Another check I ran (I can't remember which - sorry) said that the Primary DNS was OK.

    I have also tried disabling the firewall via services.msc

    I can view active directory on the 2003 domain controller without any problems.

    I have system state backups from Thursday.

    There are no DNS errors in the DNS logs.

    Active Directory Domain Services shows replication errors (obviously).

    Does anyone know how I may remedy this? If anyone has any suggestions about how I might recover active directory and connectivity on this server I will be truly grateful.

    Thanks.

    Sunday, June 26, 2011 2:02 PM

Answers

All replies

  • Yesterday I tried resetting IP using netsh int ip... and the network status chnaged to local and Internet. But, connectivity is lost about a minute after logging in.

    When I open Computer Management I can see a node named Network Policy and Access Service under Event Viewer\Custom Views\Server Roles\

    It contains error and warning events identified during installation: 20106 (no IPV6 which was not being used), 20192 (no certificate found) and 20196 (no DHCP server found, assigning APIPA address). After restarting today the following error and warning events are logged: 20192 and 20106.

    However, if I start the Remove Roles Wizard the Network Policy and Access Service is shown as not being installed.

    I am running out of ideas for what to do with this. If anyone can help I would appreciate it very much indeed.


    [edit]

    I have disabled the Windows Firewall to no effect.

    Monday, June 27, 2011 9:02 AM
  • Solved it.

    The routing and remote access service was still operational and needed to be disabled. More info here:

    http://www.petri.co.il/forums/showthread.php?t=55998

    • Marked as answer by Mark-Blood Monday, June 27, 2011 1:43 PM
    Monday, June 27, 2011 1:41 PM