none
WSUS Downloads all files again and again RRS feed

  • Question

  • Hi everyone,

    I-ve set up a online WSUS and at every sync, it seems it downloads all files. In other words :

    - I start a sync the 1st, and it announced me 900GB to download (for example)

    - The day after, all files are downloaded and approved. I start a new sync and it downloads everything again !

    Are there a way to only download the difference ? Or is it the normal way ?

    The next point I don't understand is : it downloads 900GB, but only 350GB is taken by WSUSContent : why ?

    Thanks in advance for your answers

    PS : sorry for my approximative english

    Wednesday, July 25, 2018 1:21 PM

Answers

  • Make sure you have the WSUS options set to ONLY download when the updates are approved.

    First sync will download the metadata into the database. Once you approve updates, the updates themselves start downloading immediately (not after a sync). The next sync with MS will download only the changes with regards to the METADATA, not the actual downloads.

    Have a read of my 8 part blog series on how to setup, manage, and maintain WSUS.

    https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-1-choosing-your-server-os/


    Adam Marshall, MCSE: Security
    https://www.ajtek.ca
    Microsoft MVP - Windows and Devices for IT

    • Marked as answer by Mike_Doe Tuesday, August 14, 2018 7:11 AM
    Thursday, July 26, 2018 2:22 AM
  • Hello Mike_Doe,

     

    Glad to help.

     

    Usually, we select "Download update files to this server only when updates are approved" to save drive space and bandwidth.

     

    However, it is abnormal because wsus should not download updates which is downloaded before.

       

    So at first, before you perform a synchronization, please invest the update files status, check if it is downloaded successfully before. Refer to following screenshot.

     

    If they have been downloaded before and are downloaded again when synchronizing, try following methods to troubleshoot:

    • re-index the susdb

    Refer to this: https://gallery.technet.microsoft.com/scriptcenter/6f8cde49-5c52-4abd-9820-f1d270ddea61

    • reset wsus by following command:

            wsusutil reset

     

    Then run synchronization again and check the result.

      

    Look forward to your feedback.

      

    Best Regards,

    Ray Jia


    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, July 26, 2018 5:31 AM

All replies

  • Make sure you have the WSUS options set to ONLY download when the updates are approved.

    First sync will download the metadata into the database. Once you approve updates, the updates themselves start downloading immediately (not after a sync). The next sync with MS will download only the changes with regards to the METADATA, not the actual downloads.

    Have a read of my 8 part blog series on how to setup, manage, and maintain WSUS.

    https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-1-choosing-your-server-os/


    Adam Marshall, MCSE: Security
    https://www.ajtek.ca
    Microsoft MVP - Windows and Devices for IT

    • Marked as answer by Mike_Doe Tuesday, August 14, 2018 7:11 AM
    Thursday, July 26, 2018 2:22 AM
  • Hello Mike_Doe,

     

    Glad to help.

     

    Usually, we select "Download update files to this server only when updates are approved" to save drive space and bandwidth.

     

    However, it is abnormal because wsus should not download updates which is downloaded before.

       

    So at first, before you perform a synchronization, please invest the update files status, check if it is downloaded successfully before. Refer to following screenshot.

     

    If they have been downloaded before and are downloaded again when synchronizing, try following methods to troubleshoot:

    • re-index the susdb

    Refer to this: https://gallery.technet.microsoft.com/scriptcenter/6f8cde49-5c52-4abd-9820-f1d270ddea61

    • reset wsus by following command:

            wsusutil reset

     

    Then run synchronization again and check the result.

      

    Look forward to your feedback.

      

    Best Regards,

    Ray Jia


    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, July 26, 2018 5:31 AM
  • Thanks both of you for your answers. You give me the remember to use the clean option of WSUS and now, all works well.

    I keep your links for future use.

    Tuesday, August 14, 2018 7:10 AM