locked
ATA Gateway Install on Server Core 2016 Fails. RRS feed

  • Question

  • I'm on a domain controller trying to install the lightweight gateway.

    I'm running:

    "Microsoft ATA Gateway Setup.exe" /quiet NetFrameworkCommandLineArguments="/q" ConsoleAccountName="MyDomain\MySvcAcct" ConsoleAccountPassword=MySvcAcctPassword InstallationPath="D:\ProgramFiles"

    and I get log that says:

    [04A4:1354][2018-07-10T16:09:03]i001: Burn v3.11.0.1701, Windows v10.0 (Build 14393: Service Pack 0), path: C:\Users\Administrator.MyServer\AppData\Local\Temp\3\{49D25599-C7E3-4C2D-BC39-C85648B6C51B}\.cr\Microsoft ATA Gateway Setup.exe
    [04A4:1354][2018-07-10T16:09:03]i000: Initializing string variable 'InstallationConfigurationFilePath' to value '[WixBundleOriginalSourceFolder]\GatewayInstallationConfiguration.json'
    [04A4:1354][2018-07-10T16:09:03]i000: Initializing hidden variable 'ConsoleAccountPassword'
    [04A4:1354][2018-07-10T16:09:03]i000: Initializing hidden variable 'ManagementAuthenticationToken'
    [04A4:1354][2018-07-10T16:09:03]i000: Initializing string variable 'NetFrameworkCommandLineArguments' to value '/passive /showrmui'
    [04A4:1354][2018-07-10T16:09:03]i009: Command Line: '"-burn.clean.room=D:\Source\Microsoft\ATA\Source\Microsoft ATA Gateway Setup.exe" -burn.filehandle.attached=492 -burn.filehandle.self=500 /quiet NetFrameworkCommandLineArguments=/q ConsoleAccountName=MyDomain.com\MSATA ConsoleAccountPassword=***** InstallationPath=D:\ProgramFiles'
    [04A4:1354][2018-07-10T16:09:03]i000: Setting string variable 'WixBundleOriginalSource' to value 'D:\Source\Microsoft\ATA\Source\Microsoft ATA Gateway Setup.exe'
    [04A4:1354][2018-07-10T16:09:03]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'D:\Source\Microsoft\ATA\Source\'
    [04A4:1354][2018-07-10T16:09:03]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\Administrator.MyServer\AppData\Local\Temp\Microsoft Advanced Threat Analytics Gateway_20180710160903.log'
    [04A4:1354][2018-07-10T16:09:03]i000: Setting string variable 'WixBundleName' to value 'Microsoft Advanced Threat Analytics Gateway'
    [04A4:1354][2018-07-10T16:09:03]i000: Setting string variable 'WixBundleManufacturer' to value 'Microsoft Corporation'
    [04A4:1354][2018-07-10T16:09:03]i000: Loading managed bootstrapper application.
    [04A4:1354][2018-07-10T16:09:04]i000: Creating BA thread to run asynchronously.
    [04A4:1354][2018-07-10T16:09:04]i100: Detect begin, 7 packages
    [04A4:1354][2018-07-10T16:09:04]i000: 2018-07-10 21:09:04.5396 1188 1   Debug [\[]DeploymentModel[\]] DetectBegin [\[]Installed=False[\]]
    [04A4:1354][2018-07-10T16:09:04]i000: Setting string variable 'NetFrameworkRegistryValue' to value '461814'
    [04A4:1354][2018-07-10T16:09:04]i000: Setting string variable 'ServerLevelsServerCoreRegistryValue' to value '1'
    [04A4:1354][2018-07-10T16:09:04]i000: Registry value not found. Key = 'SOFTWARE\Microsoft\Windows NT\CurrentVersion\Server\ServerLevels', Value = 'Server-Gui-Shell'
    [04A4:1354][2018-07-10T16:09:04]i000: Registry key not found. Key = 'SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\Package_for_KB3047154_RTM~31bf3856ad364e35~amd64~~6.3.2.0'
    [04A4:1354][2018-07-10T16:09:04]i000: Setting numeric variable 'KB3047154Exists' to value 0
    [04A4:1354][2018-07-10T16:09:04]i052: Condition 'NetFrameworkRegistryValue >= 394254' evaluates to true.
    [04A4:1354][2018-07-10T16:09:04]i052: Condition 'NetFrameworkRegistryValue >= 394254' evaluates to true.
    [04A4:1354][2018-07-10T16:09:04]i052: Condition 'KB3047154Exists' evaluates to false.
    [04A4:1354][2018-07-10T16:09:04]i101: Detected package: NetFrameworkPackageServer, state: Present, cached: None
    [04A4:1354][2018-07-10T16:09:04]i101: Detected package: NetFrameworkPackageServerCore, state: Present, cached: None
    [04A4:1354][2018-07-10T16:09:04]i101: Detected package: KB3047154Package, state: Absent, cached: None
    [04A4:1354][2018-07-10T16:09:04]i101: Detected package: VcRedistributable2013Package, state: Absent, cached: None
    [04A4:1354][2018-07-10T16:09:04]i101: Detected package: PefNdisDriver, state: Absent, cached: None
    [04A4:1354][2018-07-10T16:09:04]i101: Detected package: BundleActionsPackage, state: Absent, cached: None
    [04A4:1354][2018-07-10T16:09:04]i101: Detected package: MsiPackage, state: Absent, cached: None
    [04A4:1354][2018-07-10T16:09:04]i199: Detect complete, result: 0x0
    [04A4:083C][2018-07-10T16:09:04]i000: 2018-07-10 21:09:04.5552 1188 5   Debug [\[]DeploymentModel[\]] [\[]DeploymentAction=Install[\]]
    [04A4:083C][2018-07-10T16:09:04]i000: 2018-07-10 21:09:04.7896 1188 5   Debug [\[]DeploymentModel[\]] [\[]IsAfterRestartAndConfigured=False[\]]
    [04A4:083C][2018-07-10T16:09:04]i000: 2018-07-10 21:09:04.8521 1188 5   Error [\[]DeploymentManager[\]] Microsoft Advanced Threat Analytics Lightweight Gateway 1.9.7312.32791 Setup is already running.
    [04A4:083C][2018-07-10T16:09:04]i000: 2018-07-10 21:09:04.8521 1188 5   Debug [\[]GatewayBootstrapperApplication[\]] Engine.Quit [\[]deploymentResultStatus=1626 isRestartRequired=False[\]]
    [04A4:1354][2018-07-10T16:09:04]i500: Shutting down, exit code: 0x65a
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: InstallationConfigurationFilePath = D:\Source\Microsoft\ATA\Source\\GatewayInstallationConfiguration.json
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: KB3047154Exists = 0
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: NetFrameworkCommandLineArguments = /passive /showrmui
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: NetFrameworkRegistryValue = 461814
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: ServerLevelsServerCoreRegistryValue = 1
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleAction = 5
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleElevated = 1
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleLog = C:\Users\Administrator.HIIDC16LEW002\AppData\Local\Temp\Microsoft Advanced Threat Analytics Gateway_20180710160903.log
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleManufacturer = Microsoft Corporation
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleName = Microsoft Advanced Threat Analytics Gateway
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleOriginalSource = D:\Source\Microsoft\ATA\Source\Microsoft ATA Gateway Setup.exe
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleOriginalSourceFolder = D:\Source\Microsoft\ATA\Source\
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleProviderKey = {05a3382b-748c-4810-be34-36df8c117b8a}
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleSourceProcessFolder = D:\Source\Microsoft\ATA\Source\
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleSourceProcessPath = D:\Source\Microsoft\ATA\Source\Microsoft ATA Gateway Setup.exe
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleTag =
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleUILevel = 2
    [04A4:1354][2018-07-10T16:09:04]i410: Variable: WixBundleVersion = 1.9.7312.32791
    [04A4:1354][2018-07-10T16:09:05]i007: Exit code: 0x65a, restarting: No

    I see that my server is running .Net 4.7.2

    I also  see there was some problems with ATA v1.7 and ATA v1.8 running Net 4.7 but I don't see a fix short of downgrading .Net which is probably not an option.


    ncjks



    • Edited by ncjks Tuesday, July 10, 2018 10:12 PM
    Tuesday, July 10, 2018 9:21 PM

All replies

  • 1.9 & 1.9.1 should run fine with 4.7.2.

    See 

    https://docs.microsoft.com/en-us/advanced-threat-analytics/troubleshooting-ata-using-logs#ata-deployment-logs

    The interesting log in thsi case is the *_MsiPackage.log file.

    I also suggest to upgrade this 1.9 deployment to 1.9 update 1:

    https://www.microsoft.com/en-us/download/details.aspx?id=56725

    Tuesday, July 10, 2018 9:42 PM