locked
disable automapping with Add-MailboxFolderPermission command RRS feed

  • Question

  • Is this even possible?  I'm trying to disable automapping for a user that has access only to certain folders.  I'm trying to do this in Office 365.

    I'm using this command:

    Add-MailboxFolderPermission -Identity "test1@test.com:\Inbox" -User test2@test.com -AccessRights "Editor" -Automapping $false

    but I get this error message:

    A positional parameter cannot be found that accepts argument '-Automapping'.
        + CategoryInfo          : InvalidArgument: (:) [Add-MailboxFolderPermission], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Add-MailboxFolderPermission


    • Edited by oneeyejack7 Thursday, July 12, 2012 3:23 PM
    Thursday, July 12, 2012 3:21 PM

Answers

  • I can't see this being different for O365 but it doesnt exist on SP On prem.

    If that is your issue, have you tried to uncheck, download shared folders in the MAPI profile? (Assuming youre using OLK 2010).


    Sukh

    Thursday, July 12, 2012 6:47 PM

All replies

  • Thursday, July 12, 2012 4:45 PM
  • Sorry, but that's not the correct command.  I know how to disable automap with the add-mailbox permission.  I'm looking to also do it with: 

    Add-MailboxFolderPermission

    Thursday, July 12, 2012 5:40 PM
  • That doesnt exist.

    Sukh

    Thursday, July 12, 2012 5:44 PM
  • so the only way to do this is to go to the user's mailbox and set the permissions manually and then add the user?  
    Thursday, July 12, 2012 6:21 PM
  • Automap only works with FMA, if the user has this permission it get's mapped unless you disable (SP2). Dont qiute follow what you are saying, are you saying that it still get's mapped with folder permission only because I haven't heard of that.

    Sukh

    Thursday, July 12, 2012 6:28 PM
  • It does get mapped automatically.  If you type: Add-MailboxFolderPermission -Identity "test1@test.com:\Inbox" -User test2@test.com -AccessRights "Editor" the Inbox of test1 will get automatically mapped.

    I don't want user, test2, to have this automatically mapped because the Inbox of test1 starts taking up space in the OST of user test2.


    Thursday, July 12, 2012 6:34 PM
  • I can't see this being different for O365 but it doesnt exist on SP On prem.

    If that is your issue, have you tried to uncheck, download shared folders in the MAPI profile? (Assuming youre using OLK 2010).


    Sukh

    Thursday, July 12, 2012 6:47 PM