locked
Cannot access Site usage details in mysite RRS feed

  • Question

  • Hi All,

    I am facing a strange issue. I am not able to access site usage details under site adminstration or under site collection administration in my mysite. I am having the site collection administartor rights. When I am looking at the logs I am finding this :

    Access Denied for /MyID/_layouts/usageDetails.aspx. StackTrace: Microsoft.SharePoint.Utilities.SPUtility:Void HandleAccessDenied(System.Exception), Microsoft.SharePoint.SPGlobal:Void HandleUnauthorizedAccessException(System.UnauthorizedAccessException), Microsoft.SharePoint.Library.SPRequest:System.Object GetWebUsageData(System.String, System.String, System.String, System.Guid, Int32, Int32, Int32, System.DateTime), Microsoft.SharePoint.Administration.SPUsage+UsageDetailsInfo:Void .ctor(Microsoft.SharePoint.SPWeb, Microsoft.SharePoint.Administration.SPUsageReportType, Microsoft.SharePoint.Administration.SPUsagePeriodType, Int32, System.DateTime), Microsoft.SharePoint.SPWeb:System.Data.DataTable GetUsageData(Microsoft.SharePoint.Administration.SPUsageReportType, Microsoft.Shar...

    Any Help in this regard is highly appreciated.

    • Moved by Mike Walsh FIN Thursday, May 5, 2011 7:40 AM My Sites = social computing (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, May 5, 2011 7:32 AM

Answers

  • It might happen if the usage detail setting has been turned off from the platform. Please verify the settings below:

    • Go to Central Admin --> Application Management
    • Under Application Security click User permissions for Web application
    • Select the proper web application
    • Under Site Permissions, ensure that View Usage Data check box is checked

    Hope this helps.

    Thanks,
    Dip

     


    Dip
    MCTS: MOSS 2007 Administration
    MCAD, MCSD
    My blog: http://dzeee.net/sharepoint
    • Marked as answer by Rashu,Rahul Tuesday, May 17, 2011 6:57 AM
    Monday, May 16, 2011 5:00 PM

All replies

  • Hi,

    Thanks to share your post.

    For the issue, please refer the followed steps:

    1.       Open administrator website (using windows credentials)

    2.       Click on “Site Action” –> “Site Settings” and click on “Modify all Site Settings”.

    3.       Click on “people and groups” under “users and permissions” section.

    4.       Click on “Registered Users” and add newly added user email Id to this group.

    Hope this could help you!

    Leo

     

    Monday, May 9, 2011 9:22 AM
  • I tried this but it did not work. same error.

    Thanks,

    Rahul Rashu

    Tuesday, May 10, 2011 5:49 PM
  • It might happen if the usage detail setting has been turned off from the platform. Please verify the settings below:

    • Go to Central Admin --> Application Management
    • Under Application Security click User permissions for Web application
    • Select the proper web application
    • Under Site Permissions, ensure that View Usage Data check box is checked

    Hope this helps.

    Thanks,
    Dip

     


    Dip
    MCTS: MOSS 2007 Administration
    MCAD, MCSD
    My blog: http://dzeee.net/sharepoint
    • Marked as answer by Rashu,Rahul Tuesday, May 17, 2011 6:57 AM
    Monday, May 16, 2011 5:00 PM
  • Thanks Dip, It really works.

    Thanks,

    Rahul Rashu

    Tuesday, May 17, 2011 6:56 AM