locked
Game crashes in Windows 7 RRS feed

  • Question

  • Hey everybody, I've written on this forum before but recent events have led me to write again; i.e. my computer playing up.

    I have a serious problem with my computer: all my games appear to crash randomly, usually after 15 minutes or so in-game.
    My specs are a Gigabyte EP45-UD3LR motherboard, Intel Core 2 Quad Q8400, Geforce GTX 260, 2 x 2GB Kingston HyperX DDR2 RAM, Corsair 650w PSU, Western Digital SATA II + Velociraptor HDD.
    I believe Windows 7 RC Build 7100 (my OS) has bugs but I don't think it's the cause. Not that I rule it out. I think that my problems stem from hardware or driver issues, but I don't know what.

    Sometimes, I get Blue Screen. I've once had IRQL_NOT_LESS_OR_EQUAL, other times HARDWARE ISSUE, other times something totally different. In other instances, I get no blue screen at all: when it crashes, it either goes black, freezes or pixallates wildly. I have tested the RAM with Windows Memory Diagnostic and it discovered no problems, but I'm not sure if my RAM is definitely compatible with my motherboard. That said, nothing is unusual apart from when the games crash...it has never crashed in windows. I tried to follow a guide to diagnose a couple of Blue Screens, but I couldn't find the .dmp files anywhere, even after unlocking hidden files.  It definitely isn't overheating.

    I have been told that it is very likely a motherboard or driver issue. But I'm not sure. This is driving me nuts, has anybody had any similar problems and- perhaps- resolved them?

    If you need to, please ask me any questions about my system...

    • Moved by Ronnie VernonMVP Monday, August 24, 2009 6:12 AM Focus (From:Windows 7 Hardware Compatibility)
    Saturday, August 22, 2009 4:57 PM

Answers

  • Greetings,

    your Nvidia 260 GTX is fully compatible with Windows 7. Just let us know which are the drivers you have installed. Nvidia released their latest one a couple of days ago (version 190.62) More details here. And you can get them here

    And, as a sidenote, I strongly recommend you to uninstall any previous version of the drivers, if you have any installed. Use this neat free tool to clean any file/trace in the reg file and then install the new ones.

    And finally, try to get and install the latest Direct X
    W7 RTM x64 running along with Office 2010 x64 TP hope my computer won't crash! ;)
    Monday, August 24, 2009 11:39 AM
  • It is glad to hear that there is a fix to the game crash issue. Alex, please try Shadeslayer45's suggestion. For your reference, I include the detailed steps below to disable Windows Media Player Network Sharing service.

    How to disable Windows Media Player Network Sharing service
    ===========================================
    1. Click on the Start Button, type "services.msc" (without quotation marks) in the Start Search box and press Enter.
    2. Right click the service "Windows Media Player Network Sharing service" and click "Stop".
    3. Check if the issue persists.

    Thanks,
    Candice

    I should of said, only disable this if you aren't using extenders or sharing your libary (this does not include win7's automatic ones, only Windows Media Player). remember to reenable the service before you want to use these features, otherwise they won't work.

    as an additional to Candice Wang suggestion, you also may wish to disable the service, meaning it will never start unless you manually start it.

    To do this:

    1.open the start menu and type in "services.msc" (without quotes) and press enter
    2.Find the Windows Media Player Network Sharing Service and right click on it and select Properties
    3.Select Disabled from the Start Drop down box.
    4.Click OK.

    To renable the service:
    1.Follow the steps above, but select "Manual" from the drop down box. This will start the service when a program requires it.
    2.Click OK.

    The PC Specs: Athlon 3500+ 2GB RAM Geforce 8600 GT (256MB) MB:ASUS A8N-VM-CSM
    Monday, September 21, 2009 6:55 AM

All replies

  • Hey

    I'm having the same problem with similar gear; evga nForce 790i FTW Intel Core 2 9400, GTX 285, 2 X 2gig Kingmax ddr3, Velocirapter HDD. I had display issues when I installed Nvidia 185 drivers in Vista, so went to Win7 fresh install went up to the Nvidia 190 drivers games started crashing randomly and last night the system locked up just looking at a black screen PC still running. I will install another Graphics card tonight and uninstall the Nvidia drivers.

    I'll let you know how it goes.
    • Edited by sid3sh0w Sunday, August 23, 2009 1:43 AM
    Sunday, August 23, 2009 1:23 AM
  • Please do.
    I'm also trying to solve it this end, I'll keep you posted.
    Sunday, August 23, 2009 12:40 PM
  • Hi,

    I agree with sid3sh0w that this issue is caused by display card driver. I would like to confirm if the latest driver (provided by manufacturer) has been installed on the computer. If not, please get it from here:

    Geforce GTX 260 for Win7 32-bit

    Geforce GTX 260 for Win7 64-bit

    In addition, this behavior can occur if there is incompatible hardware or an incompatible device driver on your computer. If the issue persists after installing the latest driver, we can try the steps below:

    1. Remove any unnecessary hardware from the computer. Disconnect any Universal Serial Bus (USB) devices and printers, and remove the network adapter, sound card, serial adapters, and so on.

    2. If you continue to receive this error message, you may need to flash the BIOS on the computer's motherboard. Refer to the manufacturer of your computer or the Web site for the motherboard for information about how to do this.

    Meanwhile, I noticed that you are wondering how to finding DUMP file. Please refer to the steps below:

    Collect the Memory Dump files
    ====================
    1. Click "Start", input "SYSDM.CPL" (without quotation marks) in the Search Bar and press Enter.
    2. Click the "Advanced" tab and click the "Settings" button under "Startup and Recovery".
    3. Under "Write debugging information" section, make sure the "Small Memory Dump (64KB)" option is selected.
    4. Check if "%SystemRoot%\Minidump" is in the "Small Dump Directory" open box.

    Please refer to the following steps to collect memory dump files:

    1. Please click Start, type "%SystemRoot%\Minidump" (without quotation marks) in the Search Bar.
    2. Go to your Desktop, right-click on it and create a new folder named "Dump".
    3. Copy all the memory dump files (looks like Mini052007-01.dmp) in Minidump to this folder.

    To open this file, a technical analysis tool (WinDbg) is required. Computer professionals can help you analysis it.

    I hope the above information is useful. :)

    • Proposed as answer by Vivian Xing Monday, August 24, 2009 8:11 AM
    Monday, August 24, 2009 8:04 AM
  • Hi Alex,

    It should be the video card problem. Please check if the this hardware is compatible with Windows 7. See below:

    http://www.nvidia.com/object/windows_7_overview.html

    We can also try a Clean boot:

    Clean Boot
    =============
    1. Click the Start Pearl, and type "msconfig" (without the quotation marks) in Start Search box, press Enter.
    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click the "Startup" tab, click "Disable All" and click "OK".
    4. Click "OK" to restart your computer to Selective Startup environment.
    5. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.
    6. Check whether or not the issue still appears in this environment.

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't affect the system or other programs. We may still manually run these programs later.

    How to return from a Clean Boot state
    ==============
    1. Click the Start Pearl, and type "msconfig" (without the quotation marks) in Start Search box, press Enter.
    2. On the "General" tab, click "Normal Startup - load all device drivers and services".
    3. Click "OK". Click "Restart" when you are prompted to restart your computer.

    Monday, August 24, 2009 8:13 AM
  • Sorry for the delay works been flat out.

    What I have done is unistall the Nvidia drivers just using the native Windows ones now, seems to be working so far, Farcry 2 is running well, but need to test it for another day, give it a try yourself and let me know how it goes.

    I checked and it's on the Nvidia windows compatability list both cards are there. You can unistall the drivers in device manager, then go into programs and features to clear the rest of the drivers from Nvidia.

    What drivers do you have installed?

    I'm having trouble with my wireless USB device aswell but may not be related to the black screen.
    Monday, August 24, 2009 11:35 AM
  • Greetings,

    your Nvidia 260 GTX is fully compatible with Windows 7. Just let us know which are the drivers you have installed. Nvidia released their latest one a couple of days ago (version 190.62) More details here. And you can get them here

    And, as a sidenote, I strongly recommend you to uninstall any previous version of the drivers, if you have any installed. Use this neat free tool to clean any file/trace in the reg file and then install the new ones.

    And finally, try to get and install the latest Direct X
    W7 RTM x64 running along with Office 2010 x64 TP hope my computer won't crash! ;)
    Monday, August 24, 2009 11:39 AM
  • Don't worry about uninstalling Nvidia drivers, it worked fine for about 4 hours last night, this morning went to the black screen again.

    I'm having a bit of luck at the moment I've unplugged the Logitech G5 mouse and have a standard microsoft 2 button. seems alright so far still testing. Logitech don't have the win7 drivers as yet.

    Tuesday, August 25, 2009 5:15 AM
  • Hello! My first post here.

    Well, I'm facing similar problems with almost all my game.

    I'm a regular Call of Duty 4 MP player; i.e. I play online. Now the game runs fine for an hour or so, but then suddenly this problem occurs. The game lags MASSIVELY. The packet flow to the server gets severely choked. The game eventually starts working but I get kicked from the server for restricted packet flow (punkbuster).

    In other game, like Company of Heroes, it does the same. The sound gets distorted, the game halts. Sometimes it even crashes. Same was the case with Prince of Persia and Fallout 3.

    About drivers and stuff... I don't think that is an issue. Microsoft, i think, said that its a chipset issue that can be resolved by updating the drivers. Its not. I have updated all the drivers. My sound drivers are updated (Realtek ALC883, R201 released a couple of days ago). My graphic card drivers are updated (Forceware 190.62).

    I believe it has something to do with that chkdsk but that windows 7 rtm has. Upon certain triggers, chkdsk auto starts and runs with a particular extension that eats up all available physical memory, literally choking any running game.

    Is there any way to disable chkdsk?

    My specs:

    Windows 7 Ultimate 64bit

    Intel Core 2 Duo E8400 @ 3.6
    ASUS P5K-VM
    3GB Corsair XMS2 DDR2-800

    XFX GTX260 Black Edition (NVIDIA)
    Tuesday, August 25, 2009 10:49 AM
  • OK think I have it.

    Been gaming all day no problems. Used the Microsoft mouse, I have just installed the Vista Logitech drivers (cause I didn't have any installed.) and it's been ok for the last 2 hours, no black screen.

    ASKnASK sounds like something is chewing your bandwidth, do you get the same problem when you aren't playing online? Could be something doing an update in the back ground.
    Tuesday, August 25, 2009 11:36 AM
  • OK think I have it.

    Been gaming all day no problems. Used the Microsoft mouse, I have just installed the Vista Logitech drivers (cause I didn't have any installed.) and it's been ok for the last 2 hours, no black screen.

    ASKnASK sounds like something is chewing your bandwidth, do you get the same problem when you aren't playing online? Could be something doing an update in the back ground.

    It also happens when I'm playing offline. If bandwidth was the issue, the game should have simply disconnected. The PC becomes totally unresponsive. You can't open the task manager... Ctrl+Alt+Del has no effect. Its as if... someone's strangled the PC for a while lol

    Microsoft isn't offering support since the OS isn't 'OUT' yet :)

    Its that chkdsk issue I'm sure of it. I don't get it though. How could something so major be ignored by MS? Funny thing is that it has NEVER happened during normal operation (playing music, browsing internet, music etc).
    • Edited by ASKnASK Wednesday, August 26, 2009 6:52 PM came =/ game
    Wednesday, August 26, 2009 6:51 PM
  • If microsoft have said it's the chipset drivers, the asus site doesn't have any for win7 but double check the version of your chipset. The vista ones may do.

    http://support.asus.com/download/download.aspx?SLanguage=en-us this is the link to the chipset drivers.
    Thursday, August 27, 2009 2:27 AM
  • If microsoft have said it's the chipset drivers, the asus site doesn't have any for win7 but double check the version of your chipset. The vista ones may do.

    http://support.asus.com/download/download.aspx?SLanguage=en-us  this is the link to the chipset drivers.
    I'm good with PC stuff but for some purposes, I still use specific software. For example, the drivers stuff.

    There is a software named Driver Genius. It scans all your drivers and searches for updates (it has its own very large database). Its not free though.
    I thought my PC was fully up-to-date, but that software gave me 5 updates! Two for chipset drivers, one sound drivers (ALC 883), one for network and one I don't remember.

    Anyways, the problem still exists. If MS wanted to fix it, they would've done so with fix in Windows Update. Obviously, they aren't interested.
    Thursday, August 27, 2009 2:12 PM
  • OK think I have it.

    Been gaming all day no problems. Used the Microsoft mouse, I have just installed the Vista Logitech drivers (cause I didn't have any installed.) and it's been ok for the last 2 hours, no black screen.

    ASKnASK sounds like something is chewing your bandwidth, do you get the same problem when you aren't playing online? Could be something doing an update in the back ground.

    It also happens when I'm playing offline. If bandwidth was the issue, the game should have simply disconnected. The PC becomes totally unresponsive. You can't open the task manager... Ctrl+Alt+Del has no effect. Its as if... someone's strangled the PC for a while lol

    Microsoft isn't offering support since the OS isn't 'OUT' yet :)

    Its that chkdsk issue I'm sure of it. I don't get it though. How could something so major be ignored by MS? Funny thing is that it has NEVER happened during normal operation (playing music, browsing internet, music etc).
    You sure it's chkdsk? I was having similar problems untill I disabled the Windows Media network Sharing service. It used to hog my hard drive for random intervals, affecting my games quite badly

    The PC Specs: Athlon 3500+ 1GB RAM Geforce 8600 GT (256MB) MB:ASUS A8N-VM-CSM
    Thursday, September 17, 2009 6:33 AM
  • It is glad to hear that there is a fix to the game crash issue. Alex, please try Shadeslayer45's suggestion. For your reference, I include the detailed steps below to disable Windows Media Player Network Sharing service.

    How to disable Windows Media Player Network Sharing service
    ===========================================
    1. Click on the Start Button, type "services.msc" (without quotation marks) in the Start Search box and press Enter.
    2. Right click the service "Windows Media Player Network Sharing service" and click "Stop".
    3. Check if the issue persists.

    Thanks,
    Candice

    Thursday, September 17, 2009 8:18 AM
  • It is glad to hear that there is a fix to the game crash issue. Alex, please try Shadeslayer45's suggestion. For your reference, I include the detailed steps below to disable Windows Media Player Network Sharing service.

    How to disable Windows Media Player Network Sharing service
    ===========================================
    1. Click on the Start Button, type "services.msc" (without quotation marks) in the Start Search box and press Enter.
    2. Right click the service "Windows Media Player Network Sharing service" and click "Stop".
    3. Check if the issue persists.

    Thanks,
    Candice

    I should of said, only disable this if you aren't using extenders or sharing your libary (this does not include win7's automatic ones, only Windows Media Player). remember to reenable the service before you want to use these features, otherwise they won't work.

    as an additional to Candice Wang suggestion, you also may wish to disable the service, meaning it will never start unless you manually start it.

    To do this:

    1.open the start menu and type in "services.msc" (without quotes) and press enter
    2.Find the Windows Media Player Network Sharing Service and right click on it and select Properties
    3.Select Disabled from the Start Drop down box.
    4.Click OK.

    To renable the service:
    1.Follow the steps above, but select "Manual" from the drop down box. This will start the service when a program requires it.
    2.Click OK.

    The PC Specs: Athlon 3500+ 2GB RAM Geforce 8600 GT (256MB) MB:ASUS A8N-VM-CSM
    Monday, September 21, 2009 6:55 AM
  • Hi,

    I just set-up my NEW PC 9/4/10...Windows7 64-bit Home Premium, 3.07Ghz processor, 6 gigs RAM, HD graphics...ran all the updates (Windows and hardware), and installed The Sims3.

     

    Shortly after beginning to play, my system crashed to a black screen.  I had to reboot using system restore to just after the game was installed and initiated troubleshooting problem...HP advised me to get graphics updates.  Since I had already initiated updates during set-up, I was reluctant to mess with the hardware since as I said, it's new and has way more resources available than is needed to run this game.  So,

     

    I went to the Sims3 web-site...The fix was to turn OFF the User Account Control "UAC" to run the game.  After playing, I turned it back ON and restarted.  I have been playing since then without any reaccurances.  From START > type in search "UAC" to get control window.

     

    Hope this helps!

    Tuesday, September 7, 2010 4:52 PM