none
Cannot connect using Remote Desktop RRS feed

  • Question

  • I have a server running Windows Server 2008. I have Remote Desktop setup to allow connections from computers running any version of Remote Desktop. I have been trying to connect from my laptop running Windows XP Professional. I get the following error message:

     

    Remote Desktop Disconnected:

    This computer cannot connect to the remote computer.

    Try connection again. If this problem continues, contact the owner of the remote computer or your network administrator.

     

    I also tried to connect using a different laptop running Windows Vista and got the same error message. Any help would be appreciated.

    Monday, March 14, 2011 2:18 PM

Answers

  • How do I access the settings for allow users with network level authentication to connect?

    Accessing Advanced System Properties: Run the command sysdm.cpl (fastest result of any alternative) and click on the "Remote" tab.

    1st Alternative: Click Start > Click Server Manager (wait for snap-ins to load) > If it isn't selected by default, click on "Server Manager (ServerName)" at the very top of the left pane > On the right side of "Server Summary," Click on "Configure Remote Desktop"

    2nd Alternative: Click Start > Right Click "Computer" > Select Properties - In the Left Pane, Click "Advanced Systems Settings" > Select "Remote" tab

    3rd Alternative: Open Control Panel - Sort/View By - Small/Large Icons > Click on "System" > In the Left Pane, Click "Advance Systems Settings" > Select "Remote" tab

    I tried to ping the client with no success. I also tried to ping the server from the client with no success.

     If you can't get the systems to talk to one another... check connectivity and troubleshoot that first. Otherwise its like talking to the wall. It might be relief to get it out but you get no where doing it. These systems can't carry a conversation without their handshakes or having the ability to talk to each other.

    Run IPconfig in both systems and post the results.. if you find your own discrepancy and resolve. Please mark a supportive answer in this thread.

    Best Regards,


     

    Steve Kline
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Product Specialist
    Microsoft Certified Network Product Specialist
    Red Hat Certified System Administrator
    This posting is "as is" without warranties and confers no rights.

    • Marked as answer by glimmertwins Thursday, March 17, 2011 7:53 PM
    Tuesday, March 15, 2011 8:13 PM

All replies

  • Please try to disable the windows firewall on the server and give a try once more and also use the ip address to connect from the remote desktio cleint instead hostname.

     

    Thanks


    http://www.virmansec.com/blogs/skhairuddin
    Monday, March 14, 2011 2:25 PM
  • Try to check connection to remote desktop server using telnet  (port 3389, by name and by IP).
    VitVas
    Monday, March 14, 2011 3:21 PM
  • Are you able to ping the server?

    Please check that is no firewall / router that is blocking traffic.

    Also, try to diable all your security softwares and check if you are able to connect to the remote computer.

     


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Microsoft Student Partner
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration

    Monday, March 14, 2011 3:47 PM
  • I have Windows Firewall off and no anti-virus software on. I tried to ping the server with no success. Is there something else I should try?
    Monday, March 14, 2011 4:28 PM
  • If your internal firewalls are disabled and you are unable to ping the server, that means that you have something wrong with the routers / firewalls that are between the client computers and the server.

    Please make sure that your routes are well configured and there is no router / firewall that is between your client computers and your server that is blocking the traffic.

    The use of wireshark may be helpful for troubleshooting.

     


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Microsoft Student Partner
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration

    • Proposed as answer by Mr XMVP Monday, March 14, 2011 8:39 PM
    Monday, March 14, 2011 4:37 PM
  • Please check if your client and sever both are on the same subnet and as a test plese try to ping the client from the server and make it sure that both are on the network. Check hardware switch network cable etc.
    http://www.virmansec.com/blogs/skhairuddin
    Monday, March 14, 2011 5:40 PM
  • It was my router, had to turn on port forwarding....duh!  Kinda new to network troubleshooting.  Thanks to all for the help!!
    Monday, March 14, 2011 7:16 PM
  • I have a server running Windows Server 2008. I have Remote Desktop setup to allow connections from computers running any version of Remote Desktop. I have been trying to connect from my laptop running Windows XP Professional. I get the following error message:

     

    Remote Desktop Disconnected:

    This computer cannot connect to the remote computer.

    Try connection again. If this problem continues, contact the owner of the remote computer or your network administrator.

     

    I also tried to connect using a different laptop running Windows Vista and got the same error message. Any help would be appreciated.

    If you could please run these commands in your command prompt and verify again?

    netsh advfirewall firewall set rule name="File and Printer Sharing (Echo Request - ICMPv4-In)" new enable=yes
    netsh advfirewall firewall set rule name="File and Printer Sharing (Echo Request - ICMPv4-Out)" new enable=yes
    netsh advfirewall firewall set rule name="Remote Desktop (TCP-In)" new enable=yes
    

    You must enable file sharing from the Network and Sharing center. If you want to ping the server by name that isn't in DNS, do not enable Network Discovery as its not needed. But you must enable file and printer sharing. You can still disable public shares and only authorized users should be able get to those shares.

    Ping again to verify connectivity to the IP address only. Not the domain name or the server netbios name. If network discovery is disabled, it won't recognize it anyway unless its in DNS.

    Just to make sure the registry isn't conflicting with what you see... change the setting to only allow users with network level authentication to connect. (Vista Sp1 and higher only) After you set it and click on OK. Go back to the screen and change it back to allow any version of RDC.

    Then try connecting again via command line to eliminate the problem from the RDC settings...

    mstsc.exe /v:[IP ADDRESS HERE]:3389
    
    

    Steve Kline
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Product Specialist
    Microsoft Certified Network Product Specialist
    Red Hat Certified System Administrator
    This posting is "as is" without warranties and confers no rights.
    Monday, March 14, 2011 7:23 PM
  • Ping again to verify connectivity to the IP address only. Not the domain name or the server netbios name. If network discovery is disabled, it won't recognize it anyway unless its in DNS.

     

    I tried to ping the client with no success. I also tried to ping the server from the client with no success.

     

    Just to make sure the registry isn't conflicting with what you see... change the setting to only allow users with network level authentication to connect. (Vista Sp1 and higher only) After you set it and click on OK. Go back to the screen and change it back to allow any version of RDC.

     

    How do I access the settings for allow users with network level authentication to connect?

    Tuesday, March 15, 2011 3:20 PM
  • How do I access the settings for allow users with network level authentication to connect?

    Accessing Advanced System Properties: Run the command sysdm.cpl (fastest result of any alternative) and click on the "Remote" tab.

    1st Alternative: Click Start > Click Server Manager (wait for snap-ins to load) > If it isn't selected by default, click on "Server Manager (ServerName)" at the very top of the left pane > On the right side of "Server Summary," Click on "Configure Remote Desktop"

    2nd Alternative: Click Start > Right Click "Computer" > Select Properties - In the Left Pane, Click "Advanced Systems Settings" > Select "Remote" tab

    3rd Alternative: Open Control Panel - Sort/View By - Small/Large Icons > Click on "System" > In the Left Pane, Click "Advance Systems Settings" > Select "Remote" tab

    I tried to ping the client with no success. I also tried to ping the server from the client with no success.

     If you can't get the systems to talk to one another... check connectivity and troubleshoot that first. Otherwise its like talking to the wall. It might be relief to get it out but you get no where doing it. These systems can't carry a conversation without their handshakes or having the ability to talk to each other.

    Run IPconfig in both systems and post the results.. if you find your own discrepancy and resolve. Please mark a supportive answer in this thread.

    Best Regards,


     

    Steve Kline
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Product Specialist
    Microsoft Certified Network Product Specialist
    Red Hat Certified System Administrator
    This posting is "as is" without warranties and confers no rights.

    • Marked as answer by glimmertwins Thursday, March 17, 2011 7:53 PM
    Tuesday, March 15, 2011 8:13 PM
  • Ok the ipconfig for the server is:

     

    Link-local IPv6 Address...: fe80::4164:e0b6:832d:e7c6%10

    IPv4 Address..................: 192.168.1.50

    Subnet Mask...................: 255.255.255.0

    Default Gatway...............: 192.168.1.1

     

     

    the ipconfig for the client is:

     

    IPv6 Address....................: 2002:d026:49cd:1234:8c7:2f51:341d:a630

    Temporary IPv6 Address...: 2002:d026:49cd:1234:64f1:9055:df6e:593a

    Link-local IPv6 Address.....: fe80::8c7:2f51:341d:a630%11

    IPv4 Address....................: 192.168.2.4

    Subnet Mask.....................: 255.255.255.0

    Default Gateway...............: fe80::222:75ff:fe62:3b58%11

                                             192.168.2.1

     

    I'm so lost right now lol

    Thursday, March 17, 2011 7:53 PM
  • Ok the ipconfig for the server is:

     

    Link-local IPv6 Address...: fe80::4164:e0b6:832d:e7c6%10

    IPv4 Address..................: 192.168.1.50

    Subnet Mask...................: 255.255.255.0

    Default Gatway...............: 192.168.1.1

     

     

    the ipconfig for the client is:

     

    IPv6 Address....................: 2002:d026:49cd:1234:8c7:2f51:341d:a630

    Temporary IPv6 Address...: 2002:d026:49cd:1234:64f1:9055:df6e:593a

    Link-local IPv6 Address.....: fe80::8c7:2f51:341d:a630%11

    IPv4 Address....................: 192.168.2.4

    Subnet Mask.....................: 255.255.255.0

    Default Gateway...............: fe80::222:75ff:fe62:3b58%11

                                             192.168.2.1

     

    I'm so lost right now lol


    Your Client and Server are on two different subnets. Is there a router for 192.168.2.0 network connected to 192.168.1.0 network?

    If not, that is why your systems aren't talking. Put your client on the 192.168.1.0 network or the only workaround to allowing both of these systems to talk is to change your Subnet Mask to 255.255.252.0. This would make your Subnet Range from 192.168.0.1 up through 192.168.3.254. Which is 1022 Hosts by the way... bit excessive. Your best bet is to put the client on the 192.168.1.0 network.

     


    Steve Kline
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Product Specialist
    Microsoft Certified Network Product Specialist
    Red Hat Certified System Administrator
    This posting is "as is" without warranties and confers no rights.
    Wednesday, March 23, 2011 3:44 PM
  • RE: Your Client and Server are on two different subnets. Is there a router for 192.168.2.0 network connected to 192.168.1.0 network?

    there is no router connected

     

     

    RE: Your best bet is to put the client on the 192.168.1.0 network.

    what is the best way to put the client on the 192.168.1.0 network? do i change the client IPv4 address? the client is at another location

     

    Tuesday, March 29, 2011 4:05 PM
  • RE: Your Client and Server are on two different subnets. Is there a router for 192.168.2.0 network connected to 192.168.1.0 network?

    there is no router connected

     

     

    RE: Your best bet is to put the client on the 192.168.1.0 network.

    what is the best way to put the client on the 192.168.1.0 network? do i change the client IPv4 address? the client is at another location

     


    There must be a router in this configuration... if you have internet access, then this router should be available.

    What are your port forwarding rules on the firewall at the location of your Remote Desktop Server?


    Steve Kline
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Technology Specialist: Active Directory, Network Infrastructure, Application Platform, Windows 7
    Microsoft Certified Product Specialist & Network Product Specialist
    Red Hat Certified System Administrator
    This posting is "as is" without warranties and confers no rights.
    Friday, April 1, 2011 4:23 PM