none
mdt 2012 static ip RRS feed

  • Question

  • Hello!

    I have a really big problem for my organization. We have static ip addressing and all OS installations should process through static IPs. How to set up static ip in deployment wizard we know, but after all manipulations ztidomainjoin.wsf doesn't work. Windows XP or 7 don't join domain. I think it's because of unnettend.xml and sysprep.inf (no info about ip in them)

    help me with some advice pls

    Saturday, December 28, 2013 12:08 PM

Answers

  • Yuck, Static IP addresses are so 1990's.

    MDT should work with Static IP Addresses, even the ZTIDomainJoin.wsf

    There are two places where the OS will attempt to join to a domain.

    1. MDT will take any domain credentials collected and add them to the unattend.xml file for joining during OOBE.

    2. When MDT starts the "State Restore" phase, the ZTIDomainJoin.wsf script will attempt to join to the domain if not already connected *and* if requested. Typically this will happen if the Domain Join during the OOBE failed, allowing for a retry.

    The Litetouch.wsf script will do a good job of setting the static IP address *before* starting the "State Restore" phase, so if you are having problems, there is something else wrong, MDT should support this scenario. Check the bdd.log file, and verify that the scripts are setting the Static IP addresses before running ZTIDomainJoin.wsf during the state restore in the full OS.

    If you are still having problems reading the BDD.log file, post to a public share like SkyDrive, and share the link here.


    Keith Garner - keithga.wordpress.com

    Monday, December 30, 2013 3:43 AM
    Moderator