locked
SMTP Email -- From Address Issue RRS feed

  • Question

  • Hi All,

    I need to set from address of email exactly as "NO_REPLY_EMAIL [xyz@yahoo.co.uk ]"

    Please let me know any suggestions.

    Thanks

    Friday, February 3, 2012 2:13 PM

Answers

All replies

  • Please see this article:

    The correct format for an e-mail address is:

    Display Name <email@address.com>

     


    If this is helpful or answers your question - please mark accordingly.
    Because I get points for it which gives my life purpose (also, it helps other people find answers quickly)
    • Proposed as answer by Rohit.SharmaModerator Friday, February 3, 2012 4:12 PM
    • Unproposed as answer by BTS User Friday, February 3, 2012 4:58 PM
    • Proposed as answer by Srboslav Wednesday, November 18, 2015 2:03 PM
    Friday, February 3, 2012 2:51 PM
  • Hi,

    That depends in what you are trying to accomplish and What port binding you are using.


    If you use a dynamic port, you have to set SMTP Transport Properties inside a Message Assign Shape, some like this:

    Email(SMTP.Subject) = "Failed error message notification";
    EMail(SMTP.From) = "xyz@yahoo.co.uk";
    EMail(SMTP.EmailBodyFileCharset) = "UTF-8";
    EMail(SMTP.SMTPHost) = "localhost";
    

    If you set to Specify later you have to configure variables for the SMTP send port in the BizTalk Server Administration console as Alastair Grant descrived


    Sandro Pereira
    DevScope | MVP & MCTS BizTalk Server 2010
    http://sandroaspbiztalkblog.wordpress.com/ | @sandro_asp
    Please mark as answered if this answers your question.
    Friday, February 3, 2012 4:09 PM
    Moderator
  • I've tried to set up address to "NO_REPLY_EMAIL [xyz@yahoo.co.uk ]" in SMTP port parameters and it was applied without errors. What is the problem?

    Check there is a space before ']' and before '['. Is that what you want?

    Maybe you've got some errors for this addres? If so, please, provide the error text.


    Leonid Ganeline [BizTalk MVP] BizTalkien: Advanced Questions: have fun - test your knowledge
    Friday, February 3, 2012 7:30 PM
    Moderator
  • Hi

    Could you please tell us what is the error message you are getting while setting the email address in the port? Because i see no issues in the suggestions provided by Leonid & Sandro above ?

    Please could you give more details about the error in suspended message/or from event log if possible?

    Thanks, Naushad (MCC/MCTS) http://alamnaushad.wordpress.com |@naushadalam

    If this is helpful or answers your question - please mark accordingly.


    Thursday, February 9, 2012 10:54 PM
    Moderator
  • Hi,

    What exact answer/solution are you looking for? Please respond to questions asked by Leonid! Either set the address in orchestration or in the send port, when configuring the SMTP Adapter.

    Cheers,

    Steef-Jan Wiggers

    MVP & MCTS BizTalk Server 2010

    http://soa-thoughts.blogspot.com/ | @SteefJan

    If this answers your question please mark it accordingly


    BizTalk

    Saturday, March 17, 2012 10:54 AM
    Moderator
  • I am using BT 2013 and Display Name <email@address.com> worked for me (with <> braces, but did not work with [] braces). Thanks!
    Wednesday, November 18, 2015 2:05 PM
  • Ideally there shouldn't be any problem with [] braces but could you please let us know if you are getting any particular error message?

    And where are you setting this From address? In orchestration or in Send port configurations?


    Thanks,
    Prashant

    My BizTalk Blog
    -------------------------------------------------------------------------
    Please mark this post accordingly if it answers your query or is helpful.

    Thursday, November 19, 2015 4:41 PM