locked
Can't open documents with Office 2010 and SPD 2013 RRS feed

  • Question

  • So I've found a bunch of posts about this issue but no resolutions.  If you install SPD 2013 on a machine with Office 2010, it breaks the ability to open office files inside SharePoint 2013 libraries using the client application. 

    Instead of the file being opened, you get a "Webpage cannot be displayed" error message, with a URL such as:

    excel:ofe|u|http://domainname/sitename/libraryname/documentname.xlsx
    OR
    msword:ofe|u|http://domainname/sitename/libraryname/test-word-document.docx

    There is a work-around for Lync 2013 or Project 2013, you can install these applications without the "Office Tools->Microsoft SharePoint Foundation support" option.  To do this choose the Customize option on Installation and then under Office Tools, select Not Available for the Microsoft SharePoint Foundation support.  Although you can try this for SPD 2013 as well, even though you choose to not install this component, it still installs and breaks the open office file functionality.

    Since you cannot use SPD 2010 to open SharePoint 2013 workflows, I have no idea how to resolve this.  Our company is currently using Office 2010 and I doubt we will upgrade to Office 2013 for awhile.  Any ideas would be greatly appreciated!


    Nick Hurst

    Monday, July 15, 2013 5:58 PM

All replies

  • after installing SPD 2013.. did you try running a repair on office 2010.

    that may fix the bindng issue with other office documents like word and excel


    val it: unit=()

    Monday, July 15, 2013 6:10 PM
  • Yeah and unfortunately it doesn't fix the issue.  Thanks. 

    Nick Hurst

    Monday, July 15, 2013 7:04 PM
  • One  solution might be, if you have office 2010 x86 bit version then install spd 2013 x64 bit, which might not do problem with other x86 bit version dll's and can work fine with files also

    Note: I have not tried it, this is just suggestion.

    Regards,

    Vikas Patel.


    Regards, Vikas Patel

    Monday, July 15, 2013 8:05 PM
  • Microsoft prevents you from mixing 64-bit and 32-bit installations, even if they are different versions.  I've even tried coping the functioning OWSSUPP.DLL (before SPD 2013 install) and then replacing the new OWSSUPP.DLL file (after SPD 2013 install) with the old one.  Still doesn't work.  Deleting the OWSSUPP.DLL file and running repair on the Office 2010 install doesn't fix the issue either. 

    I cannot believe that Microsoft hasn't fixed this issue, this is a huge issue for organizations that aren't ready to move to Office 2013 yet.  So basically anyone that wants to create or edit workflows on SharePoint 2013, can no longer edit nor view documents stored on SharePoint 2013 using the office applications.  That is a horrible user experience for all SPD users.  There are numerous posts about this going back months now, but still no fixes from Microsoft.  

    Sorry about the little rant but I've spent a ton of time trying to get this issue resolved with no success and am pretty frustrated.  If anyone has any other ideas please let me know.  Thanks.     

    Nick Hurst

    Thursday, July 18, 2013 9:00 PM
  • The Repair Office worked for me!
    Thursday, December 19, 2013 3:22 PM
  • We are facing the same issue... It's really bad.. The repair didn't work for me as well..

    There's a workaround that worked for me though. Instead of clicking the "Title" or "Document" Name in the library, if you have "Document ID" enabled and it's in the default view if you click the Document ID instead  you will get a prompt to "Open" or "Save" it.

    Try it..


    AJ MCTS: SP 2010 Configuration MCSA: Windows 7 If you find this post useful kindly please mark it as an answer :) TY

    Thursday, December 19, 2013 3:32 PM
  • It would appear that two things need to occur to fix having SPD 2013 installed with Office 2010. 

    First you need to make sure that your office installation is fully updated/patched with the Important updates.  What we found is Office patches were not being automatically installed because of our organization group policy settings.  Then once all important updates have been installed, run repair office. 

    This seems to fix the issue with Word, Excel and PowerPoint files being able to be opened in the client application using IE.  And the only thing I can tell you about the version of IE, is this should fix this working with IE 9, 10 and 11 32bit browsers.  I'm not sure about IE8. 

    What this does not fix, is the mapping to InfoPath 2010 though.  So the links in the List options tab to "Customize Form" just returns the familiar Webpage cannot be displayed message in IE with the URL starting with:
    ms-infopath:csl|u|http

    It also doesn't fix the Advanced Setting link in Form Libraries, where you should be able to click on the 'Edit Template' link to edit the InfoPath form associated with the library.  That also returns the Webpage cannot be displayed message. 

    I guess our next thing to test is upgrading to InfoPath 2013 as well.  Ugh, our internal documentation on what you have to do to install SharePoint Designer 2013 and still have everything work is getting ridiculous...... 


    Nick Hurst


    • Edited by Nick Hurst Friday, December 20, 2013 6:10 PM
    Friday, December 20, 2013 6:09 PM