none
Missing System Protection on DPM RRS feed

  • Question

  • Hi.

    Since a couple of days, I'm unable to select the 'System Protection' (with or without Bare Metal recovery) on some of my servers and/or the 'All Shares/All Volumes' option is not available; in others, I can select only 'System Protection':


    If SQL is installed, I'm able to select the SQL instance and databases....

    I used DPM since version 2010 with no issue and I haven't installed any upgrade, recently, as far as I can remember....

    I'm on a Windows Server 2012R2 + DPM 2012R2 (both with all updates) + Agent 4.2.1292.0.

    Any clue is appreciated, thanks.

                  Enrico

    Monday, March 30, 2015 11:58 AM

Answers

  • Hi Enrico,

    I did not find a powershell cmdlet for refreshing yet. In the meantime from the following article:

    Protecting Hyper-V Machines

    http://technet.microsoft.com/en-us/library/ff634200.aspx

    We should able to disable caching as it will be enabled after creating this key on the DPM server:

    HKLM\Software\Microsoft\Microsoft Data Protection Manager\Configuration\CacheInquiryResults

    As we should still need the caching, we can also change the caching time-out. The default time-out for the cache is 48 hours. You can change this by adding a InquiryResultsTimeoutInterval to the registry.
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Configuration\CacheInquiryResults. 

    Under the above key, create the value: InquiryResultsTimeoutInterval:REG_DWORD:XX  (in Hours).


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EnricoZogno Tuesday, March 31, 2015 10:14 AM
    Tuesday, March 31, 2015 9:12 AM
    Moderator

All replies

  • Hi,

    try to reboot one of your affected Servers, refresh ProtectionGroup or clear Cache and check again.

    VSS Service shoul cause the Problem on the affected Servers


    Seidl Michael | http://www.techguy.at | twitter.com/techguyat | facebook.com/techguyat | youtube.com/techguyat

    Tuesday, March 31, 2015 5:48 AM
  • Hi Seidi.

    I solved refreshing the cache. Now I'm looking for a powershell command (if exists) to refresh the whole cache to avoid refreshing servers one by one.

            Enrico

    Tuesday, March 31, 2015 7:02 AM
  • Hi Enrico,

    I did not find a powershell cmdlet for refreshing yet. In the meantime from the following article:

    Protecting Hyper-V Machines

    http://technet.microsoft.com/en-us/library/ff634200.aspx

    We should able to disable caching as it will be enabled after creating this key on the DPM server:

    HKLM\Software\Microsoft\Microsoft Data Protection Manager\Configuration\CacheInquiryResults

    As we should still need the caching, we can also change the caching time-out. The default time-out for the cache is 48 hours. You can change this by adding a InquiryResultsTimeoutInterval to the registry.
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Configuration\CacheInquiryResults. 

    Under the above key, create the value: InquiryResultsTimeoutInterval:REG_DWORD:XX  (in Hours).


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by EnricoZogno Tuesday, March 31, 2015 10:14 AM
    Tuesday, March 31, 2015 9:12 AM
    Moderator
  • Thanks Shaon.

    I'll managed this situation using the registry key you provided me....

    Tuesday, March 31, 2015 10:14 AM