locked
Upgrade OS RRS feed

  • Question

  • Hi,

    Right now I have my domain functional level is Windows 2008 R2.My ADFS and ADFS Proxy servers are also Windows 2008 R2 with ADFS 2.0. Now I want to upgrade my all DCs to Windows 2016 and domain functional level to Windows 2016. If we want to do this, do we need to upgrade ADFS server? How we can upgrade ADFS server to Windows 2016 and ADFS 3.0.

    Please help me out.

    Thursday, March 7, 2019 12:13 AM

All replies

  • Hello,

    the requirement is that domain controllers in which the ADFS Server is joined must be 2008 or later and the minimum DFL is 2003 or higher.

    It would be a good idea to migrate your adfs servers after you move to 2016. Here are some migration guides

    https://blog.kloud.com.au/2017/02/01/adfs-v-2-0-migration-to-adfs-2016/

    Hope that helps


    Isaac Oben MCITP:EA, MCSE,MCC <a href="https://www.mcpvirtualbusinesscard.com/VBCServer/4a046848-4b33-4a28-b254-e5b01e29693e/interactivecard"> View my MCP Certifications</a>

    Friday, March 8, 2019 5:39 AM
  • Thank you.

    Wednesday, March 13, 2019 2:56 PM