locked
How do I force Word 2016 to Spellcheck everything that is pasted from another document? RRS feed

  • Question

  • Long story short we had a user update to Office 2016 from 2010. 

    Whenever they would take a document that had portions of the document listed to not spellcheck and paste to a new document they would see that that portion was never spellchecked. I have managed to find a work around (since if you do not copy the formatting after pasting it forces spellcheck to work again) but I was hoping for an easier more permanent solution. 

    We have enabled spellchecking on the entire document that the portion is pasted to but it still does not seem to resolve the issue, only pasting it and then changing the formatting to "Merge" or "Text Only" forces a spellcheck. I have found 0 results online and am hoping someone may be able to answer my question here. I have gone through and forced Word to Recheck through proofing and selecting the entire portion I copied over and turning spellcheck back on but it does not solve the issue. The only that that does is pasting and then selecting the clipboard and either "Merge" or "Text Only".

    Any ideas are greatly appreciated.  

    Monday, December 12, 2016 6:02 PM

All replies

  • Your description suggests the content's language setting in the source document might be set to 'no proofing' (i.e. don't check spelling or grammar). After you've finished copying & pasting, select the entire document (Ctrl-A), then go to Review|Language|Set Proofing Language and make sure the 'don't check spelling or grammar' option is NOT checked. You might also need to re-set the 'Recheck Document' option. The following macro shows how you can enforce proofing in Word for USEnglish:

    Sub ForceProofing()
    With ActiveDocument.Range
      'Set the proofing language
      .LanguageID = wdEnglishUS
      'Tell Word the spelling and grammar checker is not to ignore any text
      .NoProofing = False
      'Tell Word document has not been checked for spelling
      .SpellingChecked = False
      'Tell Word document has not been checked for grammar
      .GrammarChecked = False
    End With
    'Tell Word to automatically detect the language you are using as you type
    Application.CheckLanguage = True
    'Clear the list of words that were previously ignored during a spelling check.
    Application.ResetIgnoreAll
    End Sub

    You can change the language to whatever language you prefer and you can either change the True/False options to enforce a particular arrangement or comment-out/delete those lines to leave things as they are. Added to Word's Normal template, the macro will be available for use with all documents. Once you have the macro configured the way you like it, you could even assign it to a keyboard shortcut.

    For PC macro installation & usage instructions, see: http://www.gmayor.com/installing_macro.htm
    For Mac macro installation & usage instructions, see: http://word.mvps.org/Mac/InstallMacro.html


    Cheers
    Paul Edstein
    [MS MVP - Word]

    • Proposed as answer by Steve Fan Tuesday, December 13, 2016 9:15 AM
    Tuesday, December 13, 2016 6:33 AM
  • Hi Zac,

    Please check if Paul's reply is helpful to your question. If you need further assistance, please don't hesitate to post back.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 14, 2016 7:43 AM
  • The spell-check setting ("do not check spelling or grammar") is like character formatting. If you paste text with this keeping formatting, you keep this setting.

    Paul's macro will work after-the fact. So will pressing Ctrl+A to select all text and then resetting the proofing language setting. Note that text in textboxes and in headers and footers will not be changed using Ctrl+A. There are probably other structures that it does not pick up as well.


    Charles Kenyon Madison, WI

    • Proposed as answer by Stefan BlomMVP Monday, December 19, 2016 12:54 PM
    Wednesday, December 14, 2016 9:53 PM