none
DPM 2010 - Error ID 2019 - Details: An existing connection was forcibly closed by the remote host (0x80072746) RRS feed

  • Question

  • Hello,
    I have a unique PG for my fileserver that runs full backup every night 07 PM.
    The backup is scheduled on long-term retention and has a week to daily frequency.
    The volume of data it has to bring the tape is approximately 500GB.

    Use a Backup Tape Library for HP LTO-4 drive (800GB/1.6TB)

    The backup has failed every night with the message: - (ID 2019 - Details: An existing connection Was Forcibly closed by the remote host (0x80072746))

    In Event Viewer it creates an error:
    Source: DPM-EM
    EventID: 3311
    Level: Error
    General: The back up to tape job failed for the Following Reason: (ID: 3311) (ID: 2019)

    All other four are working perfectly PG which ensures the functioning of hardare server and tape library. (Example: PG VMs - 1.3 TB, 600GB States System, Full Daily backup too).

    What can I do to fix the problem?

    Thanks, Nelson Rodrigo
    Tuesday, August 3, 2010 12:06 PM

Answers

  • Try disabling TCP Chimney on both the DPM server and the Protected server.

    On 2003 the command is: Netsh int ip set chimney DISABLED
    On 2008 the command is: Netsh int tcp set global chimney=disabled

     

    Also enable network bandwidth throtting under the agents tab for that protected server.

    There are different channels for the control and data information that passes between the DPM server and a protected server. The control path uses the DCOM (RPC) channel, and the data path uses TCP/IP. If the data path completely saturates the network (even for a short duration), DCOM calls may fail. If the calls fail, this causes the job to fail. To avoid this problem, enable throttling for the protected servers to limit the network usage of the data path to 85 percent.

    By default, throttling is not enabled in DPM because throttling requires Quality of Service (QoS) to be installed on both the DPM server and the protected server.

    If the 85 percent setting does not resolve the issue completely, increase the throttling level of the protected server that has the problem.

    If this solution does not resolve the problem, the DPM server maybe overloaded. Try to reorganize the protection groups so that backups are staggered, or so that synchronizations occur at staggered times.

     


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, August 3, 2010 3:38 PM
    Moderator
  • OK try this.

     

    Add DWORD with name "ConnectionNoActivityTimeout" in path "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent" and set the value to 180 on PS.

     

       Windows Registry Editor Version 5.00

       [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
       "ConnectionNoActivityTimeout"=dword:0000180

     

    Restart DPMRA service on PS


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, August 4, 2010 2:30 PM
    Moderator

All replies

  • Hi Nelson,

    can you provide some more details?

    what is the datasource type? you only do tape based backups? what is the OS of the protected server?

    regards,

    Alex

    Tuesday, August 3, 2010 12:24 PM
  • Try disabling TCP Chimney on both the DPM server and the Protected server.

    On 2003 the command is: Netsh int ip set chimney DISABLED
    On 2008 the command is: Netsh int tcp set global chimney=disabled

     

    Also enable network bandwidth throtting under the agents tab for that protected server.

    There are different channels for the control and data information that passes between the DPM server and a protected server. The control path uses the DCOM (RPC) channel, and the data path uses TCP/IP. If the data path completely saturates the network (even for a short duration), DCOM calls may fail. If the calls fail, this causes the job to fail. To avoid this problem, enable throttling for the protected servers to limit the network usage of the data path to 85 percent.

    By default, throttling is not enabled in DPM because throttling requires Quality of Service (QoS) to be installed on both the DPM server and the protected server.

    If the 85 percent setting does not resolve the issue completely, increase the throttling level of the protected server that has the problem.

    If this solution does not resolve the problem, the DPM server maybe overloaded. Try to reorganize the protection groups so that backups are staggered, or so that synchronizations occur at staggered times.

     


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, August 3, 2010 3:38 PM
    Moderator
  • Hello Alex,
    Sure, thank you for your attention.

    The data source is a file server, this Protection Group is composed of some selected folders in drive X: the Protected Server.

    The Protected Server is a virtual machine, you have installed Windows 2008 SP2.

    I've ran the steps that our friend "Mike J" asked about CHIMNEY disable and enable Throlttle to 85%, but still is giving the same error.

    Any ideas?

    Att
    Nelson
    Wednesday, August 4, 2010 1:02 PM
  • Hi Nelson,

    are there any clues on the protected server things like log files and eventvwr round the time the error appears?

    regards,

    Alex

    Wednesday, August 4, 2010 1:08 PM
  • Hello Mike, thank you for your attention.

    The data source is a file server, this Protection Group is composed of some selected folders in drive X: the Protected Server. The Protected Server is a virtual machine, you have installed Windows 2008 SP2.

    Only being made tape-based backups, as the DPM server is not available to local disk backups.

    I performed the steps to disable and enable CHIMNEY Throlttle to 85%, but still is giving the same error. The QoS was already enabled on both servers.

    Any ideas?

    Att
    Nelson

    Wednesday, August 4, 2010 1:08 PM
  • OK try this.

     

    Add DWORD with name "ConnectionNoActivityTimeout" in path "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent" and set the value to 180 on PS.

     

       Windows Registry Editor Version 5.00

       [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
       "ConnectionNoActivityTimeout"=dword:0000180

     

    Restart DPMRA service on PS


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, August 4, 2010 2:30 PM
    Moderator
  • Hi Alex,

    Yes, has some Information events in the System Log a few seconds after the time set out in the schedule of error in the DPM console.

    Event ID: 7036 - Copy Service Volume Shadow entered the stopped state
    Event ID: 7036 - The service entered the stopped state DPMRA

    It say something for you?

    Att, Nelson

    Wednesday, August 4, 2010 5:42 PM
  • Hello Mike,

    I created the registry key as requested.
    Just saw something in the service DPMRA Protected Server is in manual startup mode, is this normal? I have started and stopped him for sure.

    I will await the scheduling of this PG is to perform tonight.
    Amah inform you as the job status.

    Thanks, Nelson
    Wednesday, August 4, 2010 5:45 PM
  • Hi,

     

    Yes, DPMRA is always set for manual.  It will stop when there is nothing to do and start on demand when a DCOM request comes in from the DPM server.

    Lets see if that reg key works for you. 


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, August 4, 2010 7:24 PM
    Moderator
  • Hi Nelson,

     

    I am closing this thread. Please feel free to reopen if the proposed solution does not helps u. 

    thanks,

    Parag

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, August 6, 2010 10:11 AM
    Moderator
  • Hello Mike,

    Thanks, after setting in the Registry of the PS that the backup PG is working OK.

    Att.

    Nelson

     

    Monday, August 9, 2010 6:41 PM
  • Reopening an old topic; I have the same problem, Tried the solutions above, but they didn't help.

    Server causing me headaches is a file-server running 2008.

    Any tips?


    Please visit http://www.bleumer.eu
    Thursday, April 14, 2011 7:34 AM
  • OK try this.

     

    Add DWORD with name "ConnectionNoActivityTimeout" in path "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent" and set the value to 180 on PS.

     

       Windows Registry Editor Version 5.00

       [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
       "ConnectionNoActivityTimeout"=dword:0000180

     

    Restart DPMRA service on PS


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    I have a similar situation, getting the same "connection was forcibly closed by remote host" error, but my issue is slightly different in that I have a primary DPM 2010 backing up several virtual servers, with a secondary DPM 2010 backing up those backups offsite.  The secondary backup job keeps resulting in this error, but only for 1 of the virtual servers.

    Does anyone know if this registry fix is expected to work on a 64 bit Server 2008 R2 DPM 2010 machine?  ...if so, should I use QWORD (64 bit) instead of DWORD (32 bit)?  I tried creating a DWORD and it didn't seem to work.


    • Edited by Jim Nasium Tuesday, September 20, 2011 4:42 PM
    Tuesday, September 20, 2011 4:41 PM
  • Jim,

    I have been having plenty of DPM2010 errors and currently working with Microsoft on it. I am using a NetApp 2040 configured using iSCSI connected to a 6 node cluster running Windows DataCeneter 2008R2 SP1 running 29 VM's. I have never had this error happen 0x80072746 until today. What I did to resolve it was run the following command on my DPM2010 server and all 6 Nodes as an elevated administrator on the command prompt and the backup ran fine when I reran the job.

    Netsh int tcp set global chimney=disabled

    A couple of thing that might help is make sure you have updated to the newest version of DPM 3.0.7707.0 on the server and agents
    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=20953

    Also some other updates I have added to the Cluster recently are the following which have solved some other issues I have been having due to iSCSI.

    http://support.microsoft.com/kb/2494016
    http://support.microsoft.com/kb/2494162
    http://support.microsoft.com/kb/2520235
    http://support.microsoft.com/kb/2531907 

    One last think to do is to check if you are using Hardware VSS or Software VSS. Again as an elevated admin in the command prompt run the following command

    vssadmin list providers

    If you are using Microsoft VSS then you should be fine. If another provider is listed make sure you are using the most recent version from them. For me I had to update to SnapDrive 6.3.1R1, which again solved more problems I was having.

    Good Luck!

    Joey

     

    Tuesday, September 20, 2011 7:31 PM
  • I'm facing the same issues, Joey did you have to restart your HyperV servers after upgrading snapdrive to the latest version?
    Sunday, October 16, 2011 7:48 AM
  • After applying:

    On 2003 the command is: Netsh int ip set chimney DISABLED
    On 2008 the command is: Netsh int tcp set global chimney=disabled

    And

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent]
     "ConnectionNoActivityTimeout"=dword:0000180

    I got this "Pending" thing, the error event log still said "ID 2019 Details: An existing connection was forcibly closed by the remote host (0x80072746)"

     


    • Edited by Oneoa Friday, December 2, 2011 2:15 AM
    Friday, December 2, 2011 2:12 AM