locked
Computers not fully reporting back. RRS feed

  • Question

  • Good afternoon,

     

    I have had pretty good luck installing SCE/SP1 and getting it to work with the workstations in my domain.   I have 6 (out of 365) pesky machines that report back that they are still active but give no other status.  I can not get a hardware or software inventory and likewise the workstations have no status when it comes to updates.  I've combed through the boards and have pretty much done all the troubleshooting things that were suggested.   From stopping/restarting the Automatic update services, to deleting registry keys.   Below is the portion of the windows update log that I think is causing the problem.  It's the only part that has actual error messages.  Well at least to me nothing else in the log appears to be an error.  So, if anyone could help me out or offer a suggestion, I would greatly appreciate it.

     

    2008-04-10          10:24:49-0400    1176       f08          AU received event of 1

    2008-04-10          10:24:49-0400    1176       f08          WU client succeeds CClientCallRecorder::BeginFindUpdates from AutomaticUpdates with call id {A47A54B3-949D-4DB5-9662-52E583126BC0}

    2008-04-10          10:24:49-0400    1176       6dc         WU client executing call {A47A54B3-949D-4DB5-9662-52E583126BC0} of type Search Call

    2008-04-10          10:24:52-0400    1176       6dc         Send failed with hr = 80072efd.

    2008-04-10          10:24:52-0400    1176       6dc         SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>

    2008-04-10          10:24:53-0400    1176       6dc         Send failed with hr = 80072efd.

    2008-04-10          10:24:53-0400    1176       6dc         SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>

    2008-04-10          10:24:54-0400    1176       6dc         Send failed with hr = 80072efd.

    2008-04-10          10:24:54-0400    1176       6dc         SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>

    2008-04-10          10:24:55-0400    1176       6dc         Send failed with hr = 80072efd.

    2008-04-10          10:24:55-0400    1176       6dc         SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>

    2008-04-10          10:24:55-0400    1176       6dc         DownloadFileInternal failed for https://HQNT-SCE07.XXXXXXX.org:8531/SelfUpdate/wuident.cab: error 0x80072efd

    2008-04-10          10:24:55-0400    1176       6dc         IsUpdateRequired failed with error 0x80072efd

    2008-04-10          10:24:55-0400    1776       cf8          Trying to make out of proc datastore active

    2008-04-10          10:24:55-0400    1776       cf8          Out of proc datastore is now active

    2008-04-10          10:24:56-0400    1176       6dc         PT: Using serverID {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}

    2008-04-10          10:24:56-0400    1176       6dc         WU client failed Searching for update with error 0x80248008

    2008-04-10          10:24:56-0400    1176       6dc         Search Callback Failed, hr is 0x80248008

     

    Thanks,


    Mike

    Thursday, April 10, 2008 6:09 PM

Answers

  • Hi Mike,

     

    Thanks for your information.

     

    I would like to suggest that you to check the following:

     

    1. If the problematic clients were deployed by imageX or RIS, please check the following KB article as a test:

     

    A Windows 2000-based or Windows XP-based computer that was set up by using a Windows 2000 or Windows XP image does not appear in the Windows Server Update Services (WSUS) console
    http://support.microsoft.com/kb/903262/en-us

     

    2. Check IIS settings, make sure the virtual folder "Self Update" existing.

     

    3. Delete the network devices in SCE console\Administration\Device management if there are any.

     

    4. Download AU TOOLS from the following address(Choose receive from Microsoft):

     

    Workspace URL: https://sftasia.one.microsoft.com/choosetransfer.aspx?key=e02b46f5-ac9b-4f04-adbf-a724ae65e914
    Password: *xQST30wiHHCBk^@

     

    Run it on problematic clients.

     

    Hope it helps.

     

     

    Tuesday, April 15, 2008 7:57 AM

All replies

  • Hi Mike,

     

    The error code indicate that the issue is related to the proxy. Please check the proxy setting in your deployment environment. If there is no proxy server, please perform the following:

     

    1. Open Internet Explorer.
    2. On the Tools menu, click Internet Options.
    3. Click the Connections tab, and then click LAN Settings.
    4. In the Local Area Network (LAN) Settings dialog box, click to select the Automatically detect settings check box, and then click OK.
    5. Quit Internet Explorer.
    6. Click Start, click Run, type cmd , and then click OK.
    7. Type the following commands. Press ENTER after each command.
    a. proxycfg -d
    b. net stop wuauserv
    c. net start wuauserv
    d. wuauclt /detectnow
    e. exit

     

    For more information on proxycfg, you may review:


    900935 How the Windows Update client determines which proxy server to use to connect to the Windows Update Web site
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;900935

     

    After that, please perform the following steps:

     

    1. Clearing the BITS queue:
    To clear the BITs queue, you can use the steps outlined in the following:
    920649 You cannot download new updates from a server that is running Windows Server Update Services
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;920649

     

    2. To rename the SoftwareDistribution folder and start a WSUS detection:
    1) Open a command prompt and run this command: net stop wuauserv
    2) Browse to the file system to the %windir%t directory and rename the SoftwareDistribution directory
    3) Open a command prompt and run the following commands:
     net start wuauserv
     wuauclt /detectnow

     

    After performing mentioned above, please check if it works.

     

    Hope it helps.

    Monday, April 14, 2008 8:51 AM
  • Thanks so much for your reply.   I did as you instructed but it didn't solve the problem.   I even went so far as to reinstall the agent but no luck.   There is no proxy server configured and that was confirmed when I ran the proxycfg -d command.  I've attached the entire log, and the error message about the proxy is still the same.   It's just so bizzare that I only have a handful of these computers that are causing me this problem.  It's probably 3-4% of the total computers that are listed in the console.

     

    2008-04-14 09:25:06-0400 1176 f84 Service Main starts
    2008-04-14 09:25:06-0400 1176 f84 Using BatchFlushAge = 29321.
    2008-04-14 09:25:06-0400 1176 f84 Using SamplingValue = 140.
    2008-04-14 09:25:06-0400 1176 f84 Successfully loaded event namespace dictionary.
    2008-04-14 09:25:06-0400 1176 f84 Successfully loaded client event namespace descriptor.
    2008-04-14 09:25:06-0400 1176 f84 Successfully initialized local event logger. Events will be logged at C:\WINDOWS\SoftwareDistribution\ReportingEvents.log.
    2008-04-14 09:25:06-0400 1176 f84 Successfully initialized NT event logger.
    2008-04-14 09:25:06-0400 1176 f84 Successfully initialized event uploader 0.
    2008-04-14 09:25:06-0400 1176 f84 Successfully initialized event uploader 1.
    2008-04-14 09:25:06-0400 1176 f84 WU client with version 5.4.3790.2182 successfully initialized
    2008-04-14 09:25:06-0400 1176 f84 Service status is now SERVICE_RUNNING
    2008-04-14 09:25:06-0400 1176  ec Failed to open event cache file at C:\WINDOWS\SoftwareDistribution\EventCache\{D7618063-F509-4E91-A1CB-A4E346E68C60}.bin for reading with hr = 80070002.
    2008-04-14 09:25:06-0400 1176  ec Attempted to delete event cache file at C:\WINDOWS\SoftwareDistribution\EventCache\{D7618063-F509-4E91-A1CB-A4E346E68C60}.bin but the file could not be found. hr = 80070002.
    2008-04-14 09:25:19-0400 2320 dc4 Trying to make out of proc datastore active
    2008-04-14 09:25:21-0400 2320 dc4 Service 3DA21691-E39D-4DA6-8A4B-B43877BCB1B7 added
    2008-04-14 09:25:22-0400 2320 dc4 Service 9482F4B4-E343-43B6-B170-9A65BC822C77 added
    2008-04-14 09:25:22-0400 2320 dc4 Data store successfully created
    2008-04-14 09:25:22-0400 2320 dc4 Out of proc datastore is now active
    2008-04-14 09:25:22-0400 1176 c98 Client Call Recorder finished delayed initialization
    2008-04-14 09:25:22-0400 1176 c98 Setting AU scheduled install time to 2008-04-15 07:00:00
    2008-04-14 09:25:22-0400 1176 c98 AU finished delayed initialization
    2008-04-14 09:25:22-0400 1176 c98 Triggering AU detection through DetectNow api
    2008-04-14 09:25:22-0400 1176 f84 AU received event of 1
    2008-04-14 09:25:22-0400 1176 f84 WU client succeeds CClientCallRecorder::BeginFindUpdates from AutomaticUpdates with call id {822A58EE-87CA-4F63-BC6E-E7971FB23278}
    2008-04-14 09:25:22-0400 1176  ec WU client executing call {822A58EE-87CA-4F63-BC6E-E7971FB23278} of type Search Call
    2008-04-14 09:25:25-0400 1176  ec Send failed with hr = 80072efd.
    2008-04-14 09:25:25-0400 1176  ec SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
    2008-04-14 09:25:26-0400 1176  ec Send failed with hr = 80072efd.
    2008-04-14 09:25:26-0400 1176  ec SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
    2008-04-14 09:25:27-0400 1176  ec Send failed with hr = 80072efd.
    2008-04-14 09:25:27-0400 1176  ec SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
    2008-04-14 09:25:28-0400 1176  ec Send failed with hr = 80072efd.
    2008-04-14 09:25:28-0400 1176  ec SendRequest failed with hr = 80072efd. Proxy List used: <(null)> Bypass List used : <(null)>
    2008-04-14 09:25:28-0400 1176  ec DownloadFileInternal failed for https://HQNT-SCE07.xxxxx.org:8531/SelfUpdate/wuident.cab: error 0x80072efd
    2008-04-14 09:25:28-0400 1176  ec IsUpdateRequired failed with error 0x80072efd
    2008-04-14 09:25:28-0400 1176  ec OS Version = 5.1.2600.2.0.65792
    2008-04-14 09:25:28-0400 1176  ec Computer Brand = Hewlett-Packard
    2008-04-14 09:25:28-0400 1176  ec Computer Model = HP d530 CMT(DC577AV)
    2008-04-14 09:25:28-0400 1176  ec Bios Revision = 786B2 v2.18
    2008-04-14 09:25:28-0400 1176  ec Bios Name = 786B2 v2.18
    2008-04-14 09:25:28-0400 1176  ec Bios Release Date = 2004-01-15T00:00:00
    2008-04-14 09:25:28-0400 1176  ec Locale ID = 1033
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: iuengine.dll = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wuapi.dll = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wuauclt.exe = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wuauclt1.exe = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wuaucpl.cpl = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wuaueng.dll = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wuaueng1.dll = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wuauserv.dll = 5.4.3790.2180
    2008-04-14 09:25:28-0400 1176  ec ClientVersion: wucltui.dll = 5.4.3790.2182
    2008-04-14 09:25:28-0400 1176  ec PT: Using serverID {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}
    2008-04-14 09:25:28-0400 1176  ec PT: Using server URL https://HQNT-SCE07.xxxxx.org:8531/ClientWebService/client.asmx
    2008-04-14 09:25:28-0400 1176  ec PT: Calling GetConfig on server
    2008-04-14 09:25:28-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:28-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:28-0400 1176  ec PT: Using server URL https://HQNT-SCE07.xxxxx.org:8531/SimpleAuthWebService/SimpleAuth.asmx
    2008-04-14 09:25:28-0400 1176  ec DetectCompressionType returning type 0, hr=0x1
    2008-04-14 09:25:28-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:28-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:28-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:28-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:28-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:28-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:29-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:29-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:29-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:29-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:29-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:29-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:29-0400 1176  ec Add header for accept-encoding: xpress succeeded
    2008-04-14 09:25:29-0400 1176  ec DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:25:29-0400 1176  ec Parse failed: error 0x80070057
    2008-04-14 09:25:29-0400 1176  ec Parse failed with 0x80070057

    2008-04-14 09:25:29-0400 1176  ec Sync of Updates: 0x80070057
    2008-04-14 09:25:29-0400 1176  ec WU client failed Searching for update with error 0x80070057
    2008-04-14 09:25:29-0400 1176  ec Search Callback Failed, hr is 0x80070057
    2008-04-14 09:25:29-0400 1176  ec Setting next AU detection timeout to 2008-04-14 18:25:29
    2008-04-14 09:25:29-0400 1176  ec Setting AU scheduled install time to 2008-04-15 07:00:00
    2008-04-14 09:25:29-0400 1176  ec WU client calls back to search call AutomaticUpdates with code Call failed and error 0x80070057
    2008-04-14 09:25:29-0400 1176  ec WU client completed and deleted call {822A58EE-87CA-4F63-BC6E-E7971FB23278}
    2008-04-14 09:25:33-0400 1176  ec REPORT EVENT: {B3C57847-6E06-41C9-B6E1-E8B1BB8EE194} 911 2008-04-14 09:25:28-0400 1 148 101 {D67661EB-2423-451D-BF5D-13199E37DF28} 0 80072efd SelfUpdate Failure Software Synchronization Error: Agent failed detecting with reason: 0x80072efd
    2008-04-14 09:25:33-0400 1176  ec REPORT EVENT: {A493443C-8F7D-4DDC-BEB9-58C8A928532D} 912 2008-04-14 09:25:29-0400 1 148 101 {00000000-0000-0000-0000-000000000000} 0 80070057 AutomaticUpdates Failure Software Synchronization Error: Agent failed detecting with reason: 0x80070057
    2008-04-14 09:25:33-0400 1176  ec Reopened existing event cache file at C:\WINDOWS\SoftwareDistribution\EventCache\{D7618063-F509-4E91-A1CB-A4E346E68C60}.bin for writing.
    2008-04-14 09:25:33-0400 1176  ec Reopened existing event cache file at C:\WINDOWS\SoftwareDistribution\EventCache\{35B40AC6-F0B5-499B-8EF4-3F0D880D905D}.bin for writing.
    2008-04-14 09:25:38-0400 3204 a8c 0 updates are ready to be installed at shutdown.
    2008-04-14 09:25:42-0400 1176 49c Service received logoff notification
    2008-04-14 09:25:42-0400 1176 f84 AU received event of 3
    2008-04-14 09:25:51-0400 1176 f84 start delayed initialization of WU client
    2008-04-14 09:27:32-0400 1176 6dc Successfully opened event cache file at C:\WINDOWS\SoftwareDistribution\EventCache\{D7618063-F509-4E91-A1CB-A4E346E68C60}.bin for reading.
    2008-04-14 09:27:32-0400 1176 6dc PT: Using serverID {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}
    2008-04-14 09:27:32-0400 1176 6dc PT: Using server URL https://HQNT-SCE07.xxxxx.org:8531/ClientWebService/client.asmx
    2008-04-14 09:27:32-0400 1176 6dc PT: Calling GetConfig on server
    2008-04-14 09:27:32-0400 1176 6dc Add header for accept-encoding: xpress succeeded
    2008-04-14 09:27:32-0400 1176 6dc DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:27:32-0400 1176 6dc PT: Using server URL https://HQNT-SCE07.xxxxx.org:8531/SimpleAuthWebService/SimpleAuth.asmx
    2008-04-14 09:27:32-0400 1176 6dc DetectCompressionType returning type 0, hr=0x1
    2008-04-14 09:27:32-0400 1176 6dc Add header for accept-encoding: xpress succeeded
    2008-04-14 09:27:32-0400 1176 6dc DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:27:32-0400 1176 6dc Add header for accept-encoding: xpress succeeded
    2008-04-14 09:27:32-0400 1176 6dc DetectCompressionType returning type 1, hr=0x0
    2008-04-14 09:27:32-0400 1176 6dc PT: Using serverID {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}
    2008-04-14 09:27:32-0400 1176 6dc Failed to obtain cached url with hr = 80248008.
    2008-04-14 09:27:32-0400 1176 6dc Failed to upload events with hr = 80248008.
    2008-04-14 09:32:32-0400 2320 dc4 Out of proc datastore is shutting down
    2008-04-14 09:32:33-0400 2320 dc4 Out of proc datastore is now inactive

     

    Thanks again for all your help and if you can think of anything else to try, please let me know.

     

    Mike

    Monday, April 14, 2008 1:43 PM
  • Hi Mike,

     

    Thanks for your information.

     

    I would like to suggest that you to check the following:

     

    1. If the problematic clients were deployed by imageX or RIS, please check the following KB article as a test:

     

    A Windows 2000-based or Windows XP-based computer that was set up by using a Windows 2000 or Windows XP image does not appear in the Windows Server Update Services (WSUS) console
    http://support.microsoft.com/kb/903262/en-us

     

    2. Check IIS settings, make sure the virtual folder "Self Update" existing.

     

    3. Delete the network devices in SCE console\Administration\Device management if there are any.

     

    4. Download AU TOOLS from the following address(Choose receive from Microsoft):

     

    Workspace URL: https://sftasia.one.microsoft.com/choosetransfer.aspx?key=e02b46f5-ac9b-4f04-adbf-a724ae65e914
    Password: *xQST30wiHHCBk^@

     

    Run it on problematic clients.

     

    Hope it helps.

     

     

    Tuesday, April 15, 2008 7:57 AM
  • Hi Mike,


    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as 'Answered' as the previous steps should be helpful for many similar scenarios.

     

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    In addition, we'd love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

     

    Thanks!

    Friday, April 18, 2008 3:40 AM