none
UEFI PXE boot with ONLY DHCP options (no ProxyDHCP)! RRS feed

  • Question

  • While there are recommendation (or unsupported setups), I really would like to just use DHCP options for UEFI PXE boot (lets forget that WDS exists! (WDS is not only PXE server that exists, it is not included in this exercise)

    I just want to get it working without router IPhelpers (please do not insist on recommending it over & over)

    Legacy BIOS PXE boot works perfectly with DHCP ONLY options

    43 (010400000000FF)

    60 (PXEClient)

    66 (IP or Hostname of the PXE Server)

    67 (bootfile - it does mean only wdsnbp.com!)

    UEFI PXE fails (with any setups that I tried so far)

    Any pointers would be appreciated

    PXE Forced Mode Utility does not seem to help

    Does option 43 get used at all in UEFI PXE boot with MS DHCP server?

    option 43 for PXE servers

    vendor options - handcrafted

    PXE-ish

    Seb







    Tuesday, February 14, 2017 9:06 AM

Answers

All replies

  • I can see in packet capture that DHCP Reply has correct options for the client:

    ServerIP: 10.0.0.55 (server on which TFTP server is running)

    BootFileName: mybootfile.efi (.efi file that I want the client to use as it boot)

    yet I only get PXE-E16 No offers received on that client!

    Seb

    Tuesday, February 14, 2017 3:48 PM
  • Hi,

    1.I have check that thread about option 43,typically,it could work.And please make sure these port is open:

    UDP - 67, 68, 69, 4011
    TCP - 135, 137, 138, 139, 5040

    You could use portqry(https://www.microsoft.com/en-us/download/details.aspx?id=24009) to check.

    2.Since you're using network capture tools,was there any more information before the error occurred?

    3.What pxe server did you use?WDS pxe server or 3-rd party pxe server?


    Best Regards
    Cartman
    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, February 16, 2017 2:32 AM
  • Isn't it the whole point of this question to have NO PXE Server at all?

    I want to boot with DHCP options ONLY!

    It works perfectly fine for legacy BIOS PXE, I see no valid reason to not work for UEFI PXE boot

    Seb


    • Edited by scerazy Thursday, February 16, 2017 11:48 AM
    Thursday, February 16, 2017 8:48 AM
  • Hi,

    According the article form IBM Knowledge Center:

    Note: Some UEFI targets are not able to correctly process option 43. For those targets it is necessary to set option 66 and 67.

    REF:http://www.ibm.com/support/knowledgecenter/en/SS3HLM_7.1.1.13/com.ibm.tivoli.tpm.osd.doc_7.1.1.13/install/cosd_idhcp.htm

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    Best Regards
    Cartman
    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, February 17, 2017 8:30 AM
  • As already explained, I DO HAVE Options 43/60/66/67 set for legacy BIOS = works perfectly fine

    I also have Options 60/66/67 set for UEFI clients, and even client receives the info from DHCP, it simply gets ignored & boot does NOT happen.

    PXE-E16 No offers received

    If the same boot file (mybootfile.efi) is delivered via PXE server (no matter what the name is!) boot works fine. But I prefer NOT to need to have PXE server

    Seb

    Friday, February 17, 2017 8:10 PM
  • Got it in the end.

    For UEFI boot, in Policy had to REMOVE option 60 & ADD option 150 -TFTP Server IP Address as per

    http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-communications-manager-callmanager/13992-win2000-dhcp.html

    No idea why (as Option 150 should be Cisco only)

    Now my UEFI PXE client boots from what I tell it to boot from!

    Seb





    • Marked as answer by scerazy Saturday, February 18, 2017 11:17 AM
    • Edited by scerazy Saturday, February 18, 2017 5:50 PM
    Saturday, February 18, 2017 11:17 AM