none
MDT using UEFI generates a Failure:5615 RRS feed

  • Question

  • Hi All,
                I'm using MDT 8450, ADK 1809, on a Windows Server 2016 and I'm getting a Failure (5615): False: Boot Drive was not found... Failed to run the action: Install Operating System.

    1. This is a new Dell OptiPlex 7060 and I've tested on three of the same model
    2. Using the latest WinPE10 Drivers
    3. UEFI partition is set to GPT, not MBR.
    4. BIOS is set to boot w/UEFI, Legacy Options ROM turned on, SecureBoot Turned Off, NIC Stack w/PXE Support enabled, AHCI instead of RAID
    5.  Same image of Windows 10 Ent. build 1803 works on OptiPlex 7050 and older as well as Latitude 5480 and older booting into Legacy BIOS.
    6. Operating System installs to 100% and promptly generates the error.  Immediately I run DiskPart and under drive 0 I see the following...

    Volume 0, Letter D, Type DVD-ROM
    Volume 1, Letter E, Label Windows, 460GB, NTFS, Partition
    Volume 2, Letter F, Label Recovery, 5392MB, NTFS, Partition

    For some reason I can't understand, it cannot grab drive letter C.  It appears to format successfully using UEFI and creating the necessary partitions.  According to the LTIApply log, it applies the .WIM file successfully but is unable to find the boot drive.  From the LiteTouch.log, my OS drive is E:\  thus my error.  I'm at a loss at this point as to why this is occurring.  Is something within the Dell BIOS disallowing C:\ to be used?

    Wednesday, October 24, 2018 12:04 AM

All replies

  • I'm actually having the same exact issue on the 7060.  It seems as though MDT isn't setting the boot partition correctly. 
    Wednesday, October 24, 2018 1:41 PM
  • Okay this is insane and I'd really like to hear from a MS System Engineer on why it works but I followed the instructions on this site from Dell (https://www.dell.com/support/article/us/en/04/sln301421/microsoft-deployment-tools-2013-update-2-contains-a-bug-in-uefi-deployment-sequence?lang=en)  and so far it's working.  Right now I have successfully imaged one test machine and we're about to test it on eight more Dell OptiPlex 7060s and a Latitude 5490 strictly using UEFI Secure Boot.  I will post a follow up again once I've had success on the remaining PCs and hopefully with some additional input from either Dell or Microsoft on why this was the case.

    Note: Part of what baffles me is that this was a known bug that occurred between MDT 2013 and I've been using MDT2016 since we went to MDT and have always kept both MDT and ADK updated.  But this is the first time I've battled with using UEFI so clearly legacy boot was not an issue.  :)

    Thursday, October 25, 2018 12:12 AM
  • Did you do anything else besides disable the other format steps and then paste in the old format and partition step?  I did this and still am getting the same error.  I updated to the latest PE 10 drivers along with making the DHCP changes.  
    Saturday, November 3, 2018 8:57 PM
  • Can you verify that the symptoms described in Dell's KB actually apply in your case (i.e. correct BIOS config, yet MDT sets the IsUEFI variable = false). Are you running the latest version of MDT?

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Monday, November 5, 2018 9:48 AM
  • Hi Bill001979,
                 As far as the MDT tasks, no I didn't do anything else.  The only thing I did prior was to make sure my MDT was patched to v8450 and the ADK was updated to 1809 build.  As for the Dell OptiPlex, the BIOS settings were returned to near factory meaning the only thing I had changed was the Network Card Stack settings to support PXE.  Otherwise, it was UEFI, Secure Boot using Boot Manager.  But that was never the issue.  The partitions were being created and the OS was being applied, but it would assign OSDisk a drive letter E:\ thus creating the error.  When I followed this method posted by Dell, it actually worked.

    Hope this helps.

    Monday, November 5, 2018 5:33 PM
  • Hi Anton,

               I love the Wing Commander series, still deeply on the fence about Star Citizen though.   Anyway, the answer to your first question is "no".  The issue was not isUEFI ='False'.   So honestly, I do know why this obscure solution fixed my issue. Only to say that it did.   MDT is 8450 & ADK is 1809 on a fully updated Server 2016.  WDS is PXE on a server 2012r2 fully updated. 

    BIOS was returned to booting via UEFI, Secure Boot w/Boot Manager.  System would boot via IPv4 and found WDS almost instantly.  Image deploys only this time, instead of OSDisk getting drive letter E:\ assigned to it, it would assign drive letter C:\ and the task sequences would continue on successfully. 

    Cheers

    Monday, November 5, 2018 5:38 PM