locked
Can't create Wireless External Hyper-V Switch Error applying virtual switch RRS feed

  • Question

  • I'm running Windows Server Technical Preview 2 on my laptop and am not able to create an External Hyper-V Switch with my wireless network. I've tried both the GUI and powershell and it keeps failing. I get the error below. Any help appreciated, thanks!

    Ethernet port '{904448FE-2AC0-4818-818C-4D62BECF4C79}' bind failed: Not implemented (0x80004001).

    Thursday, July 23, 2015 3:21 PM

Answers

  • Hi mbiver,

    Base on my experience  some times we can try to disconnect your wireless connection then reconnect it and create the external virtual switch again.

    Best Regards,


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    • Proposed as answer by Alex Lv Friday, August 7, 2015 2:44 AM
    • Marked as answer by Alex Lv Monday, August 10, 2015 8:53 AM
    Tuesday, July 28, 2015 9:55 AM

All replies

  • Hi mbiver,

    Base on my experience  some times we can try to disconnect your wireless connection then reconnect it and create the external virtual switch again.

    Best Regards,


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    • Proposed as answer by Alex Lv Friday, August 7, 2015 2:44 AM
    • Marked as answer by Alex Lv Monday, August 10, 2015 8:53 AM
    Tuesday, July 28, 2015 9:55 AM
  • Hello mbiver, has there been any update on this? Did Alex's suggestion to disconnect and reconnect your wireless connection help to resolve the issue?

    Thanks,
    Jess Cunningham
    Windows Beta Team

    Thursday, July 30, 2015 7:35 PM
  • Sorry, I've not had a chance to test just yet. Will be back in the office on Tuesday and test then.
    Wednesday, August 5, 2015 6:07 PM
  • well, finally upgraded to TP3 hoping the issue was resolved, but still getting an error. when trying to create a hyper-v virtual switch from a wireless NIC

    class not registered 0x80040154

    Thursday, September 10, 2015 10:37 PM
  • I am also running TP3 and experiencing the same issue. I have tried disjoining networks, disabling all protocols, deleting the driver and reinstalling, adding the switch from powershell, and reinstalling TP3. 
    Thursday, November 5, 2015 9:04 PM
  • Hi, I had a similar issue with the error message "Error applying Virtual Switch Properties changes. Failed while adding virtual Ethernet switch connections. Ethernet Port. {<GUID>} bind failed: Catastrophic failure (0x8000FFFF)".

    This was after I changed an existing external Virtual Switch mapped to my wireless connection into a private Virtual Switch. When I went to change it back I found it couldn't. I could create an external Virtual Switch using my wired NIC but not using the wireless.

    Eventually I noticed that on the Sharing tab of the properties of the wireless adapter “Allow other network users to connect through this computer’s Internet Connection” was ticked. As soon as I cleared that checkbox I could create the external Virtual Switch bound to my wireless connection.

    Hope this helps. :)

    Saturday, June 17, 2017 10:18 AM