locked
windows update cannot currently check for updates because the service is not running RRS feed

  • Question

  • Running Windows 7 on a Dell N5110. 

    I get the above message for Windows Updates. Below that it states: Find out more about free software from (null). 

    I have restarted the computer. 

    I have run McAffe and MalwareBytes Pro- nothing wrong.

    This answer didn't work because the Software Distribution folder was already empty:

    • go to services and stop Windows update service
    • locate C:\Windows\SoftwareDistribution\ folder and delete all its content
    • start Windows update service
    • check for update

    Under Services:

    • BITS is set at Automatic(Delayed Start)
    • Windows Update is also set at Automatic (Delayed Start). It is stopped. If I try to start it, I get the following message: Windows could not start the Windows Update service on local computer. Error 1079: The account specified is different from the account specified for other services running in the same processes. 

    In addition, the Windows Update shows nothing under view update history and nothing under hidden updates. Change settings allows me to do absolutely nothing. Red Shield with an x and the options are shaded. 

    Any help would be greatly appreciated.

    Sunday, January 19, 2014 3:40 AM

Answers

  • Hi,

    How's everything now?

    If issue persists, please try this link

    Services fail to start and you receive an Error 1079 on a computer that is running Windows Server 2008, Windows Vista, Windows 2008 R2 or Windows 7

     

    http://support.microsoft.com/kb/2478117/en-us

    Regards


    Yolanda
    TechNet Community Support

    • Marked as answer by Roger Lu Monday, February 10, 2014 1:23 AM
    Wednesday, February 5, 2014 6:13 AM

All replies

  • Whenever the "null" thing appears, that definitely means that that the service itself is not running.  The other symptoms, such as the empty update history, are also indicative of that.

    Just out of curiosity, what is selected under the "Logon" tab in the "Properties" window for the Windows Update service?

    And just for kicks, have you tried starting the service with all your protection programs (like antivirus) turned off?  I had an antivirus program unexpectedly block starting the service once.

    Sunday, January 19, 2014 5:34 AM
  • For kicks - I forgot to put - yes I tried to run with the firewall and malwarbytes turned off. No dice. Also the windows defender has a message in services that says Failed to Read Description. Error Code 1168. 

    Logon Tab under properties - had logon to my account. Changed to Local System Acoount.

    This step has improved the situation. Now it thinks that updates are controlled by system administrator. It will not automatically check. I can force it to check by choosing check online for updates, but I would prefer to get it back to automatically checking. This is a personal laptop, not owned/run by a corporation. 

    Code 80072EE6 Windows Update encountered an unknown error. This error does not come up when I choose get help with this error. 

    Sunday, January 19, 2014 6:16 PM
  • It sounds like the Windows Update policies are set.

    Try this:

    1. Stop the Windows Update service.
    2. Open Registry Editor (regedit) with administrative privileges.
    3. Browse to HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate
    4. Delete this entire key by right-clicking the "WindowsUpdate" key in the left pane and choosing Delete.
    5. Start the Windows Update service.

    • Edited by Jason.C.F Sunday, January 19, 2014 7:41 PM
    Sunday, January 19, 2014 7:40 PM
  • Hi,

    How's everything now?

    If issue persists, please try this link

    Services fail to start and you receive an Error 1079 on a computer that is running Windows Server 2008, Windows Vista, Windows 2008 R2 or Windows 7

     

    http://support.microsoft.com/kb/2478117/en-us

    Regards


    Yolanda
    TechNet Community Support

    • Marked as answer by Roger Lu Monday, February 10, 2014 1:23 AM
    Wednesday, February 5, 2014 6:13 AM