locked
Compatibility between ADFS 3.0 and ADFS 2.0 RRS feed

  • Question

  • Hello,

    We are using ADFS 3.0 in our organisation, but one of our customers has Windows 2008 R2.

    We have only tested ADFS 3.0 with another ADFS 3.0. I was wondering if a deployment with ADFS 3.0 and our end, and ADFS 2.0 at the customer's end would work?

    My understanding is that it would work but we would only be able to work with ADFS features that are compatible with the customer's version of ADFS (that is, 2.0). Is that correct?

    Is there some sort of documentation in TechNet/MSDN/etc that outlines the features in ADFS 3.0 which are not backwards compatible with ADFS 2.0?

    Thanks in advance for your help and support.

    Regards,

    P.

    Friday, October 7, 2016 2:41 PM

Answers

  • You shouldn't have any issue working with AD FS 2012 R2 and AD FS 2.0. The core federation support (SAML 2.0 / WS-Federation / WS-Trust) is largely untouched.

    http://blog.auth360.net

    Friday, October 7, 2016 5:36 PM

All replies

  • You shouldn't have any issue working with AD FS 2012 R2 and AD FS 2.0. The core federation support (SAML 2.0 / WS-Federation / WS-Trust) is largely untouched.

    http://blog.auth360.net

    Friday, October 7, 2016 5:36 PM
  • Thank you Mylo.

    I guess we will just go for it and see how it goes.

    Regards,

    P.

    Saturday, October 8, 2016 11:13 AM