locked
"Not enough memory to run Micorsoft Excel. Please close other applications and try again." due to blocked file. RRS feed

  • Question

  • Hello,

    We have a problem when opening Excel-files that are for example attached to mail. If we open the file directly from Outlook 2010 or OWA doesnt matter.

    We allways get the following error message. "Not enough memory to run Micorsoft Excel. Please close other applications and try again"

    But we narrowed it down to that the problem is cause by files that are blocked. If you unblock it using the preference page of the file it opens just fine.

    Why are the files being marked as blocked, and how do we solve this?

    Best Regards

    Pierre Wulff

    • Edited by Pierre Wulff Tuesday, November 16, 2010 6:58 AM Spelling
    Monday, November 15, 2010 4:07 PM

Answers

  • Hi,

     

    Some files are blocked by Outlook. We may follow these steps to modify the registry and change Outlook's attachment security behavior.

    ========================

    1.      Exit Outlook if it is running.

    2.      Click Start, and then click Run. Copy and paste (or type) the following command in the Open box, and then press ENTER: regedit

    3.      Verify that the following registry key for your version of Outlook exists.

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security

    If the registry key exists, go to step 5.
    If the registry key does not exist, follow these steps to create it:

    a.                  Locate, and then click the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft

    b.                  Under Edit, click New, and then click Key.

    c.                   Type Office, and then press ENTER.

    d.                  Under Edit, click New, and then click Key.

    e.                  For Outlook 2010, type 14.0, and then press ENTER.

    f.                    Under Edit, click New, and then click Key.

    g.                  Type Outlook, and then press ENTER.

    h.                  Under Edit, click New, and then click Key.

    i.                    Type Security, and then press ENTER.

    1.      Under Edit, click New, and then click String Value.

    2.      Copy and paste (or type) the following name for the new value:

    Level1Remove

    3.      Press ENTER.

    4.      Right-click the new string value name, and then click Modify.

    5.      Type the file name extension of the file type that you want to open in Outlook. For example:

    .xlsx

    6.      Click OK.

    7.      Exit Registry Editor.

    8.      Restart your computer.

     

    When you start Outlook, you can open the file types that you specified in the registry.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Thursday, November 25, 2010 5:54 AM
    Thursday, November 18, 2010 9:21 AM

All replies

  • Hi,

     

    What’s the version of your operating system?

     

    You may try to enable/increase the virtual memory/paging file in Windows.

     

    For details, you can refer to this: http://windows.microsoft.com/en-IN/windows-vista/Change-the-size-of-virtual-memory

     

    Best Regards,

     

    Sally Tang

    Tuesday, November 16, 2010 8:00 AM
  • We´re running on Windows Server 2008 R2 configured as a Terminal Server.

     

    When it comes to the increasing of the page file, that wont make any difference cause the error message disappears when the file is unblocked.

    So the error message cant actually have anything to do with the actual problem. But is there a workaround for this issue or bug?

    • Edited by Pierre Wulff Tuesday, November 16, 2010 9:24 AM more info
    Tuesday, November 16, 2010 9:04 AM
  • Hi,

     

    Some files are blocked by Outlook. We may follow these steps to modify the registry and change Outlook's attachment security behavior.

    ========================

    1.      Exit Outlook if it is running.

    2.      Click Start, and then click Run. Copy and paste (or type) the following command in the Open box, and then press ENTER: regedit

    3.      Verify that the following registry key for your version of Outlook exists.

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security

    If the registry key exists, go to step 5.
    If the registry key does not exist, follow these steps to create it:

    a.                  Locate, and then click the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft

    b.                  Under Edit, click New, and then click Key.

    c.                   Type Office, and then press ENTER.

    d.                  Under Edit, click New, and then click Key.

    e.                  For Outlook 2010, type 14.0, and then press ENTER.

    f.                    Under Edit, click New, and then click Key.

    g.                  Type Outlook, and then press ENTER.

    h.                  Under Edit, click New, and then click Key.

    i.                    Type Security, and then press ENTER.

    1.      Under Edit, click New, and then click String Value.

    2.      Copy and paste (or type) the following name for the new value:

    Level1Remove

    3.      Press ENTER.

    4.      Right-click the new string value name, and then click Modify.

    5.      Type the file name extension of the file type that you want to open in Outlook. For example:

    .xlsx

    6.      Click OK.

    7.      Exit Registry Editor.

    8.      Restart your computer.

     

    When you start Outlook, you can open the file types that you specified in the registry.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Thursday, November 25, 2010 5:54 AM
    Thursday, November 18, 2010 9:21 AM