none
IBCM - deployments not completing RRS feed

  • Question

  • I just got IBCM communications working properly.  So, next step is to test deploying something.  Everything I try gets downloaded to the ccmcache on the machine I'm using for testing.  CCM32BitLauncher.log gives me an entry saying a process is created for the install.  Then, nothing.  What else can I look at to see where the process is breaking?

    CB - 1906

    Thursday, May 21, 2020 10:20 PM

All replies

  • Are you testing with a package or application?

    Jason | https://home.configmgrftw.com | @jasonsandys

    Friday, May 22, 2020 12:13 AM
  • Hi,

    The Ccm32BitLauncher.log records actions for starting applications on the client marked run as 32 bit.
    The following table lists the log files that contain information related to application management:
    https://docs.microsoft.com/en-us/mem/configmgr/core/plan-design/hierarchy/log-files#BKMK_AppManageLog

    I hope the following article will help you troubleshoot problems during the application installation phase:
    Application Installation


    Best regards,
    Larry

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 22, 2020 7:15 AM
  • A package.  I've downloaded and tried to deploy VLC Player, and 7-zip.  These are both new packages, built yesterday.  I also tried to deploy a package that has been in my system for years, so definitely a "known good", Acrobat Pro XI.  I see the content in ccmcache, but the programs are not installed.

    The client is not getting AV updates, either, though.


    Friday, May 22, 2020 1:08 PM
  • Larry, thanks for that link to the log file explanations.

    Looking at the execmgr.log file, I see an installation failure for one of the packages I deployed, with an exit code of 1.  Now, I need to go find what that means.

    Friday, May 22, 2020 1:40 PM
  • Also, I wanted to clarify how I package these things, as well, in case that is affecting it.  Although, I'm doing it the same way I've always done:

    In the package itself, I check that there are source files, and I use FQDN to point to the source folder.

    For the program, we use a setup.bat that calls the command line to install the program exe.  So, in the program, on the General tab, I have setup.bat in the Command line box, normally we have things run Hidden, but in the case of the VLC package, I selected Normal.  After running: No action required; everything else on General is blank. Requirements tab: estimated disk space 50MB, On any platform.  Environment: Whether or not a user is logged on, Run with Administrative rights. Drive mode - Runs with UNC name.

    The batch file itself is something we use pretty much for all our installs, just changing the appropriate pieces:

    @ECHO OFF
    CLS
    IF "%1"=="/FORCE" GOTO INSTALL
    IF "%1"=="/Force" GOTO INSTALL
    IF "%1"=="/force" GOTO INSTALL
    GOTO INTRO

    :INTRO
    ECHO. 
    ECHO. 
    ECHO This will install "VLC Media Player"
    ECHO    - Requires Administrator Rights
    ECHO. 
    ECHO Close this window to stop installation
    ECHO.
    ECHO             Otherwise...
    ECHO.


    ECHO Installing VLC Player...

    "%~dp0\vlc-3.0.10-win64.exe /S"

    Friday, May 22, 2020 2:08 PM
  • Error code 1 means "Incorrect function."

    This can mean any number of things but the issue is with your script.

    Is that the full batch file above? If so, you are specifying to goto a label named "INSTALL" but that label doesn't exist in the file; the only label that exists is "INTRO".

    I don't know if that's truly the issue or not, but only some local debugging and testing will help figure that out.


    Jason | https://home.configmgrftw.com | @jasonsandys


    Friday, May 22, 2020 2:19 PM
  • Ok, so you're saying the issue is most likely with the package, not the process, correct? I looked back through the execmgr.log for the "known good" package, and it just said that it had been successful before, so would not run. I don't think that's actually the case, but I don't want to dig where that may end up being true.

    Could you share anything that I could test with, that is an obvious "this will definitely work if the process is working? I've looked through the rest of the packages on my server, and they've all either been deployed to this box already, or are very specialized things.

    The other big issue I'm having is that Software Updates aren't being downloaded or installed, but there are some errors in one of the WUA logs, so I'll dig into those before asking for your help. As always, Jason, your help and advice is greatly appreciated.

    Friday, May 22, 2020 3:21 PM
  • More specifically, the script itself. The error code is directly from it (the script) and this is simply being reported by ConfigMgr. From troubleshooting, manually running the script on the system in question is the first step (from a command-prompt running as local System).

    For Windows Updates, always start with wuahandler.log on the client.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Friday, May 22, 2020 7:43 PM
  • Hi,


    How are things going? I just checked in to see if there are any updates. Please feel free to feedback and if the above reply is helpful, please kindly click “Mark as answer”. It would make the reply to the top and easier to be found for other people who has the similar question.

    If there is any other assistance we can provide, please feel free to let us know, we will do our best to help you.

    Thank you!


    Best regards,
    Larry

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 25, 2020 6:18 AM
  • Still working on the issue.  Things coming to the disconnected test machine through the SUP get installed fine, but I am not having much luck with applications/software packages.
    Friday, May 29, 2020 2:23 PM