locked
Exchange 2010 Send/Receive Message Size Limits RRS feed

  • Question

  • I have set the Max Receive and Max Send to 40960KB in the Transport Settings

    I have set the Max Message Size to 40960KB for the Outbound Send Connector

    I have set the Max Message Size to 20480KB for the Default Send Connector

    I would also like to be able to pass attachments up to 40MB between internal recipients. In testing, I cannot send anything larger than 20BM

    Saturday, July 9, 2011 12:23 AM

Answers

  • Hi,

    In Exchange 2010, the limits of sending or receiving emails have the below checks: Organization limit, Global limit, Connector limit, Server limit and User limit. And you can refer to the article ‘Understanding Message Size Limits'.

     So, from your description, you also should check Organization limit(the default is 10MB), Receive Connector limit(the default of the recipient is 10MB), Recipient limits(Sending/Receiving message size), Global settings. For more, you can refer to the article ‘Setting Message Size Limits in Exchange 2010 and Exchange 2007.

    Besides, conversion encoding and agent processing can increase the size of the message as it flows through the Exchange organization. So you need to control the limits a little more.

    Hope this helps.

    Thanks


    Sophia Xu
    • Proposed as answer by Sophia Xu Monday, July 11, 2011 6:19 AM
    • Marked as answer by Sophia Xu Thursday, July 14, 2011 8:34 AM
    Monday, July 11, 2011 6:18 AM

All replies

  • You can look at various locations where message size limits are enforced and increase or eliminate them.  One place is in Global Settings > Message Delivery.  Another is a property of each user's mailbox, under Delivery Restrictions, as do public folders.  Distribution groups have maximum message sizes.   Still another place is on any connector over which the mesage much pass.  You can restrict message sizes in the SMTP virtual server, affecting any message that must pass through it.

    The limits you set apply to the entire message.  If you want to allow 40MB attachments, then you'd probably want to set your limits maybe 30% higher than that.

    http://exchangepedia.com/2007/09/exchange-server-2007-setting-message-size-limits.html


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    • Proposed as answer by Sophia Xu Thursday, July 14, 2011 8:34 AM
    Saturday, July 9, 2011 1:21 AM
  • Refer below article too.

    http://technet.microsoft.com/en-us/library/bb124345.aspx

     

    Regards


    MVP-Directory Services

    Awinish Vishwakarma| CHECK MY BLOG

    Disclaimer: This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Saturday, July 9, 2011 7:39 AM
  • Hi

    You set the Max send size of 20 MB limit for your default send connector, may be your mail pass through that send connector and thats why you are not able send emails more than 20 MB.

    Also, to send 40 MB, dont set 40 MB as limit, increase it some extent. which will not create any problem in sending email for about 40 MB size.

    Saturday, July 9, 2011 10:43 AM
  • Hi,

    In Exchange 2010, the limits of sending or receiving emails have the below checks: Organization limit, Global limit, Connector limit, Server limit and User limit. And you can refer to the article ‘Understanding Message Size Limits'.

     So, from your description, you also should check Organization limit(the default is 10MB), Receive Connector limit(the default of the recipient is 10MB), Recipient limits(Sending/Receiving message size), Global settings. For more, you can refer to the article ‘Setting Message Size Limits in Exchange 2010 and Exchange 2007.

    Besides, conversion encoding and agent processing can increase the size of the message as it flows through the Exchange organization. So you need to control the limits a little more.

    Hope this helps.

    Thanks


    Sophia Xu
    • Proposed as answer by Sophia Xu Monday, July 11, 2011 6:19 AM
    • Marked as answer by Sophia Xu Thursday, July 14, 2011 8:34 AM
    Monday, July 11, 2011 6:18 AM