locked
svchost.exe hogging system resourses - audio endpoint builder issue? RRS feed

  • Question

  • I have:
    Windows 7 Home Premium
    8 GM RAM
    64bit Operating System
    AMD Phenon II x4925 processor 2.80 GHz

    Over the last couple of weeks I've noticed that my system runs a slower.  Defrag and disk cleanup run once a week.  I've found it is the svchost.exe in the task manager.  Currently, it's running at 117k and nothing else is open except Firefox for this window.  Firefox is taking up less resources. When I click on the associated processes, these are attached:
    Windows Audio Endpoint Builder
    hidserv
    HomeGroupListener
    NetMan
    pcasvc
    SysMain
    TrkWks
    UxSms
    WLanSvc
    WPDBusEnum
    Wudfsvc

    I'm too much of a beginner to follow some of the instructions out on the web to modify system files, so I'd like to know if anyone knows what might be the issue and provide troubleshooting tips. 

    I feel strongly this started after a recent automatic update.  I haven't added any new programs or made any major changes to the computer system.

    Saturday, April 16, 2011 11:21 PM

Answers

  • Hi,

     

    According to your description, you could try to restore to a previous time point to check the result.

     

    And I would like to share the following articles with you: 

     

    How to troubleshoot high cpu in the System process

     

    PRF: High CPU (SVCHOST.EXE)

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Monday, April 25, 2011 8:32 AM
    Tuesday, April 19, 2011 9:36 AM