locked
How to edit driver INF files? RRS feed

  • Question

  • I'm using Dell Studio 1558 laptop with integrated webcam. Recently, Windows installed an update that installed a wrong driver for the webcam. Therefore, the webcam was not usable. I manually located the driver location (C:\Windows\system32\drivers) from Device Manager and deleted it manually. But I forgot to edit the corresponding INF file (C:\Windows\inf). Therefore, each time Windows loads, it's unable to locate the driver and still the device is unusable. Is there a possibility to locate the INF file manually and edit it?

    Note: I tried uninstalling the wrong driver software, but the driver remained, so I tried manual method. The old driver still exists, but the new driver location must be removed to use the existing/old driver as Windows looks for the new driver first.


    Balaji Kundalam

    Sunday, November 3, 2013 12:01 PM

Answers

  • Hi,

    Generally, to resolve this issue, use Registry Editor to grant Read Only permissions to the Local Service user account.
    To do this, follow these steps:

    1.Click Start, click Run, type regedit, and then click OK.
    2.Expand the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ SecurePipeServers

    3.Right-click winreg, and then click Permissions.
    4.Click Add.
    5. In the Enter the object names to select box, type Local Service, and then click OK.

    Alternatively, you can type the name of a user or group that you want to grant access permission.
    6.In the Permissions for LOCAL SERVICE list, next to Read, click to select the Allow check box.
    7.Quit Registry Editor, and then restart your computer.

    Thanks

    • Marked as answer by Cloud_TS Sunday, December 8, 2013 5:27 PM
    Thursday, December 5, 2013 2:45 AM

All replies

  • Hi Balaji Kundalam,

    This issue mostly can be caused due to the manually driver uninstallation is incomplete instead of the .inf file.

    Based on the current situation, I would like to suggest you try the following to check the issue.

    1. Try to clear previous driver by registry

    a. Start Registry Editor.

    b. Locate and then click the following registry subkey and then find the associated key of the webcam:

    HKEY_LOCAL_MACHINE\Software\……
    HKEY_CURRENT_USER\Software\……

    You may also refer to the link below to find the registry key:

    Introduction to Registry Keys for Drivers

    http://msdn.microsoft.com/en-us/library/windows/hardware/ff544262%28v=vs.85%29.aspx

    c. Uninstall key in the registry.

    please backup Registry first.

    How to back up and restore the registry in Windows
     
    http://support.microsoft.com/kb/322756

    2. Reinstall the new driver manually.

    If the issue still occurs, I suggest you to visit the webcam manufacturer’s website for technical support. 

    Hopefully you could resolve your issue soon.

    Regards,

    Blair Deng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Friday, November 8, 2013 1:23 AM
  • Thanks Blair. But unfortunately, I don't find a suitable driver in Dell website. And for the registry, I get the following error message when I open some of the keys:


    Balaji Kundalam

    Saturday, November 9, 2013 10:01 AM
  • Hi Balaji

    Most of the time these type of registry errors can be bypassed by using sysinternals pstools .

    http://www.windowstechinfo.com/2013/07/solved-cannot-import-to-registry-not.html

    Saturday, November 9, 2013 12:12 PM
  • Hi Balaji Kundalam,
     
    Thank you for your update.
     
    Because you receive a "Access denied" error, typically it results from the insufficient permission on the key. Please take the ownership of the key and verify the permissions on it.
     
    1. Right click the key--->Permissions…--->Advanced--->Owner tab.
     
    2. Choose the built-in Administrators group and click apply.
     
    3. In the Permissions tab, verify whether the local administrator has been granted proper permission on it. If not, please grant administrator Full Control permission to see whether it works.
     
    please backup Registry first.
     
    How to back up and restore the registry in Windows
     
    http://support.microsoft.com/kb/322756
     
    You may try installing the driver again and check if the issue is resolved.
     
    Hope it Helps.
     
    Regards,
     
    Blair Deng

    Blair Deng
    TechNet Community Support

    Thursday, November 14, 2013 2:59 PM
  • Hi Balaji Kundalam,
     
    Thank you for your update.
     
    Because you receive a "Access denied" error, typically it results from the insufficient permission on the key. Please take the ownership of the key and verify the permissions on it.
     
    1. Right click the key--->Permissions…--->Advanced--->Owner tab.
     
    2. Choose the built-in Administrators group and click apply.
     
    3. In the Permissions tab, verify whether the local administrator has been granted proper permission on it. If not, please grant administrator Full Control permission to see whether it works.
     
    please backup Registry first.
     
    How to back up and restore the registry in Windows
     
    http://support.microsoft.com/kb/322756
     
    You may try installing the driver again and check if the issue is resolved.
     
    Hope it Helps.
     
    Regards,
     
    Blair Deng

    Blair Deng
    TechNet Community Support

    Still it's 'access denied'. Is it may be due to corrupt registry?

    Balaji Kundalam

    Sunday, November 17, 2013 5:45 AM
  • Hi,

    Generally, to resolve this issue, use Registry Editor to grant Read Only permissions to the Local Service user account.
    To do this, follow these steps:

    1.Click Start, click Run, type regedit, and then click OK.
    2.Expand the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ SecurePipeServers

    3.Right-click winreg, and then click Permissions.
    4.Click Add.
    5. In the Enter the object names to select box, type Local Service, and then click OK.

    Alternatively, you can type the name of a user or group that you want to grant access permission.
    6.In the Permissions for LOCAL SERVICE list, next to Read, click to select the Allow check box.
    7.Quit Registry Editor, and then restart your computer.

    Thanks

    • Marked as answer by Cloud_TS Sunday, December 8, 2013 5:27 PM
    Thursday, December 5, 2013 2:45 AM