locked
Printing option disable automaticaly RRS feed

  • Question

  • Hi, in our business we have a 2008 server  we have Printing server on that. All printer are install to this server.

    The client are on Vista. We install printer on the client. When we want to print in Duplex mode on a printer or on a photocopier the option are disable.. But if we check on the server, the fonction is enable and work. So what we do, we delete theprinter on the client and reinstall and now the option is enable !  but some day later, the option come disable again..

     

    Can you help me with that ?

    Friday, April 9, 2010 1:47 PM

Answers

  • There is a registry key you can add to extend past the 7 day default

    on Vista, every 7 days the connection is completely recreated.

     

    This can be adjusted by setting the “InactiveGuidPrinterAge” and “ActiveGuidPrinterAge” DWORD registry values (under “HKLM\Software\Microsoft\Windows NT\CurrentVersion\Print\Providers” to a very large value.  (The value is specified in seconds.)

     


    Alan Morris Windows Printing Team; Search the Microsoft Knowledge Base here: http://support.microsoft.com/search/Default.aspx?adv=1
    • Marked as answer by Miles Zhang Monday, May 3, 2010 6:48 AM
    Monday, April 19, 2010 11:04 PM
    Answerer
  • It is not there thus the default to seven days (~600000 seconds).  Add New DWord  (do not include the "" s) and set the value to 99999999.  This is a client side setting.  If you have never editted the registry, ask someone who has to add the values.


    Alan Morris Windows Printing Team; Search the Microsoft Knowledge Base here: http://support.microsoft.com/search/Default.aspx?adv=1
    Tuesday, April 20, 2010 4:26 PM
    Answerer

All replies

  • Hi,

    Thanks for the post.

    From your description, I understand that the printing option will be disabled automatically on the client side. This issue can be temporarilly fixed by reinstalling the printer on the client machines but it will reoccur some days later.

    Here is some questions I would like to confirm:

    1. Does this issue occur on the machines with other OS?

    2. Does this issue just occur with some specifc network printer? If so, would you please tell me the exact model?

    3. Is there any third party printing program installed on the problematic machine?

    In this case, you could use Process Monitor on the problematic machine to keep monitoring the specific printer key in the following sub-key.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers

    Hope this helps.

    Monday, April 12, 2010 7:39 AM
  • 1. Theoccur with all vista system

    2. They occur of all printer and photocopieur we have some Hp 4250 , 4350, Sharp MXM-450

    3. We didnt have third part program install

    Tuesday, April 13, 2010 11:30 AM
  • Any update for me ???
    Monday, April 19, 2010 2:38 PM
  • It sounds like the Vista drivers are getting reinstalled from the local client driverstore and taking the defaults from the driver rather than the defaults from the server.  Make sure you have the Vista (Server 2008) drivers installed on the print server.  If the Vista machines are running SP2 be sure to install SP2 on the print server.
    Alan Morris Windows Printing Team; Search the Microsoft Knowledge Base here: http://support.microsoft.com/search/Default.aspx?adv=1
    Monday, April 19, 2010 6:00 PM
    Answerer
  • There is a registry key you can add to extend past the 7 day default

    on Vista, every 7 days the connection is completely recreated.

     

    This can be adjusted by setting the “InactiveGuidPrinterAge” and “ActiveGuidPrinterAge” DWORD registry values (under “HKLM\Software\Microsoft\Windows NT\CurrentVersion\Print\Providers” to a very large value.  (The value is specified in seconds.)

     


    Alan Morris Windows Printing Team; Search the Microsoft Knowledge Base here: http://support.microsoft.com/search/Default.aspx?adv=1
    • Marked as answer by Miles Zhang Monday, May 3, 2010 6:48 AM
    Monday, April 19, 2010 11:04 PM
    Answerer
  • Do you have a exemple of this Key because we dont this on our computer ...
    Tuesday, April 20, 2010 1:26 PM
  • It is not there thus the default to seven days (~600000 seconds).  Add New DWord  (do not include the "" s) and set the value to 99999999.  This is a client side setting.  If you have never editted the registry, ask someone who has to add the values.


    Alan Morris Windows Printing Team; Search the Microsoft Knowledge Base here: http://support.microsoft.com/search/Default.aspx?adv=1
    Tuesday, April 20, 2010 4:26 PM
    Answerer