locked
Improper Windows 7 Shutdown RRS feed

  • Question

  • Windows 7 improper shutdown.  I can get Windows 7 to shutdown normally in any Safe Mode but in normal operations Windows 7 takes a long time to finally shutdown and when I restart I get an error indicator indicating improper shutdown.  I've run updates and all drivers, etc. are shown as latest available.
    Saturday, November 21, 2009 3:21 PM

Answers

  • Open the system configuration interface (start menu search box "system configuration") and remove the startup and non - microsoft services. A third party service may be delaying shutdown. Also refer to your event viewer (start menu search box "event viewer") where there may be more information.


    Seesons greetings!
    • Proposed as answer by genericuser123 Monday, November 23, 2009 1:56 AM
    • Marked as answer by Linda Yan Thursday, November 26, 2009 5:44 AM
    Monday, November 23, 2009 1:51 AM
  • Since we can shut down the computer in Safe mode, our issue should be caused by third party conflicts. We can try the following steps to fix our issue.

    Clean Boot
    ======================
    This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. Select the Services tab in the open window. Check the “Hide all Microsoft Services” option and click Disable All.
    3. Switch to the Startup tab and click Disable All.
    4. Click OK to save the settings and select Restart when prompted.
    5. Check whether or not the issue still occurs.

    If the computer can shut down normally now, you can try the methods in the following link to find the root cause.

    http://support.microsoft.com/kb/929135

    I hope this can help you.


    John
    • Marked as answer by Linda Yan Thursday, November 26, 2009 5:44 AM
    Monday, November 23, 2009 5:52 AM

All replies

  • Do you wait for it to fully shut down or do you manually turn off the computer?
    Sunday, November 22, 2009 11:11 PM
  • Open the system configuration interface (start menu search box "system configuration") and remove the startup and non - microsoft services. A third party service may be delaying shutdown. Also refer to your event viewer (start menu search box "event viewer") where there may be more information.


    Seesons greetings!
    • Proposed as answer by genericuser123 Monday, November 23, 2009 1:56 AM
    • Marked as answer by Linda Yan Thursday, November 26, 2009 5:44 AM
    Monday, November 23, 2009 1:51 AM
  • Since we can shut down the computer in Safe mode, our issue should be caused by third party conflicts. We can try the following steps to fix our issue.

    Clean Boot
    ======================
    This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:
    1. Click the Start Button and type "msconfig" (without quotation marks) in the Search Box and press Enter.
    2. Select the Services tab in the open window. Check the “Hide all Microsoft Services” option and click Disable All.
    3. Switch to the Startup tab and click Disable All.
    4. Click OK to save the settings and select Restart when prompted.
    5. Check whether or not the issue still occurs.

    If the computer can shut down normally now, you can try the methods in the following link to find the root cause.

    http://support.microsoft.com/kb/929135

    I hope this can help you.


    John
    • Marked as answer by Linda Yan Thursday, November 26, 2009 5:44 AM
    Monday, November 23, 2009 5:52 AM
  • I must agree with both John Cena, and Mr. Seven. As for third party software, I doubt it unless it is running in the program. If it was a software issure that is not closing properly it would show a screen saying force program shut down and after the PC will turn off. Only way to find out is with a clean boot and see.

    Monday, November 23, 2009 5:57 AM
  • If you think it takes long time to find the cause of the issue, you can try the following method to workaround this issue.

    Navigate to this key:

    HKEY_CURRENT_USER\Control Panel\Desktop

    Double click the AutoEndTasks key (in the right pane) and change the Value Data to 1
     
    Close the Registry and restart your computer. 

    Now, when you shut down this computer, all programs will be killed and the computer shouldn’t be delayed!

    I hope this can help you.

    John


    John
    Tuesday, November 24, 2009 10:44 AM