locked
NAS device no recognized by Network discovery RRS feed

  • Question

  • I have a DLINK DNS-323 NAS device with two hard drives.  Under W7 it appeared under in the Network folder, but after he W10 upgrade, network discover fails to find it.

    I have managed to find a workaround based on posts in other forums:

    1 - One post suggested that I could verify that the device was attached to the network properly by running a file explorer program on an Android tablet.  That worked fine, and I could see and access the files on both drives.

    2 - I found that the DLink setup program was able to detect the device and display it's IP address, but was not able to map the drives.

    3 - Another post suggested opening Windows Explorer (not IE) and entering the following:  \\(IP address)\(Device name)

         This enabled me to access both drives and their contents.

    But network discovery still fails to find the drive and I can't access the drives as I did before with W7.

    None of the outside forum posts that I found contained any way to restore the normal access vie the Network object.  They just provided the workaround and said that it was an MS problem that needed to be fixed.


    • Edited by jeth32 Monday, September 26, 2016 7:35 AM typo
    • Moved by Peter GeelenMVP Monday, September 26, 2016 7:41 AM Not For TNWiki forum
    Monday, September 26, 2016 7:35 AM

Answers

All replies

  • One other thing to look at is to check if your network is set to private in the "Network and Sharing Center"  if its set to public and you are using SMB1 you will run into the security fix mentioned here https://technet.microsoft.com/en-us/library/security/MS16-110 .   
    Monday, September 26, 2016 11:16 PM
  • I think I have the same problem, so have cross posted the message below which I originally entered in Windows 10 Setup...

    Hi,

    I was recently prompted to upgrade one of my machines to the anniversary edition of Windows 10 so I did.

    I have experienced all manner of problems with the upgrade resulting in me performing a clean install of Windows 10 and then upgrading before I tried anything else.  However, thats history.

    My problem is simple.  Now that I've re-installed Windows 10 and fully updated I started to re-install all my other software.  

    The first step to do this was to add an existing Network location where all the software installations are located.  Only I can't now map that network location, when I go into the wizard and enter the address I get the error message "The folder you entered does not appear to be valid. Please choose another."

    Now it's slightly more complex than that as the network location is on a NAS device that sits on a different subnet (192.168.30.0/24).  However, from the machine with a problem (which is on subnet 192.168.1.0/24) I  can successfully connect to the NAS Web interface (so routing is working successfully) AND other Windows 10 machines (that don't have the latest upgrade) and are on the same sub net (192.168.1.0/24) are successfully connecting to the NAS.

    Go figure as this looks like something in the latest upgrade broke Network locations.

    Any help greatly appreciated.

    Iain


    Iain

    Tuesday, October 4, 2016 4:30 PM