locked
Configuring multiple attached disks in Windows Server 2008 R2 backup fails RRS feed

  • Question

  • Apparently there may be a new bug in the Server 2008R2 version of Backup.  When we try to add a new destination to the scheduled backup it fails if not all USB drives are currently attached.  Even changing the time of the backup fails if all drives are not attached.  The error message is "The filename, directory name, or volume label is incorrect."  The workaround to attach all drives while running the wizard is only practical if you have two or three (no more than the number of USB ports you have.)  Is anyone aware of a fix or another workaround?  Here is a link to another forum that indicates it is a new issue with R2:  http://serverfault.com/questions/80621/windows-server-backup-says-the-filename-directory-name-or-volume-label-is-incor

    Thanks.
    Wednesday, December 2, 2009 12:42 PM

Answers

  • Hi Hunger,

    Thank you for your feedback. Currently, you can try the following workaround.

    Workaround:

    ============


    1) Use command line or UI to create backup schedule with a disk as backup target.

     

    2) Detach the first disk.

     

    3) Use WBADMIN Command line for adding another disk to schedule.

     

        For example:

     

       WBADMIN ENABLE BACKUP -addtarget:{aa123d14-bba0-1dd9-0d93-80aaaa6bbb63}

     

    Note that AddTarget parameter takes disk ID which can be got by running "WBADMIN GET DISKS" command.

    Hope it helps.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Wednesday, January 13, 2010 11:10 AM
    Friday, January 8, 2010 12:47 PM

All replies

  • I have the same issue. My customers with 2008 server do not have this issue so I too believe it is an R2 problem. Any luck with a solution ???

    Thanks Ted
    Monday, December 21, 2009 7:14 PM
  • I have the same issue. Is anybody aware of a fix.
    Wednesday, December 30, 2009 4:33 AM
  • Hi Hunger,

    Thank you for your feedback. Currently, you can try the following workaround.

    Workaround:

    ============


    1) Use command line or UI to create backup schedule with a disk as backup target.

     

    2) Detach the first disk.

     

    3) Use WBADMIN Command line for adding another disk to schedule.

     

        For example:

     

       WBADMIN ENABLE BACKUP -addtarget:{aa123d14-bba0-1dd9-0d93-80aaaa6bbb63}

     

    Note that AddTarget parameter takes disk ID which can be got by running "WBADMIN GET DISKS" command.

    Hope it helps.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Wednesday, January 13, 2010 11:10 AM
    Friday, January 8, 2010 12:47 PM
  • Sorry, I know this an older post, but issue still remains using WBAdmin and manually adding the disks.
    Monday, June 7, 2010 6:29 PM
  • Thanks David,

    This workaround Worked.

    Tuesday, June 8, 2010 1:13 AM