none
*.eml Time Stamp - Select File in Windows Explorer Changes the Modified Date RRS feed

  • Question

  • The Windows Live Mail *.eml files time stamp is getting changed to the current date when the file is selected in the Windows Explorer! I save backup copies of important E-mails to folders on the Hard Drive and then synchronize them with the same folders on other LAN Hard Drives for backup archives. When these E-mail files are selected or opened from the Windows Explorer in the Windows 7 OPS the Modified Date Time Stamp is changed to the current date automatically! This action creates a real problem when doing later synchronizations of all of the folders! The date will not be the original date of the E-mail and the original file will be over copied with the file with the newest date stamp. I stopped Indexing on the *.eml files and that stopped the time stamp change when overcopy synchronization, but if the file is selected during a viewing in Windows Explorer then the Time Stamp is updated to the current date again! A solution to this problem would be greatly appreciated if anybody knows of one. Thanks - - - Shorto

    Thursday, April 8, 2010 1:58 PM

Answers

  • The Date and Timestamp changing issue in Windows 7 has a two part fix!

    1. Disable the Indexing of the *.eml file type in the Indexing Options located by Clicking on "Control Panel" -  "Indexing Options" - Advanced Button - File Types Tab - scroll down to the .eml file type and uncheck the Box then click OK to finish, so that the Email type of files won't be Indexed.
    2. Delete the Registry Entry listed below, be sure to Export and Save the original Key so it could be Restored if something goes wrong!  \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers
     and Delete the .eml entry
     
    That should fix the problem with the changing Date/Timestamp of Email Files. For more information read CarlS's WindowsSeven Fourm thread where I also have more input:
     
     http://www.sevenforums.com/browsers-mail/35334-eml-files-timestamps-updated-constantly.html
     
    This should give you a better understanding on the problem and the Fix. - - - Shorto

    • Marked as answer by ShortoW Tuesday, November 6, 2012 3:31 PM
    Tuesday, November 6, 2012 3:31 PM
  • Hi,

    This behavior should be by design. I suggest you contact our Windows Live Support to confirm. If it can be always re-produced, we will consider to report it to proper department.

    How to Contact Windows Live Hotmail Support - Windows Live


    Arthur Xie - MSFT
    Monday, April 12, 2010 8:31 AM
    Moderator

All replies

  • Hi,

    This behavior should be by design. I suggest you contact our Windows Live Support to confirm. If it can be always re-produced, we will consider to report it to proper department.

    How to Contact Windows Live Hotmail Support - Windows Live


    Arthur Xie - MSFT
    Monday, April 12, 2010 8:31 AM
    Moderator
  • Hello,
    I've the same problem:
    I've many emails (.eml files) stored in a folder on my PC and I use a program to synchronize this folder on an external hard disk. But, every time I do the synchronization, these .eml files always seem to be modified, even though they have never been opened or modified by me!
    But the files are really different: the modified date of .eml files is constantly and automatically (not by me) changed.
    So I've to synchronize these files each time uselessly transferring many GBs and losing a lot of time...
    I want to say that I have this problem only with Windows 7 64 bit and .eml files. Instead in Windows XP everything is working correctly.
    How can I avoid this annoying problem?
    Thank you.
    Tuesday, November 6, 2012 11:16 AM
  • The Date and Timestamp changing issue in Windows 7 has a two part fix!

    1. Disable the Indexing of the *.eml file type in the Indexing Options located by Clicking on "Control Panel" -  "Indexing Options" - Advanced Button - File Types Tab - scroll down to the .eml file type and uncheck the Box then click OK to finish, so that the Email type of files won't be Indexed.
    2. Delete the Registry Entry listed below, be sure to Export and Save the original Key so it could be Restored if something goes wrong!  \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers
     and Delete the .eml entry
     
    That should fix the problem with the changing Date/Timestamp of Email Files. For more information read CarlS's WindowsSeven Fourm thread where I also have more input:
     
     http://www.sevenforums.com/browsers-mail/35334-eml-files-timestamps-updated-constantly.html
     
    This should give you a better understanding on the problem and the Fix. - - - Shorto

    • Marked as answer by ShortoW Tuesday, November 6, 2012 3:31 PM
    Tuesday, November 6, 2012 3:31 PM
  • Hello ShortoW,
    Thanks for the good reply, but I don't want manually modify Windows registry... is there a cleaner solution?

    Tuesday, November 6, 2012 4:24 PM
  • Hello ShortoW,
    Thanks for the good reply, but I don't want manually modify Windows registry... is there a cleaner solution?

    -----------------------------------------------------------------------------------------------

    I don't know of any! I make backups across my 7 computer network and this fix works for all *.eml files, they just don't get modified by the indexing feature of Windows 7 so the Date/Time stays the same as the original. I installed this fix in April 2010 and have not observed any problems. Making changes to the Registry is easy and safe if you make backups and are carefull - just research the proceedure and learn to do it in a safe manner. - - - Shorto 


    Tuesday, November 6, 2012 4:59 PM
  • Hello,  I am having the same problem when I try to save Outlook files as .eml files in a folder on my Mac hard drive.  I have Outlook 2011 for the Mac.  I need to desperately keep the 'date received' as the original 'date received' and NOT the date when I moved the file to the hard drive (which is what is happening now).  I would greatly appreciate any information on how to preserve the 'date received' so I can keep my emails in the order received.  Thank you
    Thursday, February 7, 2013 10:22 PM
  • Windows 7 Home Premium. Using Outlook for email.

    I followed these steps exactly as written and it did not solve the problem.

    Copy of saved email from flash drive to hard drive preserved the email modified date. However, when opening and closing the email the modified date of this email (along with others copied to that folder) changed to today's date. Restored registry to original state.

    I am not a techy. Is there a step missing?

    Please advise

    Captain Bob

    Friday, May 16, 2014 8:46 PM
  • This procedure worked pretty good in Windows 7, but it doesn't work in Windows 8/8.1. I don't know what keeps changing the modified Date in Windows 8/8.1 with indexing disabled for *.eml files. It's driving me crazy too when I Archive Email files! - - - Shorto
    Saturday, May 17, 2014 8:30 PM
  • Solved!!! By a suggestion from Mr. Spigolo, on the Microsoft Support site.

    Simply remove the .eml extension from the Indexing Options Advanced page,

    in the Control Panel! It DOES work!

    Thanks, Mr. Spigolo!

    Marco254

    Friday, April 21, 2017 8:21 PM
  • Perhaps Solved!!! in Win8 but not in 8.1, which lacks the 'File types' tab in the Advanced Options page.  And here I've been using 8.1 for years without noticing that the Win7 Registry fix had stopped working...
    Saturday, July 4, 2020 9:07 AM