locked
MOH and Media Bypass no longer working after Skype Business updates RRS feed

  • Question

  • Not using the Skype Business skin but still using the Lync Enterprise 2013 skin

    1 - MOH still works ok with call park but not for basic Lync to Lync calls or Lync to PSTN calls. Basically I noticed that CsClientPolicy EnableClientMusicOnHold was now set to false instead of true and so I set it back to True and set the music file path as per below. Now when I place a call on hold I hear the new soft swoosh sound for going on hold but I don't not hear any music. Under Options>Ringtones and Sounds I have the following  file selected: C:\Program Files\Microsoft Lync Server 2013\Application Host\Applications\Conferencing Attendant\Media\Music\DefaultHold.wma which seems to work fine for call park but not basic call HOLD. Note: the Hold/Resume functionality/sip signalling works ok - any ideas?

    2 - My current setup is with a Mitel MiVB PBX connected via a sip trunk (does not support TLS/SRTP and so it is disabled and using TCP/RTP) to Lync Enterprise 2013 with redundant mediation servers Ms-1 and Ms-2. I have Network Configuration > Global > Enable media bypass and Always bypass selected and enabled, as well, under Voice Routing > Trunk Configuration >  [Encryption support level = Not Supported / Refer = 3rd party / Enable media bypass = enabled / Centralized media processing = enabled] ... after the update the media is not bypassing mediation servers anymore ... any ideas as to why?

    Tuesday, April 21, 2015 8:34 PM

All replies

  • Not using the Skype Business skin but still using the Lync Enterprise 2013 skin

    1 - MOH still works ok with call park but not for basic Lync to Lync calls or Lync to PSTN calls. Basically I noticed that CsClientPolicy EnableClientMusicOnHold was now set to false instead of true and so I set it back to True and set the music file path as per below. Now when I place a call on hold I hear the new soft swoosh sound for going on hold but I don't not hear any music. Under Options>Ringtones and Sounds I have the following  file selected: C:\Program Files\Microsoft Lync Server 2013\Application Host\Applications\Conferencing Attendant\Media\Music\DefaultHold.wma which seems to work fine for call park but not basic call HOLD. Note: the Hold/Resume functionality/sip signalling works ok - any ideas?

    2 - My current setup is with a Mitel MiVB PBX connected via a sip trunk (does not support TLS/SRTP and so it is disabled and using TCP/RTP) to Lync Enterprise 2013 with redundant mediation servers Ms-1 and Ms-2. I have Network Configuration > Global > Enable media bypass and Always bypass selected and enabled, as well, under Voice Routing > Trunk Configuration >  [Encryption support level = Not Supported / Refer = 3rd party / Enable media bypass = enabled / Centralized media processing = enabled] ... after the update the media is not bypassing mediation servers anymore ... any ideas as to why?

    • Merged by Eric_YangK Wednesday, April 22, 2015 1:01 AM Duplicate
    Tuesday, April 21, 2015 8:31 PM
  • Hi geraldchar,

     

    Some suggestions for your reference.

    Question 1:

    Try to run the following cmdlet,

     

    Set-CSClientPolicy –Identity Global –EnableClientMusicOnHold $true –MusicOnHoldAudioFile “\\lyncservername\LyncMOH\DefaultHold.wav”

    Note: Everyone should be able to read the share file.

     

     

    Question 2:

    Try to run the following cmdlet,

    Set-CsMediaConfiguration -Identity Global -EncryptionLevel SupportEncryption

    And there’s a similar KB for your reference.

    https://support.microsoft.com/en-us/kb/2761579


    Best regards,

    Eric



    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, April 22, 2015 9:49 AM
  • MOH issue: Thx but i have tried many times without success, I even added and pointed to a new file magicHold.wma (BTW DefaultHold is a .wma file and not .wav) which I have set for both Call Park hold and basic call hold (i can see the file is selected under the lync client options > Ringtones and Sounds > Play MOH + <.wma file path>. The magicHold.wma file is played ok during call park but for basic call there is still still NO MOH regardless of which file I select for basic call MOH - I have restarted my VM-Front End server box without any chnage - is there anything else that could possibly be affecting this? Also when I capture the RTP on the mediation server I don't see any MOH RTP being sent from Lync to PSTN when on hold. Please advise if anyone has any other insight.
    Set-CSClientPolicy Identity Global EnableClientMusicOnHold $true MusicOnHoldAudioFile \\lyncservername\LyncMOH\DefaultHold.wav
    Wednesday, April 22, 2015 3:09 PM
  • Lync MOH not working after Skype Business update: Please note that even though I have successfully issued the Set-CSClientPolicy –Identity Global –EnableClientMusicOnHold $true –MusicOnHoldAudioFile “\\lyncservername\LyncMOH\DefaultHold.wma” command and can see that MOH is enabled and on hold music file path is correctly set when i look at the HOLD SDP Invite a=inactive instead of a=sendonly which means that music on hold is NOT enabled - how can this be? 
    Wednesday, April 22, 2015 6:25 PM
  • Hi geraldchar,

    Have you tested with the old client (Lync 2013) ?

    Can the Lync 2013 play the music ?

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, April 26, 2015 8:23 AM
  • Yes i have tried with an old client same issue. As i mentioned above the problem is NOT with the client but somehow with Lync MOH setting even though the actual clients all show MOH enabled and the powershell clientpolicy clearly shows that MOH is enabled and pointing to the correct DefaultHold file; however when Lync HOLDs call the respective Lync INVITE SDP incorrectly contains a=inactive (ie no media to follow and therefore MOH is disabled and not enabled) instead of a=sendonly when MOH is properly enabled. Something on Lync is messed up yet i cannot find anyone who has experienced this same issue and/or how to resolve it. 
    Monday, April 27, 2015 12:24 PM
  • Hi geraldchar, we have the same issue. Were you able to resolve it?
    Wednesday, November 25, 2015 7:49 AM
  • I was able to resolve it with a registry string that's missing. If you specify MOH file with Lync client policy the registry string is created, otherwise missing. In previous Lync installations it seems the registry string was already there on installation.

    In short, you can add registry strings with GPO:

    For Office 2013:

    Add REG_SZ to [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\15.0\Lync]

    "MusicOnHoldAudioFile"="C:\\Program Files (x86)\\Microsoft Office\\Office15\MEDIA\\DefaultHold.wma"

    For Office 2016:

    Add REG_SZ to [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Lync]

    "MusicOnHoldAudioFile"="C:\\Program Files (x86)\\Microsoft Office\\Office16\\MEDIA\\DefaultHold.wma"

    Wednesday, November 25, 2015 10:02 AM