none
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. RRS feed

  • Question

  • A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26- Error:Locating Server\instance Specified)

    How Can i solve this?

    • Edited by Chino1217 Tuesday, March 25, 2014 6:17 AM
    Tuesday, March 25, 2014 6:16 AM

Answers

All replies

  • Check the below

    1. SQL Server are up are runing
    2. check the correct instance name
    3. add in exception in firewall
    4. check if anti virus is using it
    5. check the sql browser services


    Ramesh Babu Vavilla MCTS,MSBI

    Tuesday, March 25, 2014 6:34 AM
  • 1. Make sure SQL Server Service is running
    2. If a named instance, make sure SQL Server browser service is running
    3. Make sure SQL Server is configured to allow remote connections
    4. Examine the SQL Server error log for messages confirming that SQL is listening on the expected network interfaces and ports
    5. Test server connectivity with PING from the client machine
    6. Test port connectivity using TELNET or PowerShell to the server and port (from step 4) from the client machine.  For example
    a. TELNET <server-name> 1433
    b. PowerShell: 1433 | % { echo ((new-object Net.Sockets.TcpClient).Connect("YourServerName",$_)) "server listening on TCP port $_" }
    7. Check firewall settings if step 5 or 6 connectivity test fails

    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Consulting: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance
    SQL Server Integration Services: Business Intelligence

    Tuesday, March 25, 2014 12:34 PM
  • Is there a firewall in the mix?  Depending on the version of SQL you may need to configure SQL to listen on a specific port (should be 1433, but I have seen SQL not listening on this port  by default in some later installations) and open that port on the firewall.

    Check out the link below:

    http://support.microsoft.com/kb/823938

     
    Tuesday, March 25, 2014 1:02 PM
  • Simple tutorial if you're just getting started. Tutorial: Getting Started with the Database Engine 

    Detailed help: How to Troubleshoot Connecting to the SQL Server Database Engine  


    Rick Byham, Microsoft, SQL Server Books Online, Implies no warranty

    Tuesday, March 25, 2014 3:36 PM
  • I had the same problem. I tried restarting services related to SQL and checking TCP/IP settings and port numbers in SQL Server configuration manager, checked my instance name and tried restarting my computer. It still didn't work. Finally, I figured that my SQL Server Browser service in services.msc was disabled. I enabled and restarted the service. Voila, it worked!!
    • Proposed as answer by NFursova Tuesday, February 26, 2019 6:35 PM
    Sunday, January 10, 2016 7:39 PM
  • A comprehensive troubleshooter to solve various connectivity issues was recently published.

    Solving connectivity issues to SQL Server

    Friday, February 3, 2017 5:43 AM
  • here is the solution for you https://www.youtube.com/watch?v=6YYOlOBR-zc

    Monday, September 4, 2017 6:44 PM
  • Dear Drishya1!
    Thank you very much!
    I used your advice.
    It helped to solve the similar problem.
    There are a few SQL Server named instances.

    I got a network related or instance specific error 1225 in sql server 2014

    while trying to connect to some SQL Server named instance.
    I opened the Control Panel\All Control Panel Items\Administrative Tools\Services.
    I found that the SQLBrowser and SQLAgent$NameOfYourSQLNamedInstance were not running.
    I started them.
    Now I can connect to some SQL Server named instance.

    • Edited by NFursova Tuesday, February 26, 2019 6:48 PM
    Tuesday, February 26, 2019 6:46 PM
  • Perfect!
    Friday, March 29, 2019 6:46 AM
  • If the server is on the local machine, just paste the string below while creating a SqlConnection.

    SqlConnection con = new SqlConnection("Data Source=(local); Initial Catalog=TacticalDB; Integrated Security=True;");

    then Alles gut.

    Tuesday, June 18, 2019 8:44 AM