locked
Multiple copies of the same Oracle EM alert appear on SCOM console RRS feed

  • Question

  • We have an Oracle EM Grid Control 11.1.0.1 installation and the SCOM connector is configured to send alerts to a SCOM 2007 R2 system.
    We noted that every alert from OEM appears on the SCOM console 5 times (a minute late with each other), we suspect that the SCOM connector do not receive any confirmation from SCOM and re-send the same msg many times.

    The EM alert page gives the following error:

    Error calling Java callback SCOM Connector:oracle.sysman.connector.event.common.ECNotificationCallback: java.net.SocketTimeoutException: Read timed out (Rule Owner=SYSMAN, Rule Name=Database Availability and Critical Stat
    es)

    We would like to solve the communication problem or find any setting for not re-send any alert 5 times to SCOM.

    Thank you.

    Alex
    Tuesday, August 2, 2011 8:43 AM

Answers

  • Alex,

    this question is specific for the OEM - SCOM Connector which is supplied and supported by Oracle.

    I don't know if Oracle supports the connector on SCOM 2007 R2, you need to check with Oracle to be sure. Last customer I was configuring this they didn't support it.....

    There is no way to avoid this behaviour on the SCOM side since the connector works as expected but seems to fail to reply back it's status to the Java website which is part of the OEM - SCOM connector solution.

     

    Cheers,

    Oskar

     

    • Marked as answer by Nicholas Li Wednesday, August 17, 2011 6:54 AM
    Tuesday, August 2, 2011 11:22 AM
  • Hi,

    According to the error received, this issue should be related to Oracle, please contact Oracle support to make sure the configuration is correct.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Nicholas Li Wednesday, August 17, 2011 6:54 AM
    Wednesday, August 3, 2011 9:21 AM
  • Ok, thank you for your help.

    Alex

    • Marked as answer by Alepie Friday, August 19, 2011 9:52 AM
    Friday, August 19, 2011 9:52 AM

All replies

  • Alex,

    this question is specific for the OEM - SCOM Connector which is supplied and supported by Oracle.

    I don't know if Oracle supports the connector on SCOM 2007 R2, you need to check with Oracle to be sure. Last customer I was configuring this they didn't support it.....

    There is no way to avoid this behaviour on the SCOM side since the connector works as expected but seems to fail to reply back it's status to the Java website which is part of the OEM - SCOM connector solution.

     

    Cheers,

    Oskar

     

    • Marked as answer by Nicholas Li Wednesday, August 17, 2011 6:54 AM
    Tuesday, August 2, 2011 11:22 AM
  • Hi,

    According to the error received, this issue should be related to Oracle, please contact Oracle support to make sure the configuration is correct.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Nicholas Li Wednesday, August 17, 2011 6:54 AM
    Wednesday, August 3, 2011 9:21 AM
  • Ok, thank you for your help.

    Alex

    • Marked as answer by Alepie Friday, August 19, 2011 9:52 AM
    Friday, August 19, 2011 9:52 AM
  • Alex,

    Were you able to get this resolved with Oracle? If so, would you mind sharing the nature of the problem and the resolution? I'm running into the same issue, 5 SCOM alerts for each OEM alert.

    Thanks

    • Proposed as answer by Glenn_261 Monday, March 26, 2012 3:11 PM
    • Unproposed as answer by Glenn_261 Monday, March 26, 2012 3:11 PM
    Monday, March 26, 2012 2:01 PM
  • Hi Paul,

    I came across this problem and had extensive support with oracle and the third party vendor who created the SCOM connector. Verify that the SCOM connector's configuration is set below GRID's repeat interval. Here's where to look:

    $SCOM_CONNECTOR_INSTALL_LOCATION/webservice/adapters/conf/framework.properties

    Change the following parameter in this file:

    scom2007.connector.response.timeout = 50

    In this case, in Grid the alert was set to be checked every minute and originally the above setting was set to 75(seconds). If your configuration is the default, it should be at 75 as well.

    Stop/start the SCOM service afterward.

    $SCOM_CONNECTOR_INSTALL_LOCATION/webservice/adapters/bin/service.sh stop

    $SCOM_CONNECTOR_INSTALL_LOCATION/webservice/adapters/bin/service.sh start

    Glenn


    • Edited by Glenn_261 Monday, March 26, 2012 3:33 PM
    Monday, March 26, 2012 3:31 PM