none
How do I create project in project pro and save/publish to project server AND pick up site template I have on project server RRS feed

  • Question

  • We have Project Server working and really are liking what we are seeing.  However, today I was asked how to take a current Project Professional project 2010 and save it to project server AND make sure they pick up the SharePoint site template we are using in Project Server when we create the Project from there.  I was able to save/publish the project to project server but it did not pick up the template I have associated within the project types association.  Did I miss a step somewhere or do something wrong on the save in some way?  They really want to be able to do this and I understand why.  Any help?

    Cletus51

    Wednesday, May 9, 2012 11:06 PM

All replies

  • Dear Cletus51,

    In PS 2010, there are two locations you can specify the Project Site template.  One is in the EPT, and the other is in the Server Settings > Project Site Provisioning Settings page.

    When you initiate a new project from PWA > Project Center > New Project, you can select an EPT from the drop down, and by association, the Project Site Template.  When you eventually publish that project the Project Site will be created based on the template listed in the EPT.

    You may also start a new project from Project Professional, in this case you will be creating a "basic project" - and will not be able to select an EPT.  When you finally publish that project, it will pick up the Project Site Template from the Server Settings > Project Site Provisioning page.

    Hope that helps,


    Thanks, Eric S. http://www.pcubed.com

    Thursday, May 10, 2012 2:03 AM
  • Hi Cletus51,

    Are you looking to create Project Workspace site (Project SharePoint Site) using your customized template

    If yes, then are you able to see your templete listed under

    Server Settings > Project Site Provisioning page


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    Thursday, May 10, 2012 2:52 AM
    Moderator
  • I must be doing something wrong.  I have a EPT setup so that when I create a new project within PWA, it picks up the template and creates the site; that works fine.  I just select the "abc project" from the New drop down and the project is created and the site is created.  However, when I open project pro on my desktop and say new project, put in some tasks and then do Save As and then publish to project server, it does not pick up the site template.  it saves the project, publishes it, etc. but when I click on Project Site, it says nothing exists.  How do I get it to pick up that site template?  Do I have to save this in a certain way? 

    Cletus51

    Thursday, May 10, 2012 3:27 PM
  • When you create a new Project, do one of the following

    Create a new project using a Server template

    Or 

    Create a new blank project, save it (make sure you are saving it as project)

    when you try to publish it it will ask you if you want to create a website.

    Thursday, May 10, 2012 9:43 PM
  • Dear Cletus51,

    Have you looked at your Server Settings > Project Site Provisioning Settings page?

    What does it indicate?

    Also, are you able to go to Server Settings > Project Sites and create a new site for that project from that page?

    Let us know...


    Thanks, Eric S. http://www.pcubed.com

    Monday, May 14, 2012 3:12 PM