none
MDT 2013 rules by SequenceID Does not work RRS feed

  • Question

  • Hello, 

    Im having an issue with MDT 2013 Custom Settings
    In 2012 U1 I used the following lines to enable diffrent rules set to diffrent Task Sequences but in 2013 it's just doesn't work

    "
    [Settings]
    Priority=TaskSequenceID, Default

    [Default]
    Skip1=YES

    [TaskID]
    Skip2=YES
    "

    The Problem is that Skip1 get's skipped but Skip2 does not,
    All the rules which are not under Default are ignored.

    I temporary resolved it by puting only one task, and all the rules are in the Default rules but I must get it working like in 2012.

    Thank you!

    Monday, September 29, 2014 12:07 PM

All replies

  • I assume that when you say Skip1 and Skip2 you are talking about the SkipXxx variables in MDT that allow you to skip wizard pages in the Litetouch Wizard? If so, that's not how it works, and it never worked this way in MDT 2012 U1.

    The cs.ini file get's processed *before* the Wizard, and before you have selected a TaskSequenceID type. So there is no way for ZTIGather.wsf to run the [TaskSequenceID] section ( not the [TaskID] section) *after* you have selected the Task Sequence, and *before* you branch to other wizard page(s).

    I assume, instead, that you imported an external modification to the wizard script to get it working as you say on MDT 2012 U1. Similar to johan's modification: http://www.deployvista.com/tabid/36/EntryID/139/language/en-US/Default.aspx


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Monday, September 29, 2014 9:31 PM
    Moderator
  • I have another environment with MDT 2012 U1 that works perfectly with the CS.ini as I described.
    The rules are processed before the wizard opens his UI phase and after the user choose  a Task he applies those settings.
    I checked the modification that are suggested in the link to make sure my server It is not configured like that and it is in fact it is not configured like that.

    I did not add any external features to the wizard or to any part of the deployment.

    Is someone else know of this issue?

    Tuesday, September 30, 2014 10:49 AM
  • Can you copy the (working) Bdd.log file to a public site like OneDrive and share the link here.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Tuesday, September 30, 2014 8:38 PM
    Moderator
  • Sorry for the slow responce, I checked a few things.
    I can't copy files because I'm working in a isolated Enviorment.

    I tried to lower the MDT version and WAIK version without luck.
    Ill focus the issue more, Some rules are apllied and some are not, for example, The line
    "SkipDomainMembership=YES" is ignored when its in the [TaskSequenceID] section but applied when in [Default].
    "DeploymentType=REFRESH" is apllied in the [TaskSequenceID] section.

    I made sure that there aren't any conflicting rules and the syntex is correct and I have a working server with identical configation (As I'm aware of).

    Sunday, October 5, 2014 12:30 PM
  • Modification of the MDT and/or WAIK version(s) is not interesting to the problem presented above.

    If you still need help, please copy the bdd.log files to a public site like OneDrive, and share the link.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Sunday, October 5, 2014 11:38 PM
    Moderator
  • I can't copy files because I'm working in an isolated Enviorment.

    In the risk of sounding rude, this is very unhelping.
    I see this thread is going nowhere, I'll try to manage by myself.

    Thnaks

    Monday, October 6, 2014 7:28 AM
  • Like Keith has said, the CS.ini is processed before the wizard is shown. Have you pre-set the TaskSequenceID somewhere else before running it on the older version, say using maybe DefaultGateway rules?
    Monday, October 6, 2014 9:54 AM