Exchange/Office 2007 out of office failure RRS feed

  • Question

  • We've got a client with Exchange 2007 and Outlook 2007 SP2, whose OOF isn't working. 

    When the users access Out of Office through Outlook, they get the message:

    Your Out of Office settings cannot be displayed, because the server is currently unavailalbe. Try again later.

    I verified that the user I'm testing with is connected to Exchange via HTTPS. Outlook's "test e-mail auto configuration" says that Autodiscover is failing with errors 12029, 0x800c8203, and 0x80072efd. Fine. So I went to OWA and enabled OOF there, but when I sent a test message (from both internal and external mailboxes), the user gets the messages, but I don't get any OOF reply.

    The users reported that OOF worked in October (and maybe December), but I didn't join the company until February so I can't say if anything changed (or that Autodiscover is even supposed to be configured for this client). What are my next troubleshooting steps. Thanks.

    Thursday, May 24, 2012 2:17 PM

All replies

  • Hi

    Autodiscover is the cause of this problem so you will have to start there.  I would start with ensuring that the certificate enabled for IIS does have the autodiscover name on it.


    Thursday, May 24, 2012 2:22 PM
  • Hello,

    Your certificate may cause autodiscover issue .If these users use outlook anywhere, please check if it is SAN certificate and the certificate name is correct.

    And please check if there is a record for “autodiscover” on DNS server.

    If using outlook, please remove old certificate and apply new certificate again.

    Besides, please make sure you have enabled”require ssl” and “ignore client certificate”

    For EWS, please check if the service Mailbox Assistant is running on the mailbox servers. If the service starts, please recreate EWS.

    Before recreating EWS, please remove old EWS firstly.


    After do it, please restart iis.

    Best Regards,


    Friday, May 25, 2012 6:29 AM
  • Hello,

    Any update?

    Best Regards,


    Monday, May 28, 2012 7:09 AM
  • I'm not sure that I agree with the suggestion that Autodiscover is the problem. We host Exchange for several clients, and nobody else has complained.

    I have some additional information.

    I setup Outlook 2010 on my home computer (not on the domain, not on the VPN) and logged into the test user's mailbox. When I tested AutoDiscover (Test e-mail autoconfiguration...), autodiscover failed for his domain, but succeeded for As far as I know, that's correct because we don't have a certificate for each client. Instead, we have one wildcard certificate for our domain.

    So I was looking into trouble with the EWS. When I run Get-WebServicesVirtualDirectory, I get the following error:

    Get-WebServicesVirtualDirectory : An error occurred while trying to access IIS (Internet Information Service) metabase. Make sure the Internet Information Service Manager component is installed and configured properly

    I'm not sure what that refers to. I know IIS is running on the CAS servers because webmail works.

    Friday, June 1, 2012 8:46 PM
  • Any other thoughts? 

    To be clear, the Outlook clients are on a different domain than the Exchange server. 

    I added an srv record in the customer's DNS (in their domain) for That didn't help.

    Tuesday, June 26, 2012 3:58 PM
  • What OS is the client running? We had a major issue when we recently upgraded from Exchange Server 2007 to 2010 - Autodiscover would not function on about 30% of clients.

    We eventually tracked it down to the clients 'misreporting' that they were running Win XP SP3 when in fact they were Win XP SP2.

    Redeploying Win XP SP3 to the problem PCs resolved the issue...

    Monday, July 9, 2012 10:07 AM
  • I'll check.
    Wednesday, July 11, 2012 8:58 PM
  • The same issue will occur when the user account and name is not the same as the default reply to email. for instance if my domian account is fred but my default reply to email is  this can occur.

    I have this issue and no idea how to resolve it. 

    Dan Sichel

    Monday, September 24, 2012 4:12 PM