locked
Excel 2010 Dialog Boxes Hidden behind Application causing application freezing RRS feed

  • Question

  • Recently upgraded to Office 2010 (32bit) /Windows 7.  Have hundreds of users that we support and so far most have upgraded.  Noticed with some users though - not all - just a small percentage, when they click SaveAs in Excel 2010, the application freezes.  On closer scrutiny we realized what was happening was the SaveAs dialog box was BEHIND the main Excel window.  The only way to restore it is to click on the tab from the Taskbar or minimize all the windows to FIND the SaveAs Dialog box.  Understandably this is causing these users stress and inconvenience.  It is very unproductive and a nuisance to say the least.  The only other variable here is that all these users have multiple monitors, usually 2-4.  But for some, this happens in their main monitor and/or the monitor that Excel is opened in and which has the focus.  Even more strange is that this does not occur to everyone, just a handful of users so far who have reported the issue.  We have also noted it happens with other dialog boxes as well, not just the SaveAs so it seems generic in that sense.

    The other item with this issue is that it's not persistent.  Users have reported it's sporadic and comes and goes.

    Is this a bug? 

    Any feedback greatly appreciated.

    Wednesday, December 14, 2011 8:51 PM

Answers

  • I agree with Ron that this issue is not caused by Excel itself. But some Excel add-in might be the root of this issue in few reporting after we upgrade Office. Thus, if there is any add-ins on the user’s computer, I suggest we test in excel safe mode to check the result. (Hold down the “Ctrl” and click the Excel icon to launch it)

     

    Feel free to post back. Thanks.

    Tony Chen

    TechNet Community Support

    • Marked as answer by Tony Chen CHN Monday, December 26, 2011 3:58 PM
    Wednesday, December 21, 2011 8:35 AM

All replies

  • Freezing is the bane of new versions, but this depends on the path saving file and network response time or efficiency of the hard drive when it concerns a local record.
    Oskar Shon, Office System MVP

    Press if Helpful

    Thursday, December 15, 2011 11:39 AM
  • Oskar

     

    This issue is not just limited to SaveAs command but also to other intr-Excel commands like Insert Cells etc, where you get a pop-up dialog box.  So the issue is not just limited to file paths as you imply.  Additionally, I don't believe this is hardware related as all the machines are identical yet this occurs sporadically, doesn't occur on ALL machines.

    Thursday, December 15, 2011 2:37 PM
  • If the problem occurs when you click on a cellis a different function. That would be happend when for example, synchronizing e-mail program, or refresh pages in the browser, Internet chat in the background, takes system resources,

    it also  Office application does not release - waits until the memory finish the process.

    I think it was necessary to investigate the matter further are limiting services and processes to a minimum considering whether to blame the individual hardware performance or running programs.


    Oskar Shon, Office System MVP

    Press if Helpful

    Thursday, December 15, 2011 3:08 PM
  • On Wed, 14 Dec 2011 20:51:03 +0000, Nootrino wrote:
     
    >
    >
    >Recently upgraded to Office 2010 (32bit) /Windows 7.  Have hundreds of users that we support and so far most have upgraded.  Noticed with some users though - not all - just a small percentage, when they click SaveAs in Excel 2010, the application freezes.  On closer scrutiny we realized what was happening was the SaveAs dialog box was BEHIND the main Excel window.  The only way to restore it is to click on the tab from the Taskbar or minimize all the windows to FIND the SaveAs Dialog box.  Understandably this is causing these users stress and inconvenience.  It is very unproductive and a nuisance to say the least.  The only other variable here is that all these users have multiple monitors, usually 2-4.  But for some, this happens in their main monitor and/or the monitor that Excel is opened in and which has the focus.  Even more strange is that this does not occur to everyone, just a handful of users so far who have reported the issue.  We have also noted it happens with other
    >dialog boxes as well, not just the SaveAs so it seems generic in that sense.
    >
    >The other item with this issue is that it's not persistent.  Users have reported it's sporadic and comes and goes.
    >
    >Is this a bug? 
    >
    >Any feedback greatly appreciated.
     
    I have experienced this issue in other programs, completely unrelated to Excel.  And on both single and dual monitor setups.  I cannot recall when it started, but I wonder if it is related to an issue with Windows (I am using W7x64), rather than with Excel.
     

    Ron
    Thursday, December 15, 2011 3:31 PM
  • On Wed, 14 Dec 2011 20:51:03 +0000, Nootrino wrote:
     
    >
    >
    >Recently upgraded to Office 2010 (32bit) /Windows 7.  Have hundreds of users that we support and so far most have upgraded.  Noticed with some users though - not all - just a small percentage, when they click SaveAs in Excel 2010, the application freezes.  On closer scrutiny we realized what was happening was the SaveAs dialog box was BEHIND the main Excel window.  The only way to restore it is to click on the tab from the Taskbar or minimize all the windows to FIND the SaveAs Dialog box.  Understandably this is causing these users stress and inconvenience.  It is very unproductive and a nuisance to say the least.  The only other variable here is that all these users have multiple monitors, usually 2-4.  But for some, this happens in their main monitor and/or the monitor that Excel is opened in and which has the focus.  Even more strange is that this does not occur to everyone, just a handful of users so far who have reported the issue.  We have also noted it happens with other
    >dialog boxes as well, not just the SaveAs so it seems generic in that sense.
    >
    >The other item with this issue is that it's not persistent.  Users have reported it's sporadic and comes and goes.
    >
    >Is this a bug? 
    >
    >Any feedback greatly appreciated.
     
    A search using Google reveals that this may be a problem with W7, and was first reported during beta testing!
     
     
    and for a possible fix, but with some serious caveats:
     
     
     

    Ron
    Thursday, December 15, 2011 3:55 PM
  • I agree with Ron that this issue is not caused by Excel itself. But some Excel add-in might be the root of this issue in few reporting after we upgrade Office. Thus, if there is any add-ins on the user’s computer, I suggest we test in excel safe mode to check the result. (Hold down the “Ctrl” and click the Excel icon to launch it)

     

    Feel free to post back. Thanks.

    Tony Chen

    TechNet Community Support

    • Marked as answer by Tony Chen CHN Monday, December 26, 2011 3:58 PM
    Wednesday, December 21, 2011 8:35 AM
  • i have the same problem but it only happens with excel... i have noticed that after i send an email using Outlook 2010 with an attachement it starts happening... i algo noticed that when this happens i always have to open and minimize Outlook so i can find the pop up box from excel... this happens basically to all pop up boxes in excel unhide sheets, format numbers, save+as and so on.....

    thought it was a weird problem but its seems there a lot of people with this same issue.....

    • Proposed as answer by BluMty Wednesday, June 6, 2012 3:08 PM
    Wednesday, June 6, 2012 3:08 PM
  • I've found the only way to access the dialog box again is to double click on an existing spreadsheet to open it and the dialog box stays on top so you can close it out as you normally would.  Not sure what is causing it, though.
    Tuesday, August 7, 2012 2:29 AM
  • Our CFO is having the issue as well, which is becoming a serious problem.  The fix in the other thread (editing the Registry) did not resolve it.

    Geoffrey Schaller

    Tuesday, October 9, 2012 6:00 PM
  • In my case (happening to multiple users) it is an Outlook add in that we cannot do without, and getting the programmers to recode is "pulling teeth" so......

    If Outlook is open, close it and click in the spreadsheet. Tada!

    • Proposed as answer by Kami_Kaze Thursday, February 9, 2017 3:19 PM
    Monday, October 15, 2012 7:00 PM
  • upinya1 - That shouldn't have worked, but it did.  CEO had 4 unsaved spreadsheets open, so we were trying to avoid force-closing Excel.  Thanks!!
    • Proposed as answer by CJv3 Monday, December 5, 2016 11:39 AM
    Friday, November 16, 2012 9:07 PM
  • This isn't a long-term fix, but it helps get you out of the immediate situation.  Hover your mouse over the application on the tool bar.  It should bring up one or more thumbnails of instances/documents open for that application.  Hover your mouse over the thumbnail of the instance/document with the hidden dialog box.  Right click on that thumbnail and it will bring up the instance/document, only with the dialog in front this time.
    Wednesday, November 21, 2012 9:05 PM
  • My experience with this issue is if you press escape you unfreeze your screen, second, close outlook, then continue your work with excel. It won't do the same again, it only happends when outlook is opened, I have win64 and office 32, it may be the cobination that triggers it, does any one have it with office 64 or win32?

    Apparently you can open Outlook after opening Excel and the error won't appear.

    Wednesday, December 5, 2012 2:40 PM
  • I have the same problem and none of the solutions I have heard work. . . for example, when I open the Excel Name Manager, then Dialog opens in the background and Excel Freezes. I can't do anything except kill the Excel Application with the Task Manager and start over. . . at least now I am aware that "Escape" will close the dialog and get me back.

    I have multiple monitors, and if I keep Excel on the right, then the dialog opens on the left monitor and I can create the name, close the dialog etc. . .  In the haste of the day and many different windows open on the screens sometimes I get caught with Excel on the left monitor, open a dialog that becomes hidden and I am toast.

    I am one to admit my love for computers has diminished allot over the last 20 years as this in one of many technical problems that plaque me on a daily basis.

    Any advice toward a solution would be appreciated (other than the obvious, which is keep Excel on the Right Monitor).

    Windows 7 Professional/64bit, Service Pack 1
    Office 2010/32bit


    • Edited by Howard_K Tuesday, January 1, 2013 9:04 PM
    • Proposed as answer by Stephen555 Tuesday, September 2, 2014 12:32 PM
    Tuesday, January 1, 2013 9:02 PM
  • I've seen this for months now and while I don't have an absolute definitive answer, here is what I've found.

    Here are the links to the Microsoft Blogs that explain the isse:

    http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2012/04/26/hidden-dialogs-cause-excel-2010-to-appear-to-hang.aspx

    http://blogs.msdn.com/b/dhruvkh/archive/2012/05/14/outlook-ribbon-woes-on-performing-send-as-e-mail-via-other-office-2010-apps.aspx

    Link Summary...one of your Outlook Addins uses Ribbon Designer to modify the ribbon.  Microsoft is now recommending using Ribbon XML instead.  

    I have found that using the Save and Send feature in Excel seems to trigger the problem on the second use of it.  We have also found that if you hit ESC, you can at least get control of your workbook back.

    I've resorted to, at the moment, creating a shortcut that starts Outlook in Safe Mode.  This seems to solve the problem most of the time.  If you are interested, here is the path you can use to create the shortcut:  

    "C:\Program Files\Microsoft Office\Office14\OUTLOOK.EXE" /safe

    Another thing that has worked for one of my users is to NOT maximize the Excel windows and to Cascade them.  This seems to allow for access to the dialog boxes.  So far, it has only worked for one of my users and the others promise they will try it.

    One other thing that has helped others who have a similar issue is to change a registry setting that helps with window focus:

     HKEY_CURRENT_USER\Control Panel\Desktop\ForegroundLockTimeOut 

    Change the value to 0 and log off/log in to activate it.


    • Proposed as answer by Steven Burnett Wednesday, March 13, 2013 1:16 PM
    • Unproposed as answer by Steven Burnett Wednesday, March 13, 2013 1:17 PM
    • Proposed as answer by Steven Burnett Wednesday, March 13, 2013 1:21 PM
    Thursday, January 24, 2013 4:48 PM
  • Thanks for the tip on closing Outlook to get the dialog box to appear.  I had right clicked on a cell in a worksheet to change the cell formatting when the dialog disappeared under the active worksheet.  After closing Outlook the behavior returned to normal.  Out of curiosity, do you know which Add-In is causing this?

    Tuesday, March 5, 2013 5:30 PM
  • BINGO!

    I can reproduce the annoying pop under behavior after using Save & Send even once.

    Its a great feature, but for now I will have to stop using it. 

    Thanks for the suggestion!  I would never have thought it was related to that...I was searching wondering, is due to having too many files open, etc.

    • Proposed as answer by Achim1234 Friday, November 15, 2013 7:55 AM
    Wednesday, March 13, 2013 1:21 PM
  • Yes the tip to close outlook was very helpful. Thanks!

    Ron Sexton

    Thursday, March 14, 2013 6:09 PM
  • I have a user with the same issue and have changed the LoadBehavior to 0 for all add-ins under: hklm:\software\Microsoft\Office\Outlook\Addins and hklm:\software\wow326432node\Microsoft\Office\Outlook\Addins\ as well as for that particular user and I'm still having this issue. This should basically disable them all, but it appears something else needs to be done, since if the user closes Outlook...the problem goes away.

    Monday, September 16, 2013 1:30 PM
  • When a dialog box is behind Excel, you can get it in front by opening a mail in Outlook, click on Excel, close the just opened mail and grab the dialog box and drag it to the other screen. By doing this you can complete the action you desired. You can do this every time a dialog box is hidden. When you've spread Excel over to screens, you can press ESC to end the action, then you can make the Excel-screen smaller, then you start the desired action again and perform the above described action. It always works with me, but it is very tiresome.
    Thursday, December 19, 2013 2:06 PM
  • Thanks, your input helped. 

    I do believe what caused this was a recent add-in i downloaded to my outlook.

    Sam

    Thursday, February 20, 2014 6:09 PM
  • thanks,

    after reading this article I disabled the last plug in outlook, Nitro PDF.

    I already found out that outlook was the source of the issue.. my solution was.. go to an open email window and close it.

    after I disabled the Nitro PDF plugin, and restarted outlook the behaviour of outlook is now normal.

    thank you very much for this article!

    Friday, February 28, 2014 11:19 AM
  • Thank you so much! This worked for me. I had noticed a correlation between this occurring and me emailing an attachment via Outlook. Sad microsoft hasn't fixed this as of yet.

    • Proposed as answer by acorercf Monday, November 10, 2014 1:59 AM
    • Unproposed as answer by acorercf Monday, November 10, 2014 1:59 AM
    Tuesday, April 8, 2014 5:01 PM
  • On addition here is that excel will still respond to key strokes; so, if you see the problem, you can use arrow keys and the enter key to select the option you want.  

    Steps:

    1)  Go to your task bar and hover over excel.  Double click on the window you want to work with.  (The save dialog box will show up in the fore-screen and you will not be able to select it without it disappearing again.)

    2) Memorize the position of the option you want to select (to save the document is the first and already selected option).

    3) Click on the excel window (dialog box will disappear.)

    4) From memory navigate to the option that you wanted to select and press enter.

    I have also can confirm that the problem comes only after I have used the Save & Send option and closing Outlook does permit excel to function correctly again.

    Tuesday, January 13, 2015 3:08 PM
  • I was having the exact same problem.  I traced it back to a program called Grammerly that I had installed.  Once I removed it, the dialog boxes were  now in front of the application.

    Hope this helps

    Tuesday, November 17, 2015 9:27 PM
  • This issue happens on a vanilla version of excel as well. I just got stuck on the save prompt on exit with no add-on. Actually this is a common problem that Microsoft should look into it, the common dialog msgbox doesn't always display in foreground and is sandwiched between two instance of a program. Most user will simply end task the program which cause lost of data or data corruption sometime.

    Tuesday, June 27, 2017 9:05 PM
  • I hit this bug sometimes, the easiest workaround for me is to hit Alt + F4 on offending window, this will bring the offending dialog window to foreground, then continue your original operation.
    Sunday, November 11, 2018 12:35 AM