none
Trouble with Remote and OWA websites not starting automatically, possibly related to Sharepoint upgrade RRS feed

  • Question

  • I would very much appreciate it if someone could help me out. I'm working with an installation of SBS 2011 Standard that I have not deployed yet but need to very soon. I followed along with the configuration wizards and successfully installed my SSL certificate. Until today the remote.companyname websites would start automatically and everything seemed fine until shortly after I ran an update for sharepoint.

    After restarting the server I received a critical sharepoint health notification as well as a window which popped up soon after logging on informing me of a need to run psconfig to complete the update. There was a reference ID and a link with directions which I followed (I believe dutifully).

    After once more restarting the server I continued to receive the same or similar messages about completing the Sharepoint update and I noticed that when running the sharepoint management page I was getting a user name and password box when clicking on various items that I never noticed before or since; I provided my admin account information in the authentication box that would pop up on the sharepoint management site but the site would freeze.

    This is the first server I have set up with Sharepoint on it and at one point I tried to add an Admin account somewhere in the Sharepoint management site when prompted to specify a user account in an effort to restore the original behavior of the Sharepoint management page. I ran psconfig as the knowledge article I was directed to described to do for a second time and ran the Sharepoint configuration wizard (more than once).

    I restarted again and all seemed to be normal once more until I realized that my Remote.companyname websites had stopped running and I couldn't start them. Each time I tried to start the stopped pages they would fail informing me another site could be using the same port.

    After a lot of trial and error I discovered that by stopping a site listed in IIS called "Sharepoint - 80" (bound to 80 not 443) the remote.companyname sites could be started manually. I was early on in the setup of the server when I had this trouble and had not yet opened IIS manager so I do not know what sites were default and necessary to 2011 server and what sites if any may have been added or changed by the Sharepoint update.

    As of now the site called 'Sharepoint - 80' is stopped. The one above it called 'SBS Sharepoint' is running, actually all the sites are currently running except 'Sharepoint - 80' and everything seems fine as far as I can tell at this time except that if the server is restarted I need to manually start the remote.companyname sites they do not start automatically.

    I don't know if it has anything to do with this but I also noticed that the 'Default Web Site' and 'Sharepoint Web Services' sites in the IIS manager have a small ? mark on there icons and if I mouse over it says "(Multiple protocols)". Not knowing if I'm even looking in the right place and hoping more info is better than less let me mention there is also 'Companyweb' site bound to 80, the 'Default Web site' site bound to 80 and 443, the 'SBS Sharepoint' site is bound to 987, 'SBS Client Deployment Applications' bound to 80, 'Sharepoint Central Administration v4' site bound to 42124, "Sharepoint Web services' bound to 32843,32844,32845 and 'WSUS Administration' site bound to 8530,8531.

    Also I don't think it's related but my 'Services Application Pool - Sharepoint Web Services DEFAULT' component in Sharepoint Credential Management currently has an admin user account associated with it. While following a health security advisory I was in there and either the component I just mentioned or the 'Services Application Pool - Sharepoint Web Services SYSTEM' component (which currently has the spfarm account associated) had an Admin account associated. I believe I returned the two components configuration to the original settings accurately after making changes but I can't recall with absolute certainty and would like to return as much as possible to how it was after the initial setup so any suggestions on that would be greatly appreciated too.

    So to summarize aside from messing with one of those 'Services Application Pool - Sharepoint Web Services' components after the fact and not being completely sure if I put it back the way it was. All I did was allow an update to run then followed the directions carefully and now I have to stop an IIS sharepoint site ('Sharepoint - 80') to even get my remote.company websites to run and I have to start the remote.companyname sites manually every time. Sorry to be so so long winded I've spent an embarrassing amount of time today beating my head against this and wanted to get it all down in the hopes somebody can guide me to a solution.

    Thanks already if you've made it all the way through this post

    Thursday, November 10, 2011 6:30 PM

Answers

  • Hey,

    I had the exact same problem as you. The fix is actually pretty simple...

    Navigate to IIS Manager, go to the list of your websites, you should see default website, right click on it and choose advanced settings. Look at the bottom of the list and you should see an option called "automatically start" or something similiar. It is probably set to false, change it to True and start the website...

     

    I hope this helps... This problem was very frusterating. I think you are right that it is a result of the sharepoint patch that caused this greif

    • Proposed as answer by DocDavid Thursday, December 1, 2011 1:31 AM
    • Marked as answer by AcceliT Tech Monday, December 19, 2011 6:31 PM
    Thursday, December 1, 2011 1:30 AM
  • Sharepoint 80 is what would have been created after running psconfig.Ideally you should remove it from central admin.You don't need it.What comes by default with SBS is SBS Sharepoint/Companyweb.Remove SHarepoint 80:

    http://technet.microsoft.com/en-us/library/cc288211.aspx

     

    Next if you have run psconfig and it completed successfuly then you can ignore the error that you are geeting for sharepoint when you login.It will go away in 24-48  hours.It takes up that info from event logs.

    ALso run these 2 commands from sharepoint shell and post back the output:

    (get-spserver $env:computername).NeedsUpgrade

    Repair-SPManagedAccountDeployment

    Next now that sharepoint 80 is stopped,you need to start default website and do IISRESET from an elevated command prompt.then 
    remote.companyname.com would work fine.
     

    • Proposed as answer by James XiongModerator Monday, November 14, 2011 2:35 AM
    • Unproposed as answer by AcceliT Tech Thursday, November 17, 2011 8:33 PM
    • Unproposed as answer by AcceliT Tech Thursday, November 17, 2011 8:34 PM
    • Marked as answer by AcceliT Tech Wednesday, December 28, 2011 4:21 PM
    Friday, November 11, 2011 7:15 AM

All replies

  • You need to run psconfig utility on this server.Since sharepoint was update was installed we need to complete the process by running psconfig,otherwise the Sharepoint writer may fail and will eventually cause your backup to fail as well.

    1. Open an Administrative command prompt.
    2. Change directory to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN
    3. Run PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

    http://blogs.technet.com/b/sbs/archive/2011/05/24/you-must-manually-run-psconfig-after-installing-sharepoint-2010-patches.aspx

    Then wait for 24-48 hours and the message should go away.

    http://social.technet.microsoft.com/Forums/en-US/smallbusinessserver/thread/426084b8-1450-45bf-bf3a-3865cfb0cfd5
     "AcceliT Tech" wrote in message news:b4d618d9-2453-422b-993d-dab4808e029a@communitybridge.codeplex.com...

    I would very much appreciate it if someone could help me out. I'm working with an installation of SBS 2011 Standard that I have not deployed yet but need to very soon. I followed along with the configuration wizards and successfully installed my SSL certificate. Until today the remote.companyname websites would start automatically and everything seemed fine until shortly after I ran an update for sharepoint.

    After restarting the server I received a critical sharepoint health notification as well as a window which popped up soon after logging on informing me of a need to run psconfig to complete the update. There was a reference ID and a link with directions which I followed (I believe dutifully).

    After once more restarting the server I continued to receive the same or similar messages about completing the Sharepoint update and I noticed that when running the sharepoint management page I was getting a user name and password box when clicking on various items that I never noticed before or since; I provided my admin account information in the authentication box that would pop up on the sharepoint management site but the site would freeze.

    This is the first server I have set up with Sharepoint on it and at one point I tried to add an Admin account somewhere in the Sharepoint management site when prompted to specify a user account in an effort to restore the original behavior of the Sharepoint management page. I ran psconfig as the knowledge article I was directed to described to do for a second time and ran the Sharepoint configuration wizard (more than once).

    I restarted again and all seemed to be normal once more until I realized that my Remote.companyname websites had stopped running and I couldn't start them. Each time I tried to start the stopped pages they would fail informing me another site could be using the same port.

    After a lot of trial and error I discovered that by stopping a site listed in IIS called "Sharepoint - 80" (bound to 80 not 443) the remote.companyname sites could be started manually. I was early on in the setup of the server when I had this trouble and had not yet opened IIS manager so I do not know what sites were default and necessary to 2011 server and what sites if any may have been added or changed by the Sharepoint update.

    As of now the site called 'Sharepoint - 80' is stopped. The one above it called 'SBS Sharepoint' is running, actually all the sites are currently running except 'Sharepoint - 80' and everything seems fine as far as I can tell at this time except that if the server is restarted I need to manually start the remote.companyname sites they do not start automatically.

    I don't know if it has anything to do with this but I also noticed that the 'Default Web Site' and 'Sharepoint Web Services' sites in the IIS manager have a small ? mark on there icons and if I mouse over it says "(Multiple protocols)". Not knowing if I'm even looking in the right place and hoping more info is better than less let me mention there is also 'Companyweb' site bound to 80, the 'Default Web site' site bound to 80 and 443, the 'SBS Sharepoint' site is bound to 987, 'SBS Client Deployment Applications' bound to 80, 'Sharepoint Central Administration v4' site bound to 42124, "Sharepoint Web services' bound to 32843,32844,32845 and 'WSUS Administration' site bound to 8530,8531.

    Also I don't think it's related but my 'Services Application Pool - Sharepoint Web Services DEFAULT' component in Sharepoint Credential Management currently has an admin user account associated with it. While following a health security advisory I was in there and either the component I just mentioned or the 'Services Application Pool - Sharepoint Web Services SYSTEM' component (which currently has the spfarm account associated) had an Admin account associated. I believe I returned the two components configuration to the original settings accurately after making changes but I can't recall with absolute certainty and would like to return as much as possible to how it was after the initial setup so any suggestions on that would be greatly appreciated too.

    So to summarize aside from messing with one of those 'Services Application Pool - Sharepoint Web Services' components after the fact and not being completely sure if I put it back the way it was. All I did was allow an update to run then followed the directions carefully and now I have to stop an IIS sharepoint site ('Sharepoint - 80') to even get my remote.company websites to run and I have to start the remote.companyname sites manually every time. Sorry to be so so long winded I've spent an embarrassing amount of time today beating my head against this and wanted to get it all down in the hopes somebody can guide me to a solution.

    Thanks already if you've made it all the way through this post

    Thursday, November 10, 2011 7:02 PM
  • SHarepoint 80 should be stopped....its good that it is

    So if you browse https://localhost/owa from the server what page comes up?

    If you browse https://remote.companyname.com/owa then what page comes up?

    [I am assuming default website is running[started]]

    Thursday, November 10, 2011 7:46 PM
  • I allready ran that.  I believe while following the wizzard afterward I could of caused a conflict with SBS remote sites.  It took care of the alert but now my problem is that I need to stop the 'Sharepoint - 80' site in IIS inorder to start my "remote.companyname.com" sites and those remote.company sites need to be started manualy if the machine is restarted and can't run at the same time as the 'Sharepoint - 80' site

    Thursday, November 10, 2011 7:48 PM
  • Thanks for responding Jkazama I didn't notice your post go up I'm about to read it.  I was typing away in the post edit option when it came in.  Since  I allready typed some supporting info for Mel W  (or anyone else) I'm including it here for the sake of thouroghness and My next post will be in response to yours


    I'd realy like to configure Sharepoint to as close as possible to the way it was out of the box in SBS 2011 Standard.  I have not made many changes (but I did poke around a little) and have not used Sharepoint yet for anything and may not in this deployment.  Whatever I've done so far I've tried my best to outline above.

    Is it possible that my attempt to add a Sharepoint user inorder to address the authentication logon prompts I was getting briefly on the Sharepoint management page after upgrade could of caused the port conflict with the remote.company name sites? 

    When I continued to receive the Sharepoint Health alert after running the upgrade (I didn't realize it took a day to dissapear) so I tried to check the updates on the Sharepoint management site.  When I clicked on the upgrade links on the sharepoint management site after running the upgrade I was prompted with an authentication box that I had not seen before and my Admin account credentials were not excepted. 

    In my research after the fact I realized one shouldn't use an admin account in areas of sharepoint.

    I ran the Sharepoint setup wizzard in an attempt to restore the out of box SBS sharepoint behavior and think I tried to add the Admin account when I was prompted for acount info towards the end of the wizzard. But skipped making a site.

    Subsequently I ran psconfig again and repeated the Sharepoint setup wizzard at the end of which I thought everything was back to "normal" but the url shorcut link I had previously placed on the server desktop named "Home - Central Administration" that I was using to return to the management page would not open anything anymore .  I deleted the link I had made and opened the site through "Sharepoint 2010 Central Administration" and everything appeared to have been resolved.  I could once again check updates from the management page without logon promps and I was happy untill I noticed the remote.companyname.com sites were stopped and trying to start them would fail and generate an another site could be using the same port error

     


    • Edited by AcceliT Tech Thursday, November 10, 2011 8:59 PM
    Thursday, November 10, 2011 8:56 PM
  • When I browse to https://remote.companyname.com/owa I get the Outlook Web App and when I browse to https://localhost/owa I get the Outlook Web App again but with a certificate error.

    I'm glad to hear that the 'Sharepoint - 80' site should be stopped.  Is it possible the upgrade enabled it? 

    Thursday, November 10, 2011 9:34 PM
  • Sharepoint 80 is what would have been created after running psconfig.Ideally you should remove it from central admin.You don't need it.What comes by default with SBS is SBS Sharepoint/Companyweb.Remove SHarepoint 80:

    http://technet.microsoft.com/en-us/library/cc288211.aspx

     

    Next if you have run psconfig and it completed successfuly then you can ignore the error that you are geeting for sharepoint when you login.It will go away in 24-48  hours.It takes up that info from event logs.

    ALso run these 2 commands from sharepoint shell and post back the output:

    (get-spserver $env:computername).NeedsUpgrade

    Repair-SPManagedAccountDeployment

    Next now that sharepoint 80 is stopped,you need to start default website and do IISRESET from an elevated command prompt.then 
    remote.companyname.com would work fine.
     

    • Proposed as answer by James XiongModerator Monday, November 14, 2011 2:35 AM
    • Unproposed as answer by AcceliT Tech Thursday, November 17, 2011 8:33 PM
    • Unproposed as answer by AcceliT Tech Thursday, November 17, 2011 8:34 PM
    • Marked as answer by AcceliT Tech Wednesday, December 28, 2011 4:21 PM
    Friday, November 11, 2011 7:15 AM
  • Thank you for your responses Jkazama.  Since my last post the server has been installed and I'm presently on another  project.  I have not forwarded the Remote Desktop port through the firewall so I hesitate to do anything remotely that could cause me to need to restart the  remote.companyname site seeing as it's currently my only way in.  I suppose I could open the port remotely but I am scheduled to return on wednesday morning so if you don't mind waiting I'll try your suggestions tuesday night and post an update soon after. 

    Thank you again for your time and I appologize for the delay in my response

    Monday, November 14, 2011 6:55 PM
  • I'm currently on site. 

    Yesterday I removed 'Sharepoint 80' from central admin and the associated IIS site as per the instructions you linked to, I ran the needsupgrade check and it came back "false", I ran Repair-SPManagedAccountDeployment successfully and I ran  IISRESET. 

    After restarting the server I still have to manualy enable the remote.companyname.com site from within the SBS management console.

    I appreciate the help a great deal but the need to manually enable remote.companyname sites after restart still persists.  Do you or anyone else have any  suggestions as to what to try next?

    Thursday, November 17, 2011 8:33 PM
  • When you say that you have to manually enable it,what exactly do you do?

    Does the application pool crash,or is the website stopped?

    Can you post the relevant screenshot?

    And what happens if you donot enable it manually and browse the page?
    • Edited by Jkazama Friday, November 18, 2011 8:13 AM
    Friday, November 18, 2011 8:11 AM
  • After a restart if browsed to the remote.companyname site is unavailable untill I log on as Admin and enable it.  I do so by going to SBS management console then switching to shared folders and websites selecting either the remote or owa site and clicking on enable in tasks to the right of the page then they both switch from red to green. 

     The remote sites appear to be started in IIS but are unavailable for remote connection untill I navigate to them in SBS console and enable them.

    I currently can't post a screen shot much to my surprise the remote site appears to be down.  I was onsite yesterday and made sure they were enabled before I left but they are currently unavailable.  I will be driving out to the location immediately to check on what is going on.  It's about an hour away, I'll post more as I know more

    Thanks for your continued assistance


    Friday, November 18, 2011 1:54 PM
  • If in sbs console they come as red and u enable it from there then it means the app pool is crashing.

    Do you get an error 503 when you browse?

    Check eventvwr,it should give a specific event about the site.....try to get a screenshot of apppool/iis....

    Friday, November 18, 2011 11:54 PM
  • I have looked through the event logs several times and haven't been able to choose what to take a screen cap of.  A few items have caught my eye but they do not seem to coincide with any retarts which is when I'd expect to see something relating to the Remote sites not being enabled. 

    Could you walk me through what to look for and where?  I'm going to try to go out to the site on friday if I can if not I should be there on monday at which time I plan on performing a restart soley for the purpose of causing the remote sites to stop at a specific time in an effort to make locating the occurance in the logs a little easier for me.

    Thanks again

    Tuesday, November 22, 2011 11:51 PM
  • We are looking for events in application log about an app pool failing to start.I am basing this on the assumption that one or more of the application pool fails to start.When you reboot the box,can you take screenshot of the application pools and sbs console where you see the site is not enabled?Also do check if Default website is started or not....Also check for the state of IISADMIN and WWW service from service's console.....check if they are started or not....
    • Edited by Jkazama Wednesday, November 23, 2011 11:01 AM
    • Marked as answer by James XiongModerator Tuesday, November 29, 2011 9:50 AM
    • Unmarked as answer by AcceliT Tech Thursday, December 1, 2011 1:46 AM
    Wednesday, November 23, 2011 11:00 AM
  • Hey,

    I had the exact same problem as you. The fix is actually pretty simple...

    Navigate to IIS Manager, go to the list of your websites, you should see default website, right click on it and choose advanced settings. Look at the bottom of the list and you should see an option called "automatically start" or something similiar. It is probably set to false, change it to True and start the website...

     

    I hope this helps... This problem was very frusterating. I think you are right that it is a result of the sharepoint patch that caused this greif

    • Proposed as answer by DocDavid Thursday, December 1, 2011 1:31 AM
    • Marked as answer by AcceliT Tech Monday, December 19, 2011 6:31 PM
    Thursday, December 1, 2011 1:30 AM
  • Thanks I'll check that out and post back.

    Here is the requested screen caps too. 

    Could somebody be kind enough to warn me if I have posted anything in the screen caps that could be a security concern.   I have tried to edit out anything that caught my eye as a possible concern but would not like to leave up anything I might of missed.

     

    Thursday, December 1, 2011 1:46 AM
  • Thanks for your help I do not intend to seem ungratefull by unmarking the above post as answer.  I am awaiting a return to the site to restart and do not know yet if the issue has been resolved.  I appreciate your time.  This is my first post here and I was wondering if can I mark more than one post as answer?
    Thursday, December 1, 2011 1:53 AM

  • Here is a screenshot of mine and the setting I changed. I also have the question mark on my default website
    Thursday, December 1, 2011 2:06 AM
  • Thanks CSSDave I checked and Start Automaticaly under advanced settings for Default Web Site was indeed set to false and I have changed it to true.  I am hopefull that the change will have the desired result, it sure looks like that could be it. 

    I will post back as soon as I restart the server and confirm if the Remote sites are enabled.  I'm sorry for the delay but it may be a little while before I do a restart on the server.  I want to be sure I have time to stop out at the location just incase the remote sites are not enabled when the server comes back up but I will post back as soon as I know if this has resolved my issue.  Thanks again

    Friday, December 2, 2011 9:56 PM