locked
Error saving data in custom sharepoint edit form. RRS feed

  • Question

  • I created a custom edit form for sharepoint list to avoid the content type column that gets automatically in when the list is created from a content type. Here are the steps I followed for custom editform.aspx

    1. Created copy of editform.aspx and renamed it to copyedit.aspx

    2. Inserted Custom List Form control and selected list name and form type(edit)

    3. Hid the original listform webpart.

    4. Set the copyedit.aspx as default.

    4. Can be viewed on browser without an issue.

    PROBLEM :

    When I try to edit an item and SAVE it throws Server Error in '/' Application

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

     

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="RemoteOnly"/>
      </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

     

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
      </system.web>
    </configuration>




    Thursday, March 31, 2011 5:50 PM

Answers

  • I had to delete the listform webpart that I had hidden and everything worked!
    Gayathri
    Thursday, March 31, 2011 7:09 PM