none
iSCSI Server: Can't connect to local computer

    Question

  • Hi,

    I have had iSCSI working over the VPN to backup a remote server to my EX490 running Windows Server 2012 Essentials.  However, I made the mistake of allowing access by IP instead of IQN.  I now want to remove the old target and add a new one but any operation I do with the iSCSI pane (Server Manager -> File and Storage -> iSCSI) results in the following error.  It's even the same to create new iSCSI disks.

    Both iSCSI services are running in services.  I tried removing the role and adding it back in.  I think somewhere along the line I've done something to mess iSCSI up but I can't think what it is.  Does anyone have any troubleshooting tips.  As iSCSI target server was only previously available in Storage Server I'm having trouble finding any info on the web.

    I did trick my initiator into getting on the old IP address and we had a successful connection but trying to do anything on the local (WS2012e) server results in cannot connect to the computer.  Did I disassociate WINRM or something?

    Cheers,

    Al


    -- Free AV for WHSv1 : http://whsclamav.sourceforge.net/ ---- The add-in won't work on WHS 2011/2


    • Edited by Al West Thursday, January 10, 2013 5:35 PM
    Thursday, January 10, 2013 5:34 PM

Answers

  • Looks like running sfc /scannow can really mess up your system.

    Never Run sfc  on a Windows Server 2012 Essentials machine - should be disabled or inhibited by default I think :-(


    -- Free AV for WHSv1 : http://whsclamav.sourceforge.net/ ---- The add-in won't work on WHS 2011/2

    • Marked as answer by Al West Friday, January 11, 2013 11:44 AM
    Friday, January 11, 2013 11:43 AM

All replies

  • I've had a search around in Event Viewer and nothing jumps out as being wrong.  However when I run a Administrator PS I get the following error:

    PS C:\Windows\system32> New-IscsiVirtualDisk C:\iSCSIVirtualDisks\backup.vhd  –size 40GB
    New-IscsiVirtualDisk : Unable to connect to the computer.
    At line:1 char:1
    + New-IscsiVirtualDisk C:\iSCSIVirtualDisks\backup.vhd  –size 40GB
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (Microsoft.Iscsi...rd errorRecord):IscsiCmdException) [New-IscsiVirtualDisk], IscsiCmdException
        + FullyQualifiedErrorId : Utility_ConnectionScopeInvalidComputerName,Microsoft.Iscsi.Target.Commands.NewIscsiVirtualDiskCommand
     

    Looks like it doesn't like the computer name.  However the hostname resolves to the IP address.

    Bingin and Googling for the error reveals nothing close.  Any pointers?  Thanks,

    Al


    -- Free AV for WHSv1 : http://whsclamav.sourceforge.net/ ---- The add-in won't work on WHS 2011/2

    Thursday, January 10, 2013 10:25 PM
  • Looks like running sfc /scannow can really mess up your system.

    Never Run sfc  on a Windows Server 2012 Essentials machine - should be disabled or inhibited by default I think :-(


    -- Free AV for WHSv1 : http://whsclamav.sourceforge.net/ ---- The add-in won't work on WHS 2011/2

    • Marked as answer by Al West Friday, January 11, 2013 11:44 AM
    Friday, January 11, 2013 11:43 AM
  • Actually tried the same thing on an Azure 2012 VM and have the same issue with iSCSI.  For now I am using StarWind free iSCSI Target Server and it's working well for me.


    -- Free AV for WHSv1 : http://whsclamav.sourceforge.net/ ---- The add-in won't work on WHS 2011/2

    Sunday, January 13, 2013 9:41 PM
  • Apparenly the iSCSI server in the server manager wants to know the computer name. I haven't figured out how to set it for the system manager, but the New-IscsiVirtualDisk command in PS works if you add the argument -computername

    New-IscsiVirtualDisk C:\iSCSIVirtualDisks\backup.vhd –size 40GB -computername <machine.domain.com>

    I was able to make my iscsi target work by setting it up in PS and by adding computername for each command.

    --------

    Update:

    I was able to set up iSCSI target from Server Manager after i removed the server from my domain. I did a fresh install and didn't join the domain, and it worked.

    • Edited by ismo_ Thursday, March 14, 2013 10:20 AM
    • Proposed as answer by ismo_ Friday, March 15, 2013 7:54 AM
    Wednesday, March 13, 2013 12:13 PM
  • All,

    we ran into the same issue as you - after spending a lot of time together with Microsoft (thanks to Bernd), we were albe to find the root cause of this issue.

    I'm sure, you have a domain name or a computer name with only one label. :-) This is a bug in the iSCSI-Powershell command.

    Please take notice of the released hotfix in KB2953557 (http://support.microsoft.com/kb/2953557/en-us) and install the hotfix on your server.

    Cheers,

    Tom

    • Proposed as answer by JImya Friday, August 1, 2014 11:41 PM
    Wednesday, May 14, 2014 2:32 PM
  • All,

    we ran into the same issue as you - after spending a lot of time together with Microsoft (thanks to Bernd), we were albe to find the root cause of this issue.

    I'm sure, you have a domain name or a computer name with only one label. :-) This is a bug in the iSCSI-Powershell command.

    Please take notice of the released hotfix in KB2953557 (http://support.microsoft.com/kb/2953557/en-us) and install the hotfix on your server.

    Cheers,

    Tom
    Wednesday, May 14, 2014 2:33 PM
  • This was the issue the solution for my issue. Many thanks for updating this thread with this gem. I had two servers with this issue and it was driving me nuts. I actually installed another virtualized box just to provide iscsi services. Now it works like a charm and  I don't need the extra server.
    Friday, August 1, 2014 11:40 PM
  • The hotfix in KB2953557 did'not hehp for me.

    I can not assign iscsi disk or remove it. Error "Unable to connect to the computer"

    Friday, June 3, 2016 9:53 AM
  • The hotfix in KB2953557 did'not hehp for me.

    I can not assign iscsi disk or remove it. Error "Unable to connect to the computer"

    Resolve when change name server "Server" - to another :)

    no words...

    • Proposed as answer by JedieRU Tuesday, January 2, 2018 8:54 PM
    Thursday, June 9, 2016 8:28 AM
  • WHAT THE HELL!!!

    been hitting my head against this issue for days!

    my server was called "server" and this stopped the gui working.

    renamed server to Oserver and it worked.

    thanks MS - what total crap!

    @SergIT - THANKYOU!!!! 

    Saturday, July 8, 2017 10:51 AM
  • Same problem on Windows Server 2016. Just renamed my "SERVER" and that's works!
    Tuesday, January 2, 2018 8:54 PM
  • I know this thread has been around for a while, but I just found out that the same issue occurs if the server's name exceeds the NetBIOS 15-character limit. Change the name to something 15 characters or less, and magically everything works.

    This is yet another of the innumerable situations in which a detailed error message would really speed up troubleshooting. Heck, even "Unable to connect to computer <name>" would be better than what it shows now.

    Thursday, June 14, 2018 5:55 PM