Unable to connect to VMs with console


  • Hi there,

    I have a problem with connecting to my VMs using the console. I get this error " The Connection was lost due to a network error...." error code 0x0404, 0x0000.

    I'm using SCVMM 2012 SP1.  This error comes instantly, so it's not timing out. If I connect to the Hyper-V host with the Hyper-V Manager, it works flawless. Any ideas on how to fix this?


    Monday, January 14, 2013 3:14 PM

All replies

  • Can you verify which port you are using on your Hyper-V servers for vmconnect.exe? the default port should be 2179, and is located on the 'host access' tab on the properties of the host.

    are these VMs connected to a virtual network or vmnetwork?

    Kristian (Virtualization and some coffee: )

    Monday, January 14, 2013 5:31 PM
  • The port is 2179. The VMs is connected to a vmnetwork.


    Wednesday, January 16, 2013 8:19 AM
  • I've the same error.

    Did you find the solution?


    Thursday, September 12, 2013 3:27 PM

  • I had the same issue. I was using the VMM console locally on my laptop and trying to connect to the console screen of virtual machines, located on Hyper-V cluster managed by a VMM server.


    The solution for me was, to run the VMM console as a different user, specifying my credentials and in the Connect to Server window,  specifying Use current Microsoft Windows session identitiy option.

    And then I could connect to consoles of the virtual machines.



    • Edited by Ramon Bruin Tuesday, October 15, 2013 8:51 AM
    Tuesday, October 15, 2013 8:40 AM
  • I noticed a similiar error when setting roles.

    I solved it by changing Clouds for the VMs once, then back again.

    After this the user could connect with console.

    I guess it might have something to do with the database, but havent looked into it more.

    Tuesday, October 15, 2013 12:57 PM