none
SharePoint Online Management Shell does not run

    Question

  • I have a tenant admin who cannot get the SharePoint Online Management Shell to run.

    The user is running Windows 10. When they first run the management shell it gives the The specified module was not loaded exception. When the shell is run again as an administrator, it does not display any output (see image below). After this, no matter whether the shell is run as an administrator or not, the blank console is all we see.

    They downloaded the installer from here: SharePoint Online Management Shell. We have tried both the 4915-1200 and 5111-1200 (x64) versions. When you attempt to uninstall it hangs and doesn't respond.

    I haven't been able to find a fix, and reinstalling doesn't appear to resolve the issue.

    Is there something else we can try to resolve this?

    Wednesday, April 6, 2016 5:46 PM

All replies

  • I've seen some oddities on some Windows 10 machines, this one i'm on refuses to play ball with SPO. I wish I had a solution but i ended up using my Dev VM to run my scripts instead.

    Check to see if the dll has actually been installed to the system, it may be present but unidentified.

    Wednesday, April 6, 2016 6:57 PM
  • Me too, also on Windows 10. I'm also curious what the difference is between the 4915 version and the 5111 version here, https://www.microsoft.com/en-us/download/details.aspx?id=35588. I've see multiple versions in other MS downloads with no explanation. Not sure if I'm missing some rule of thumb.
    Friday, April 22, 2016 4:32 PM
  • I've tried both of them with the same results.  I see in the details that Windows 8 & Server 2012 are the latest OS versions supported.  Would be good to get this to work on the 200+ million Windows 10 devices.

    Tuesday, April 26, 2016 4:05 PM
  • In my case I attempted to "Repair" 5111 (looks like there's now a 5214 instead of 5111) from Programs and Features, but this resulted in the installer hanging until reboot. I then uninstalled 5111 and installed 4915, and that is working for me.

    Wednesday, April 27, 2016 4:06 PM
  • I experienced this behavior also and found I could not run the shell in non-administrative context even using "Run as Administrator" and using juiced creds. The only way the shell would launch is to log into the box with admin rights. Once I did that the shell runs fine.
    Monday, May 2, 2016 7:24 PM