locked
can not open .xlsx files. Always asking login. RRS feed

  • Question

  • Hi,

    Everytime I open a .xlsx file in the browser, the login screen popup and won't take my domain ID&PW. And after click OK three times, an error message popup "An error has occurred trying to perform the requested action. Please try again". I have no problem with other office format like .doc .docx .ppt.

    The server is Sharepoint 2010 foundation with Office Web Apps. The client is Windows XP sp2 with IE7.

    Please help me with the issue and thanks in advance.

    • Moved by Mike Walsh FIN Tuesday, June 28, 2011 7:24 PM SP 2010 admin q so doubly off-topic (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, June 28, 2011 2:59 PM

Answers

  • Hi all,

    Finally I resolved the issue by disconnect the server from server farm and reconnect it.

    Thank you all.

    Hao

    • Marked as answer by Hao555 Tuesday, August 9, 2011 7:38 PM
    Tuesday, August 9, 2011 7:38 PM

All replies

  • Are you logged into SP with the same account you log into your PC with?

    When you log into your machine, you communicate that login to MS Office. If you log into SP with a different account and try to open an Office file you can run into a conflict.

    Add the site as a "Trusted Site". If that doesn't work, and Passthrough authentication isn't an option, I'd save the .xlsx to your desktop, and open from there.

    Tuesday, June 28, 2011 4:48 PM
  • I am using the same account and I have tried to add the site as a Trusted Site but no lucky.

    Thanks for your reply.

    Thursday, June 30, 2011 7:34 PM
  • The only zone that will automatically pass your credentials is the Intranet Zone.  Put the site in the Intranet Zone and try again.
    http://sharepoint.nauplius.net
    Thursday, June 30, 2011 7:54 PM
  • I did add it into Intranet Zone but didn't work.

    When I open a .xlsx file in the browser, I can see the worksheet name on the bottom and then the login windows popup. Even I type in the ID and PW, the windows still keeps in popup. Again, no problem with other format( .doc, .docx and .ppt).

    I am thinking about if there something wrong in server side especially excel services.

    thanks for your reply.

    Thursday, June 30, 2011 9:15 PM
  • Hao555,

    Have you tried this on another machine? is this an issue for other users?

    As an experiment, might also want to try downloading Microsoft Office Excel Viewer.

    Tuesday, July 5, 2011 3:10 PM
  • You probably need to download Netmon and do a network trace to see what is happening.

    But prior to that you need to get up to a supported version of your OS.  XP SP2 is not supported.  You should apply service pack 3 for XP and then try it again.

    -Aseem

     


    This posting is provided "AS IS" with no warranties, and confers no rights
    Tuesday, July 5, 2011 6:43 PM
  • Are you having this issue even with a new XLSX document, or just existing ones?  Reason I ask is because it is possible that an existing XLSX doc could have a reference to another site which is causing the login prompts.
    http://sharepoint.nauplius.net
    Tuesday, July 5, 2011 7:18 PM
  • You may also want to check the SharePoint server (WFE) security event logs for errors. Make sure logon auditing is turned on (under Local Security Policy in Windows). I've seen this problem when SharePoint is expecting NTLMv2 authentication protocol but the client only sends NTLM (version 1).
    Wahid Saleemi Sr. Consultant, Avanade http://www.wahidsaleemi.com
    Wednesday, July 6, 2011 4:02 AM
  • Hi Aseem,

    I will do the trace you suggested.

    I try to do the same thing in Windows 7 host and still get the same error.

    Thanks for your reply.

    Hao

    Friday, July 8, 2011 7:14 PM
  • Hi Trevor,

    a new XLSX doc....Do you mean open a new xlsx doc in browser? I can only open a docx document in browser.

    Thanks for your reply

    Hao

    Friday, July 8, 2011 7:17 PM
  • Hi,

    SharePoint 2010 utilizes this enhanced security feature in IE 8 to block the opening of file types it considers vulnerable to scripting or other attacks, such as PDFs.   You can modify SharePoint's behavior by changing the Browser File Handling option in the Web Application General Settings of SharePoint 2010.   Your options are permissive and strict, with strict being the default. Change it to permissive and try again.


    Regards

    Henrik A. Halmstrand
    http:/www.sharepointrevealed.com
    http://getspconfig.codeplex.com
    Friday, July 8, 2011 8:57 PM
  • Hi Henrik,

    I did change the setting to  permissive and the problem is still the same.

    Thanks for your reply.

    Hao

    Monday, July 11, 2011 2:08 PM
  • Have you tried IISreset after the change?

     


    Regards

    Henrik A. Halmstrand
    http:/www.sharepointrevealed.com
    http://getspconfig.codeplex.com
    Monday, July 11, 2011 4:29 PM
  • Yes, I restart IIS after every change.

    After change to Permissive, I can open PDF files directly so I think the change has been applied. But the issue is still there.

     

    Tuesday, July 12, 2011 7:23 PM
  • Hi all,

    Finally I resolved the issue by disconnect the server from server farm and reconnect it.

    Thank you all.

    Hao

    • Marked as answer by Hao555 Tuesday, August 9, 2011 7:38 PM
    Tuesday, August 9, 2011 7:38 PM