locked
Windows 7 Permissions RRS feed

  • Question

  • I wondered if anyone has figured out a solution for this problem? I installed Windows 7 64-bit Professional Edition and I also have 2 other Internal Hard Drives that show up just fine in Windows 7. But when I try to copy any files from those two hard drives it gives me a message saying "you must have administrator permission" to copy this file. I do have Administrator Privileges and also did try to share those drives and also did use the Home Group to try to do it that way. But nothing worked, why is that message coming up and how do I fix that Please?
    • Moved by Carey FrischMVP Thursday, July 7, 2011 12:31 AM Moved to more appropriate forum category (From:Windows 7 Miscellaneous)
    Wednesday, July 6, 2011 11:56 PM

Answers

  • Hi,

     

    I would like to confirm the following details:

     

    1.       Do you copy these files to other network drives? If so, can you access the destination network drives?

    2.       Can you copy files from the two drives to external drives?

     

    Currently, try to boot into Safe Mode to check how it works.

     

    For a test, make sure that you provided the Full-Control permissions of both Sharing and Security settings to Everyone for the  folders. Then check the result.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Monday, July 18, 2011 5:52 AM
    Friday, July 8, 2011 5:48 AM
  • You need to read up on User Account Control.  Normally you're not running with Administrator privileges - just lowly user privileges.  You can start Explorer with "Run As Administrator", but that might not get you any further.

    Let me guess...  Were these hard drives formatted on another version or install of Windows?

    If so, they were created by a different user (even if you used the same username) and you'll need to take ownership of all the folders and files.  That may be enough, though you may also have to set permissions on the files and folders for your username so that you'll have the access you need to them.

    -Noel


    • Marked as answer by Cloud_TS Monday, July 18, 2011 5:52 AM
    Sunday, July 10, 2011 11:07 PM

All replies

  • Hi,

     

    I would like to confirm the following details:

     

    1.       Do you copy these files to other network drives? If so, can you access the destination network drives?

    2.       Can you copy files from the two drives to external drives?

     

    Currently, try to boot into Safe Mode to check how it works.

     

    For a test, make sure that you provided the Full-Control permissions of both Sharing and Security settings to Everyone for the  folders. Then check the result.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Monday, July 18, 2011 5:52 AM
    Friday, July 8, 2011 5:48 AM
  • You need to read up on User Account Control.  Normally you're not running with Administrator privileges - just lowly user privileges.  You can start Explorer with "Run As Administrator", but that might not get you any further.

    Let me guess...  Were these hard drives formatted on another version or install of Windows?

    If so, they were created by a different user (even if you used the same username) and you'll need to take ownership of all the folders and files.  That may be enough, though you may also have to set permissions on the files and folders for your username so that you'll have the access you need to them.

    -Noel


    • Marked as answer by Cloud_TS Monday, July 18, 2011 5:52 AM
    Sunday, July 10, 2011 11:07 PM