Failing full client restore, error in ClientRestoreWizard_Fresh.exe 0xc0000025 RRS feed

  • Question

  • I am attempting to restore a Win7/64 machine using the SBS 2011 Essentials client restore disk. Partially through the restore I always receive the following message:


    ClientRestoreWizard_Fresh.exe - Application Error

    The exception Cannot Continue

    Windows cannot continue from this exception

    (0xc0000025) occurred in the application at location 0xff2c5b48

    Click on OK to terminate the program


    I have tried restoring 3 times from three different backups and receive the same message every time.


    Please help, thanks!

    Wednesday, August 17, 2011 3:55 AM

All replies

  • I'm in the same boat.  Tried about 5 times, with the same error you are getting. 

    Did you get any other errors, coming up to this event?  Earlier, after booting from restore key (or CD), I got this error as well, "The server cannot refresh the Full System Restore Wizard.  Either your server is not compatible with this version of the Full System Restore Wizard, or another problem is preventing the server from responding.  Make sure that the most recent updates are installed on the server, and then try again."



    Sunday, September 18, 2011 6:54 AM
  • Same error here, using USB key created from the server itself from the Dashboard, Computers and backup tab, selecting "additional client computer backup tasks", "tools" and then creating a recover USB key.

    Same error for the PC restore CDs made from:

    The system with the issue is a ThinkPad W520, with the BIOS 1.30 at factory defaults (AHCI SATA internal drive).  This same boot media works fine on other systems in my home.  Here's the exact error message:

    RestoreCDInit.exe - Application Error
    The exception Cannot Continue
    Windows cannot continue from this exception.
    (0xc0000025) occured in the application at location 0xff43b477.
    Click on OK to terminate the program


    Friday, September 30, 2011 3:57 AM
  • I too am getting the same error.  RestoreCDInit.exe Setup cannot continue.

    I just created my USB key from Home Server 2011, all latest updates applied.  My HTPC PC has become currupted so booting from USB produced this error.  Core i5 on a  / AHCI SSD disk.

    Im wondering if the fault is anything to do with AHCI as the previous poster has a simular setup.  Could be driver related.

    Saturday, October 8, 2011 8:56 PM
  • Cracked it.  I found it to be boot related.  I tested the USB stick in another PC and it worked perfectly.  When i boot from USB pen im given 2 options.

    1 is USB...<my usb pen name>

    2 is UEFI USB <my usb pen name>

    Booting from UEFI fixed the problem and the program ran ok.  Loaded my NIC drivers and hey presto the restore kicked off.

    Very strange but at least its a solution.  Hope it helps everybody out there.


    Sunday, October 9, 2011 11:40 AM
  • I was never able to fully restore the client to a new hard drive.  However, the old hard drive was not failing as yet (just getting errors in both the backup and disk test analyzers).  I did a full backup using the Vista backup/restore programs, and was able to fully restore the computer to the new hard drive.


    If its any consolation, WHS appears to be backing up correctly.  I was able to restore other backups - no problems - to a usb-hard drive enclosure.  Something unique about this system, might have been it was a VISTA machine that was upgraded to Windows 7 (i had restored the machine prior, when it was in Vista, so...) - there might be some issue with the way the disks are setup on a Vista-upgraded to Windows 7 hard disk that is confusing WHS.


    Also, when I looked at the disk after the failed restore message, the data WAS there, so again, it could have been having a problem setting up the active disk and/or getting the boot sector right... Not sure - problem solved (for now - and don't have the energy to repeat (wife's machine!) at this time...


    In the interim, probably monthly, I'll be doing a Windows 7 backup to my server of her machine (just in case) until we have a real resolution to this problem.


    ALL - please note this problem is not associated with setting up the Key, getting NIC cards installed correctly, etc.  Note in both the OP and my laptop's instances, the restore almost completes, then fails.




    Friday, October 14, 2011 4:38 AM
  • Is installed on the server and clients?
    Friday, October 14, 2011 8:17 AM
  • Update Rollup 1 you mean......yes it was in my case.
    Sunday, October 16, 2011 6:41 AM
  • Whilst slightly off topic.  I am posting here as I believe SBS Essentials and WHS2011 use the same methods to restore clients.

    I have seen the same error message when trying a client restore against my WHS2011.

    My WHS2011 is hosted on Hyper-V.  Therefore, I cannot use the WHS create recovery USB stick as Hyper-V does not allow USB pass-through to the host ports.

    I downloaded the WHS recovery iso image from my Technet subscription and added the boot.wim image from the recovery disk to my WDS server to try network booting the recovery CD as I used to with WHS 1.

    I get the same error message you see, RestoreCDInit.exe - Application error (0xc0000025) when network booting to a x86 laptop, and to a clean x64 hyper-v child created purely to test the Boot image.

    As the same message is appearing on virtual machines and physical machines, I think the fault does not link to AHCI but how the recovery disk is crafted to hand over to the Recovery Wizard post boot.

    If I boot the hyper-V child with the iso image, the Recovery Wizard runs correctly.

    Wednesday, October 19, 2011 11:34 PM
  • I have WHS 2011, and SBS essentials is not a Windows Update option for me.



    Friday, January 27, 2012 12:36 PM
  • I am attempting to restore a Win7/64 machine using the SBS 2011 Essentials client restore disk. Partially through the restore I always receive the following message:

    ClientRestoreWizard_Fresh.exe - Application Error

    The exception Cannot Continue

    Windows cannot continue from this exception

    (0xc0000025) occurred in the application at location 0xff2c5b48

    Click on OK to terminate the program

    I have tried restoring 3 times from three different backups and receive the same message every time.

    Please help, thanks!

    I am seeing the same thing. Client disk is wearing out so I'm replacing it. Client and SBS 2011 Essentials are both at current patch level. Did a client backup, swapped in the new boot disk on the client, booted from the SBS 2011 Essentials Client Restore CD and began the client restore, got 3/4 restored, and then the restore crashed with ClientRestoreWizard_Fresh.exe Application Error "Windows cannot continue from this exception (0x0000025) occurred in the application location 0x00085893".

    Has anyone at Microsoft tested client restores from the CD to see if they work? Has anyone from Microsoft replied to this 8 month old posting? Does anyone at Microsoft support SBS 2011 Essentials?

    Steve Jumonville

    Wednesday, May 9, 2012 3:59 AM
  • Whenever I get an error part way through the restore I end up connecting the PC directly to the server and it goes through.  You either have to set both to good staic ip's or set both to use dhcp and reboot both.


    Sunday, May 13, 2012 9:12 PM
  • I finally got a good restore on my 3rd attempt. I don't run into network problems like this when my clients use Acronis ... just saying is all ...

    Steve Jumonville

    Sunday, May 13, 2012 11:07 PM
  • I take it back, I didn't get a good restore. The restore completed, but the system won't boot ... it hangs at the BIOS.

    If automated backups is supposed to be a selling point of SBS 2011 Essentials ... then maybe Microsoft should consider making the backups usable. Just saying is all ...

    Steve Jumonville

    Tuesday, May 22, 2012 9:46 PM
  • Agreed,

    I'm still fighting this. I've tried for 8 months, (seriously on and off) to try to restore. In the end I ended up breaking down and just reinstlaling and using the backed up files form my WHS to recover my user data directory and what not. 

    I have a ASUS p8p67 which has probably the worlds most primitive and horrible UEFI system. I work in the encryption field and work with BIOS's/UEFI/WINPE ALL the time and I still for the life of me CANNOT restore my WHS backups!

    If I try to boot form the USB key that is generated form the WHS, I get 0xc0000025 error immediately after WINPE boots before you even get to load the extra drivers. 

    If I use the CD/DVD I get a little further, i was able get to the recovery portion, to select drivers at which point it found them on my USB key, continued to the BMR (bear metal recovery) options and deselected my data drive so I would just restore my boot disk. Well as that was about to start I got..... Wait for it... 0xc000025.... @OI##*@)(*&#(@)*#&() 

    If that wasn't enough I then broke down and decided I'd do a PAID MS call for this and tried at 4:00 PST to get a hold of someone. Well 14 transfers later and 5 hours later I ended up on hold to be transferred to the team that supported this. (was told this 4 hours ago)

    Well my story did not end there, because I was hung up on as 9:00 PM is when their call center closes so of course even though I was on hold I was dropped. So I MAY or MAY not try again tomorrow. 

    The sick part at one point in my life I actually worked as a Enterprise Platforms Support engineer (EPS) in the Microsoft support arena. I never realized just how crap end user support has become. 

    Anyways, this is my cry for help! I also know that this issue with the USB is not specific to my Desktop as my T420 lenovo exhibits the exact same behavior when I try to boot form the WHS recovery disk which is on a USB. Which is also backed up by this sever. 

    Wednesday, October 2, 2013 5:45 AM
  • You have to have this hotfix for uefi.  It does not come in windows updates

    You  have to install the hot fix and make a thumb.  The cd will not be updated with the hotfix and will not work


    Wednesday, October 2, 2013 1:16 PM
  • Thanks for the link, but the UEFI update didn't work for me. 

    Since my machine was not using UEFI anyways, although there is options for UEFI on the motherboard, I installed using old bios style MBR. 

    So MS support was a dead end. They don't support WHS what so ever period they said it's up to the vendor.

    I believe I have figured out the problem of my issue. I believe it relates to the fact that I had the data on my on my boot disk and that drive pooched and even though I had back ups some of it was corrupt. 

    • Edited by zazzn Saturday, October 5, 2013 7:47 AM
    Wednesday, October 2, 2013 11:04 PM

    So HAPPY! 


    Ok here's the rundown of issues / fixes


    Issue #1 - WHS boot disk died

    -WHS boot disk fail

    -Restore WHS/install new disk


    issue #2 - BMR restore issue were couldn't boot from 

    -USB created from dashboard did not work error given during boot 0xc000025

    -Created recovery CD from the ISO from MSDN also ripped it to USB, was able to start recovery correctly


    Issue #3 - Corrupt DB

    -During BMR restore, only 2 backup's listed due to unknown issue guessing corruption in DB

    -Restoring OS partition, and Secondary disk successful (wiped secondary disk by accident somewhere along the way)

    -Unable to restore "System reserve" 0xc000025 during restore probably due to corrupt database.


    Issue #4 - Unable to boot

    -System reserve had to be recreated by using bootrec /rebulidos

    -Once bootrec fixed my MBR issues, could not boot due to corrupt IaStorA.sys driver

    -Booted to recovery console/command prompt replaced the driver with the one form my laptop which was core i7 snadybridge as well, but did not work. Kept BSODing and starting recovery console.

    -Obtained intel F6 boot disk driver ripped IaStorA.sys and IaStorV.sys and replaced the drives in the D:\windows\system32\drivers dir


    Issue #5 - Secondary drive (winXP) could not boot after recovrey

    -Don't know yet, but believed to be MBR issue 


    Other issues

    Wiped, my secondary disk were all the data was stored, not sure if the recovered data form WHS is valid since so not sure of the integrity of my personal data. 

    BMR is not just re-imaging the disk, WHS replaces some of the drivers, in which case, is why I believe my XP will not boot (since I used 64 bit os recovery and it's 32). On the WIN7 I believe it used updated F6 drivers and replaced the IaStorA.sys with a newer version which does not work or some other issues. 


    Bottom line, I've had WHS for almost 1.5 years and in that time it has failed me miserably.


    -DB integrity checks more regularly 

    -Access to backed up data though dashboard even if it's not form the computer the backup was created from, so that if BMR does not work you can at least restore parts of data that could be useful, or you can manually restore since the automated system has too many issues to work out still.

    -Access to mount and directory manipulate the DAT files some how to extract data if parts of the DB are corrupted if possible. 

    *Future versions (maybe 2012 essentials) Skydrive integration


    I think the worst part of this ordeal other than the time wasted for silly reasons is the fact that MS does not support this product and they push it on the vendors who are utterly useless themselves.


    I think i'm going to move to another solution for my backup's since this failure was just too horrendous. 

    Saturday, October 5, 2013 11:49 PM
  • Addes USB 3 drivers to the sources/boot.wim file using these instructions

    USB key booted normally

    Monday, April 17, 2017 9:41 PM
  • I know that this is an old thread, but I just ran into this problem and eventually solved it. (Thanks to the post by @richsmif for giving me a clue as to what was going wrong!) Maybe my experience will help others who are still trying to keep a WHS 2011 server functional. Also, by posting it here, I'll be able to find it again in the future.

    I had the UEFI / GPT hotfix installed on my WHS 2011 server and created a Full System Restore USB key and then added the appropriate "Drivers for a Full Restore" to the same USB. Booting with the full system restore USB would reach the point of "installing Windows" and then fail with the "RestoreCDInit.exe - Application Error" message.

    After trying many unsuccessful changes over the course of a few days, I finally stumbled onto this: In my BIOS, I found a setting that allowed for booting in various modes. It was set to "Legacy" only. I changed it to "UEFI and Legacy". On the next reboot with the boot USB, a new option appeared: "Sandisk UEFI". (Previously, only "Sandisk" was available.) I chose the "Sandisk UEFI" boot device and the full system restore proceeded normally.
    Wednesday, May 22, 2019 3:33 PM